Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help



Go Back   PeachParts Mercedes-Benz Forum > Search Forums

Showing results 1 to 30 of 500
Search took 0.11 seconds.
Search: Posts Made By: lee polowczuk
Forum: Diesel Discussion 12-18-2019, 06:56 PM
Replies: 2
Views: 229
Posted By lee polowczuk
w124 300d fair price

What would be the going price for a 1993 model with 210k.

Owner is asking 3900, I was thinking closer to 3k

Car is in very good condition Black.Palomino Tex
Forum: Tech Help 08-31-2019, 05:34 PM
Replies: 22
Views: 884
Posted By lee polowczuk
I am getting blink code 8

I am getting blink code 8
Forum: Tech Help 08-26-2019, 05:43 PM
Replies: 22
Views: 884
Posted By lee polowczuk
Great suggestion, I will try that....

Great suggestion, I will try that....
Forum: Tech Help 08-26-2019, 05:42 PM
Replies: 22
Views: 884
Posted By lee polowczuk
I have been so busy, that I haven't had the time...

I have been so busy, that I haven't had the time yet.... but it's pretty hard to get them wrong..

It is possible that they may not be on properly.
Forum: Tech Help 08-20-2019, 07:04 PM
Replies: 22
Views: 884
Posted By lee polowczuk
I had lost my code reader...got a new one... ...

I had lost my code reader...got a new one...

I will get to the bottom of it this weekend and report back....
Forum: Tech Help 08-15-2019, 07:20 PM
Replies: 22
Views: 884
Posted By lee polowczuk
I am starting to think that you are right.... I...

I am starting to think that you are right.... I am convinced the plugs are fine, but I might change them anyway....

I might not have the coil packs properly seated...although it seems like this...
Forum: Tech Help 08-10-2019, 02:00 PM
Replies: 22
Views: 884
Posted By lee polowczuk
MAF plugged in

MAF plugged in
Forum: Tech Help 08-10-2019, 01:58 PM
Replies: 22
Views: 884
Posted By lee polowczuk
Plugs are correct... only about 15 k on them......

Plugs are correct... only about 15 k on them... still trying to figure out if I damaged the wiring. Harness. I have a new old stock one on the shelf... I believe mine is original, but I canít seem...
Forum: Tech Help 08-05-2019, 04:39 PM
Replies: 22
Views: 884
Posted By lee polowczuk
hmmm ....didn't think of that.... could that...

hmmm ....didn't think of that.... could that have happened after the job when i restarted the car and all the blue smoke came out the tail pipe?

I guess what is confusing me... is that when I put...
Forum: Tech Help 08-05-2019, 11:02 AM
Replies: 22
Views: 884
Posted By lee polowczuk
M104 no power

I will try to make this brief. I had oil in my spark plug wells which caused an occasional miss. Decided to change out the o-ring gaskets (6) and valve cover gasket.

Took out oil soaked spark...
Forum: Tech Help 11-21-2017, 05:34 PM
Replies: 8
Views: 771
Posted By lee polowczuk
I changed out my 722.6 transmission with MaxLife....

I changed out my 722.6 transmission with MaxLife. it's a 97 s320. Made the change at 118k... now has 158k on the clock. Probably should drain it again soon....
Forum: Tech Help 11-20-2017, 02:22 PM
Replies: 1
Views: 361
Posted By lee polowczuk
W124 Front caliper frozen

Had to hit my brakes hard... ABS light came on.... got to location, when I restarted car, ABS light goes off.

However my front right brake caliper froze in the open position...

I will probably...
Forum: Tech Help 09-27-2017, 05:00 PM
Replies: 16
Views: 1,168
Posted By lee polowczuk
I will keep the board posted. I went out and...

I will keep the board posted. I went out and started it last night.... starts right up.... I rarely drive the car...but now that I think about it... I think the old battery was giving a somewhat...
Forum: Tech Help 09-26-2017, 01:00 AM
Replies: 33
Views: 20,565
Posted By lee polowczuk
have used Max Life in multiple cars over multiple...

have used Max Life in multiple cars over multiple years.... no problem. I change fluid and filters about every 35-45k... i know that's a wide range...the fluid always looks good coming out..... the...
Forum: Tech Help 09-26-2017, 12:41 AM
Replies: 16
Views: 1,168
Posted By lee polowczuk
To sl320

Blown away. I have owned a 108. And a 140. With 4 or 5 124's in between. I tried my wife's key in her car and it started right up. No one anywhere in the Internet offered your suggestion. ...
Forum: Tech Help 09-25-2017, 02:40 PM
Replies: 16
Views: 1,168
Posted By lee polowczuk
i have at least two other keys... my wife's and...

i have at least two other keys... my wife's and another spare. I will try tonight.

If this works..it is valuable info. I have tried to search this as an issue..and no one else seems to have had...
Forum: Tech Help 09-25-2017, 12:58 PM
Replies: 16
Views: 1,168
Posted By lee polowczuk
I will try another key....didn't know that... ...

I will try another key....didn't know that... Key is standard with no chip. I will try another. It did briefly cross my mind that the security system may have been compromised.
Forum: Tech Help 09-25-2017, 10:01 AM
Replies: 16
Views: 1,168
Posted By lee polowczuk
Fuel pump relay is silver. Went to the boneyard...

Fuel pump relay is silver. Went to the boneyard and got two. No luck.

Let's see if I can clarify. Battery was low when I first started. As I Started it , it was dying. Ac panel went from off...
Forum: Tech Help 09-24-2017, 03:51 PM
Replies: 16
Views: 1,168
Posted By lee polowczuk
oops sixto you were right...it's buried in the...

oops sixto you were right...it's buried in the fuse panel
Forum: Tech Help 09-24-2017, 03:49 PM
Replies: 16
Views: 1,168
Posted By lee polowczuk
thanks... CPS would be an easy fix... actually...

thanks... CPS would be an easy fix... actually I have fuel pumps too.... but it's Sunday... and I just don't have the time like I used to..

There is a trunk fuse panel above the battery...but...
Forum: Tech Help 09-24-2017, 02:46 PM
Replies: 16
Views: 1,168
Posted By lee polowczuk
no codes... not sure if i can hear the pumps or...

no codes... not sure if i can hear the pumps or not...

i haven't checked for spark.... but i can't imagine that all of a sudden i have that problem.

i am not sure if this car has a fuel pump...
Forum: Tech Help 09-24-2017, 02:21 PM
Replies: 16
Views: 1,168
Posted By lee polowczuk
1997 s320 cranks, won't start. Fuel pump relay?

m104 engine.

it appears you can buy a fuel pump relay for this car... but I don't know where it is located. does the car actually have a fuel pump relay?

fuel pump fuse is fine.
Forum: Tech Help 01-19-2017, 04:43 PM
Replies: 11
Views: 877
Posted By lee polowczuk
Maybe I should clarify.. The balance weight...

Maybe I should clarify..

The balance weight was getting hung up on tensioner bracker...

Both pulleys were identical except for one thing: The one on the power steering pump had two "weights"...
Forum: Tech Help 01-19-2017, 04:40 PM
Replies: 11
Views: 877
Posted By lee polowczuk
Went to install Laso..and that's the one I had an...

Went to install Laso..and that's the one I had an original problem with.. went with Graf... Laso was no longer available from the supplier... hmm..
Forum: Vintage Mercedes Forum 01-19-2017, 04:37 PM
Replies: 34
Views: 4,835
Posted By lee polowczuk
600 Grosser

600 Grosser
Forum: Tech Help 01-17-2017, 09:54 PM
Replies: 11
Views: 877
Posted By lee polowczuk
my fault.... even though the pulley's look...

my fault.... even though the pulley's look identical...the one from the water pump and the one from the power steering pump had to be switched..... it looks like they have weights attached (for...
Forum: Tech Help 01-08-2017, 09:48 PM
Replies: 11
Views: 877
Posted By lee polowczuk
i am going to recheck.... all i can think is that...

i am going to recheck.... all i can think is that i didn't see if it free turned from the start... the pulley bolts are the short ones...... so that's not an issue...
Forum: Tech Help 01-08-2017, 05:10 PM
Replies: 11
Views: 877
Posted By lee polowczuk
Water pump replacement m104

just changed out the water pump in my e320. added water to the radiator....started it up.... water pump pullley wasn't turning..

shut engine off...loosened the belt...

When i turn the pully...
Forum: Tech Help 12-02-2016, 04:08 PM
Replies: 4
Views: 600
Posted By lee polowczuk
Yes, thanks. I may have stripped the heads. ...

Yes, thanks. I may have stripped the heads. Mine have a 6mm Allen.
Forum: Tech Help 12-02-2016, 02:11 PM
Replies: 4
Views: 600
Posted By lee polowczuk
Timing cover removal. M104

Any one know if I can remove the timing cover without removing the "engine hook"? The 5mm engine hook bolts won't budge even with leverage
Showing results 1 to 30 of 500

 
Forum Jump


All times are GMT -4. The time now is 12:17 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page