Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes-Benz Forum > Search Forums

Showing results 1 to 29 of 29
Search took 0.02 seconds.
Search: Posts Made By: Ned Kelly
Forum: Tech Help 08-29-2010, 07:37 AM
Replies: 1
Views: 537
Posted By Ned Kelly
300TE rear window washer hose

Hi guys, i found a leak in this hose and when i h the switch water poors down the rear right pillar and drips into the cargo area.It looks like a leak in the hose somewhere in the grommet of the body...
Forum: Tech Help 08-21-2010, 08:31 PM
Replies: 1
Views: 447
Posted By Ned Kelly
OK, a breakthrough. I pulled out the distributor...

OK, a breakthrough. I pulled out the distributor cap and checked it and the rotor, no mafor problems there and gave it all a quick lick with some emery paper for good measure. I individually tested...
Forum: Tech Help 08-21-2010, 02:07 AM
Replies: 1
Views: 447
Posted By Ned Kelly
surging Idle and stuttering acceleration

Gday Guys this week my 300TE started to develop an occasional surging idle. Nothing too dramatic so i didn't really worry about it. Today when pullaing away from some traffic lights i got a sort of...
Forum: Tech Help 08-14-2010, 05:38 AM
Replies: 4
Views: 1,858
Posted By Ned Kelly
**UPDATE** Tested the temp sensor and it was...

**UPDATE** Tested the temp sensor and it was within spec. I also changed the 02 sensor and it has reduced the roughness of my idle by 80-90%, it is now starting to feel like a MB! The remaining idle...
Forum: Tech Help 08-13-2010, 04:09 AM
Replies: 4
Views: 1,858
Posted By Ned Kelly
engine temp sensor spec

G'Day guys, i am chasing a rough idle whem the engine is warm on my 300TE M103 1989MY. I just measured the engine temperature sender after getting home (40 min drive) with the engine off. I measured...
Forum: Tech Help 08-06-2010, 06:51 PM
Replies: 23
Views: 2,583
Posted By Ned Kelly
cool, mine definately rattles so hopefully i am...

cool, mine definately rattles so hopefully i am heading down the right path in fixing this dicky idle. I am running out of things to replace to rectify this as well as money. I have replaced, 2 new...
Forum: Tech Help 08-06-2010, 08:29 AM
Replies: 23
Views: 2,583
Posted By Ned Kelly
so the OVP should rattle when shaken?

so the OVP should rattle when shaken?
Forum: Tech Help 08-06-2010, 06:05 AM
Replies: 23
Views: 2,583
Posted By Ned Kelly
OVP Rattle is this bad or a myth?

Hi guys, i hav an 1989 300TE with a rumbling idle. I pulled my OVP tonight and it appears to be a newer model with red top and 2 fuses. Fuses are fine but i noticed a rattle when i shook it which...
Forum: Tech Help 07-24-2010, 10:56 PM
Replies: 2
Views: 536
Posted By Ned Kelly
300TE M103 rough idle when pointed down hill.

Hi guys i hope you can help. I pulled out my O2 sensor yesterday and gave it a good clean. It appears to have helped as my idle is much more consistent on level ground. The weird thing is when i...
Forum: Tech Help 07-23-2010, 08:02 AM
Replies: 7
Views: 629
Posted By Ned Kelly
yup brand new washers etc. Had it perfectly...

yup brand new washers etc. Had it perfectly sealed again last night, went for a 30 min drive no leaks. Got up in the morning started the car and fuel leaked out everywhere. I am going nuts trying to...
Forum: Tech Help 07-18-2010, 06:09 PM
Replies: 7
Views: 629
Posted By Ned Kelly
it appears to be from the crush washers on the...

it appears to be from the crush washers on the banjo fitting or the one on the pump under the non-return valve.
Forum: Tech Help 07-18-2010, 12:48 AM
Replies: 7
Views: 629
Posted By Ned Kelly
Leaking Fuel Pump Fitting

Heeelp. I just replaced both fuel pumps on my 1989 300TE with Meyle pumps and the front pump (where the filter and accumulator live) continually leaks. I have pulled it out 5 times now and used new...
Forum: Tech Help 05-29-2010, 08:18 AM
Replies: 2
Views: 594
Posted By Ned Kelly
Most of my driving is also in-town. What is the...

Most of my driving is also in-town. What is the downside when using the hotter plug should i get out on the freeway?
Forum: Tech Help 05-29-2010, 05:29 AM
Replies: 2
Views: 594
Posted By Ned Kelly
1989 300TE M103 Spark Plugs

G'Day, i hope you can help. I am stuck between using NGK BP5EFS or the cooler BP6EFS. I currently have the latter but after researching the web it seems the decision is split. Can anyone advise me...
Forum: Tech Help 05-01-2010, 04:05 AM
Replies: 18
Views: 2,048
Posted By Ned Kelly
the weather has been crap down here so getting...

the weather has been crap down here so getting the tools out hasn't been an option. The ride is certainly not hard in the rear, in fact i feels pretty nice but i am not experienced enough to identify...
Forum: Tech Help 04-30-2010, 08:06 PM
Replies: 18
Views: 2,048
Posted By Ned Kelly
The fluid returning to the resevoir isn't foamy...

The fluid returning to the resevoir isn't foamy at all, would it be foamy at this point if the accumulators were shot and nitrogen was mixing with the fluid?
Forum: Tech Help 04-29-2010, 06:19 AM
Replies: 18
Views: 2,048
Posted By Ned Kelly
The obvious problem i have at the moment is that...

The obvious problem i have at the moment is that when i move the lever on the valve the car doesn't move at all. If i sit on the back of the car with the hatch open it will smoothly go down on the...
Forum: Tech Help 04-28-2010, 06:42 AM
Replies: 18
Views: 2,048
Posted By Ned Kelly
Bewdy Mate! Great detail! I am new to the SLS...

Bewdy Mate! Great detail! I am new to the SLS thing so this will be a great step by step to sorting it out. I am pretty sure the spheres are OK as the ride in the back seems normal but i have nothing...
Forum: Tech Help 04-28-2010, 04:52 AM
Replies: 18
Views: 2,048
Posted By Ned Kelly
cheers, cool diagram. If the accumulators go is...

cheers, cool diagram. If the accumulators go is it fair to expect the ride to be rock hard in the back? The back seems to operate as is it has shocks on it (soft up and down) which should indicate...
Forum: Tech Help 04-26-2010, 04:58 AM
Replies: 18
Views: 2,048
Posted By Ned Kelly
guys?

guys?
Forum: Tech Help 04-24-2010, 10:18 PM
Replies: 18
Views: 2,048
Posted By Ned Kelly
SLS on my 1989 300TE

G'Day guys, i have no SLS function and hoping you can help. My accumulators seem OK, ride seems fine and not rock hard as indicative of shot accumulators. The system seems to recirculate ie; fluid is...
Forum: Tech Help 03-14-2010, 03:48 AM
Replies: 10
Views: 1,909
Posted By Ned Kelly
Hanen't checked the banjo bolt but there is...

Hanen't checked the banjo bolt but there is definately pressure at the aluminium valve linked to the sway bar and there is fluid returning to the resevoir. The ride seems OK but it doesn't do any...
Forum: Tech Help 03-13-2010, 11:41 PM
Replies: 10
Views: 1,909
Posted By Ned Kelly
I have exactly these symptoms. Any clues on where...

I have exactly these symptoms. Any clues on where to start looking? I released the bleed nipple on the valve body and it appears there is plenty of pressure as i was covered in brown foamy fluid.
Forum: Tech Help 01-03-2010, 03:21 AM
Replies: 7
Views: 920
Posted By Ned Kelly
Hmmmm, i had a look at this wheel and it seems to...

Hmmmm, i had a look at this wheel and it seems to run straight. The sound is quite a definate whrrr that reacts to engine speed. Man I hope it isnlt anything expensive!!!???
Forum: Tech Help 12-28-2009, 06:57 PM
Replies: 1
Views: 493
Posted By Ned Kelly
1989 300TE AC temp sensor blower

Hi Guys, I hope you can help me. I tracked this noise down the other day and it appears to be this small blower beside the glovebox liner and side vent (RHD car). I think it sucks air across the temp...
Forum: Tech Help 12-27-2009, 03:36 PM
Replies: 7
Views: 920
Posted By Ned Kelly
Thanks for that, i'll check it out when it stops...

Thanks for that, i'll check it out when it stops raining. It's a pretty loud whirr and i am now starting to think it may be the PS pump. Are these a difficult/costly thing to replace? My engine is an...
Forum: Tech Help 12-25-2009, 06:02 AM
Replies: 7
Views: 920
Posted By Ned Kelly
Bewdy mate, thanks for that. This is the MB Aust...

Bewdy mate, thanks for that. This is the MB Aust guys isn't it? I got some gear from them the other day, great bunch of guys. I registered on the site but my activating email hasn't come through yet,...
Forum: Tech Help 12-25-2009, 03:10 AM
Replies: 7
Views: 920
Posted By Ned Kelly
1989 300TE m103 engin whirr

Hi guys, i just picked this car up and it is my first Benz-i love it. I have noticed a bit of a whirring sound when the engine runs. Is this normal for one of these pups? Perhaps a normal sound due...
Forum: Tech Help 12-25-2009, 03:06 AM
Replies: 1
Views: 542
Posted By Ned Kelly
My First Benz a 300TE - Please help!

Hi Guys I just picked up my first Benz (1989 300TE 280,000kms) and the first thing i have noticed when playing around with it is, man these things are well built. I have managed to fix a bunch of...
Showing results 1 to 29 of 29

 
Forum Jump


All times are GMT -4. The time now is 03:28 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page