Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes-Benz Forum > Search Forums

Showing results 1 to 30 of 39
Search took 0 seconds.
Search: Posts Made By: A Khan
Forum: Tech Help 04-30-2007, 07:12 PM
Replies: 3
Views: 1,744
Posted By A Khan
If the Dexron III bottle states "Power Steering...

If the Dexron III bottle states "Power Steering Fluid" it's fine. Do not use transmission fluid. I know there are experts in this forum who know how to flush the system properly but I don't. What...
Forum: Tech Help 04-29-2007, 05:53 PM
Replies: 3
Views: 1,744
Posted By A Khan
On my 91 300E there are min and max indicators. ...

On my 91 300E there are min and max indicators. Anyway, if don't have one I would say half full fluid in the reservoir is about max. Regarding the type of fluid you will find lots of info. if you do...
Forum: Tech Help 07-27-2006, 11:16 AM
Replies: 13
Views: 2,592
Posted By A Khan
Autozen, the pumps were old probably original. ...

Autozen, the pumps were old probably original. Around early March of this year they started to make a buzzing sound which is indicative of pumps going bad so I had the pumps and filter replaced. ...
Forum: Tech Help 07-27-2006, 10:28 AM
Replies: 13
Views: 2,592
Posted By A Khan
Update

Just wanted to update as to what was done. As Mike suggested I replaced the MAS and had the dealer replace the crank shaft position sensor ($330). Drove the car for more than 20 minutes yesterday,...
Forum: Tech Help 07-21-2006, 02:13 PM
Replies: 13
Views: 2,592
Posted By A Khan
Mike, sorry for the delayed response. Right...

Mike, sorry for the delayed response. Right after I read your post I ordered a MAS unit (car is 91 300E 95K miles) and upon further search on this great forum I learned the crank position sensor or...
Forum: Tech Help 07-15-2006, 10:49 PM
Replies: 13
Views: 2,592
Posted By A Khan
1991 300e shuts off

I hope someone can help. The car is 91 300E with 95K miles. Replaced the battery and coolant today, drove to a gas station and filled up with gas. After driving about 15 min the car shuts off in...
Forum: Tech Help 01-05-2005, 10:19 AM
Replies: 4
Views: 1,313
Posted By A Khan
I would guess the idle control valve and the fuel...

I would guess the idle control valve and the fuel filter. The idle control valve looks like a aluminum cylinder and it's located under the air filter. You have to remove the air filter housing to...
Forum: Tech Help 12-22-2004, 10:15 AM
Replies: 2
Views: 586
Posted By A Khan
Rattle by glove compartment when starting cold

Have a 91 300E (88,000 miles) and for a while I have been noticing that when I start the car cold I hear a rattling sound by the glove compartment. The sound goes away after the car warms up and as...
Forum: Tech Help 03-09-2004, 04:59 PM
Replies: 4
Views: 825
Posted By A Khan
Thanks for the suggestions

Peter,
Where is the idle control valve located? I would like to clean it out and see if it helps. Did search on this a lot but can't find anything that would help with the location. Also, any...
Forum: Tech Help 03-09-2004, 03:55 PM
Replies: 4
Views: 825
Posted By A Khan
1991 300e almost goes off (but doesn't) when stopped

I have a 91 300E (85K miles) that after driving for a while and coming to a stop it will shake (like it is about to shut down) but it recovers immediately. Drive a few more blocks and come to a stop...
Forum: Tech Help 02-19-2004, 01:52 PM
Replies: 6
Views: 1,295
Posted By A Khan
Agree with csnow. I had mine replaced and after...

Agree with csnow. I had mine replaced and after two fillups or so it started jumping after it reaches the half mark. Gave up and decided to live with it.
Forum: Tech Help 10-10-2003, 12:27 PM
Replies: 14
Views: 933
Posted By A Khan
Sixto, Thanks for your help. I found the bleed...

Sixto,
Thanks for your help. I found the bleed ports that you mentioned. Next time when I change the coolant I will remove the bleed ports and hopefully this will purge air in the system and the...
Forum: Tech Help 10-08-2003, 04:24 PM
Replies: 14
Views: 933
Posted By A Khan
So the question is why is it not rising when I...

So the question is why is it not rising when I have the cap removed and and I turn on the engine and let it idle for more than 10 min. Could it be because I have the heater on at full blast.
Forum: Tech Help 10-08-2003, 04:04 PM
Replies: 14
Views: 933
Posted By A Khan
Sixto, When I did the search on the archives I...

Sixto,
When I did the search on the archives I noticed that a few people had this gurgling sound when they turned on the heat. The most common explaination was that air in the syatem created that...
Forum: Tech Help 10-08-2003, 12:00 PM
Replies: 14
Views: 933
Posted By A Khan
Coolant vent

Just replaced coolant (Benz coolant) on my 91 300E and thought I had everything in order. However, I guess I missed something. Now when I start the car and the climate control dial is set to 80 I...
Forum: Tech Help 10-01-2003, 08:59 PM
Replies: 19
Views: 2,694
Posted By A Khan
When the fuel gauge was bouncing I replaced it...

When the fuel gauge was bouncing I replaced it with a new gauge and after of couple of fills at BP it started again. Changed gas about a month ago bouncing decreased. The spark plugs I replaced...
Forum: Tech Help 10-01-2003, 02:37 PM
Replies: 19
Views: 2,694
Posted By A Khan
Hi Haasman, I used to use BP but stopped using...

Hi Haasman,
I used to use BP but stopped using that brand and started using Citgo (3 months now and no more bouncing gas gauges). I am using Bosch heavy duty spark plugs and the Redline fuel system...
Forum: Tech Help 10-01-2003, 02:20 PM
Replies: 19
Views: 2,694
Posted By A Khan
I used Redline fuel system cleaner and afterwards...

I used Redline fuel system cleaner and afterwards always used 2 oz whenever I filled the tank up. If the injectors were clogged then why would the car start up right away and die?
Forum: Tech Help 10-01-2003, 01:34 PM
Replies: 19
Views: 2,694
Posted By A Khan
The iginition coil was replaced when I did the...

The iginition coil was replaced when I did the tune up and I checked it again and it's fine. I also did look at the old threads but their solutions I have already done. I am out of solutions for...
Forum: Tech Help 09-30-2003, 11:32 AM
Replies: 19
Views: 2,694
Posted By A Khan
91 300E takes two times to start

I got a 91 300E (85,000 miles) and always had this problem ever since I bought it last year. It quickly starts and immediately dies (usually happens in cold weather). Starting again is no problem. ...
Forum: Tech Help 08-22-2003, 10:17 AM
Replies: 9
Views: 916
Posted By A Khan
Fuel pumps

Last week I replaced my 91 300E fuel filter and accumulator. After searching this forum I bought a Bosch filter and installed it. Everything was fine until yesterday. I noticed a buzzing sound...
Forum: Tech Help 08-11-2003, 09:22 AM
Replies: 4
Views: 744
Posted By A Khan
Brake pads replacement clarification

Need a little clarification. In some posts I have read that one should open the brake bleeder screw when pushing the pistons back or you risk damaging the master cylinder.

However, most of the...
Forum: Tech Help 07-18-2003, 07:56 PM
Replies: 8
Views: 863
Posted By A Khan
Not sure about your model but on my 300E I was...

Not sure about your model but on my 300E I was cleaning the A/C drain hose and the foam fell apart. Steve stated that I can install a new foam tubing (got it from the delear $11) by removing the...
Forum: Tech Help 06-29-2003, 10:50 PM
Replies: 2
Views: 634
Posted By A Khan
Steve, Thanks for the info. I will give it a...

Steve,
Thanks for the info. I will give it a shot.
Forum: Tech Help 06-29-2003, 10:12 PM
Replies: 2
Views: 634
Posted By A Khan
300E A/C drain

Went to clean the A/C drain on 91 300E using a brush (should have searched this forum which indicated a wire should be inserted to clean out the drain). The problem came when I had the brush...
Forum: Tech Help 04-28-2003, 05:56 PM
Replies: 2
Views: 976
Posted By A Khan
I was hoping there was some other way (other than...

I was hoping there was some other way (other than removing the battery). I know there is a clamp on the right hand side holding the battery is there another clamp on the left side that needs to be...
Forum: Tech Help 04-28-2003, 05:19 PM
Replies: 2
Views: 976
Posted By A Khan
Battery and OVP

I need some advice regarding replacing the OVP. I removed the cover behind the battery and the OVP is secrued by a bracket with a nut. I cut my hand several times loosining the nut and the OVP...
Forum: Tech Help 01-31-2003, 09:28 PM
Replies: 2
Views: 527
Posted By A Khan
Thanks Gilly. I did a search to find the...

Thanks Gilly. I did a search to find the location of the fuse and you were the one who pointed out the location. I printed your instructions and was able to find it in no time and after checking it...
Forum: Tech Help 01-31-2003, 08:50 PM
Replies: 2
Views: 527
Posted By A Khan
91 300e blower strip fuse

Have a 91 300E and the blower quit working. Checked the fuse and it was cracked in the middle. What is the amperage of this strip fuse?

Thanks
Forum: Tech Help 01-09-2003, 03:19 PM
Replies: 11
Views: 1,969
Posted By A Khan
The problem is not with the guage but with the...

The problem is not with the guage but with the fuel sending unit located in the trunk. I replace mine and it does the same thing. With the tank full the guage is fine. However, as soon as it hits...
Showing results 1 to 30 of 39

 
Forum Jump


All times are GMT -4. The time now is 07:46 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page