Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help



Go Back   PeachParts Mercedes-Benz Forum > Search Forums

Showing results 1 to 30 of 102
Search took 0.02 seconds.
Search: Posts Made By: cleavster
Forum: Tech Help 06-01-2020, 05:28 PM
Replies: 4
Views: 869
Posted By cleavster
Also, You can try going to the bone yard and pick...

Also, You can try going to the bone yard and pick one up.
Forum: Tech Help 05-31-2020, 11:10 PM
Replies: 7
Views: 865
Posted By cleavster
Here are the latest updates.... After more...

Here are the latest updates....

After more testing and rechecking, the code reader came up with another code on the MAS controller - Code 2.

Code 2 - Fuel pump relay (circuit 87) not...
Forum: Tech Help 05-28-2020, 08:53 AM
Replies: 7
Views: 865
Posted By cleavster
I checked the cap, the wires, and the plugs are...

I checked the cap, the wires, and the plugs are all in good condition. Using a code reader, I was able to determine that the MAS controller to pull the following codes:

Code 3 - TN/TD signal...
Forum: Tech Help 05-25-2020, 01:09 AM
Replies: 7
Views: 865
Posted By cleavster
Well, Interesting enough Code 11 came back on the...

Well, Interesting enough Code 11 came back on the CEL codes. Is that a broken pump at this point? Any ideas?
Forum: Tech Help 05-24-2020, 08:43 PM
Replies: 7
Views: 865
Posted By cleavster
190e Code 11; Hesitation from Idle

Hi Folks,

The CEL light came on with Code 11 (air injection) and I discovered that one of the vacuum lines was disconnected. Checked for other vacuum leaks and no other leaks found. Reset Code and...
Forum: Tech Help 03-09-2020, 06:29 PM
Replies: 4
Views: 832
Posted By cleavster
190e Differential Fluid

Hi folks,

I have searched the forums and came up with three different choices. See below:

Liqui Moly GL-5 75W-90 fluid

Liqui Moly GL-4+ 75W-90 fluid

Redline 75W-90 Gear Oil fluid
Forum: Tech Help 10-11-2019, 06:25 PM
Replies: 6
Views: 1,636
Posted By cleavster
Thank you both for your recommendations and have...

Thank you both for your recommendations and have decided with the RedLine MTL! Much appreciated!
Forum: Tech Help 10-10-2019, 12:53 AM
Replies: 6
Views: 1,636
Posted By cleavster
190e Manual Transmission Fluid

Hi Folks,

I'm trying to determine the correct manual transmission fluid for a 717.432 5-speed.

I've researched the forums and it is not clear to use

Dexron III ATF or

75W-90 Fully...
Forum: Tech Help 05-17-2019, 12:55 AM
Replies: 4
Views: 748
Posted By cleavster
I did replace the N10 combination relay with a...

I did replace the N10 combination relay with a working one as posted earlier and the results were the same.
Forum: Tech Help 05-16-2019, 02:40 PM
Replies: 4
Views: 748
Posted By cleavster
1995 W124 Wagon - Rear Left Signal Issue

The rear left signal light is not working while engaging the signal or the hazard switch. At first, the issue was intermittent and now is permanent.

The Combination Relay (201 821 00 47) was...
Forum: Tech Help 10-21-2018, 07:40 PM
Replies: 12
Views: 918
Posted By cleavster
Thank you for the info. The modulator has been...

Thank you for the info. The modulator has been replaced and the rubber gasket is very brittle and just replaced the whole unit.

Unfortunately, I have one more leak coming from the same area. ...
Forum: Tech Help 10-12-2018, 11:14 AM
Replies: 12
Views: 918
Posted By cleavster
Got it! The ATF fluid was low and once filled,...

Got it! The ATF fluid was low and once filled, the surging stopped. Whew!

However, There is a prominent leak coming from the modulator valve. I ordered a replacement part and should be arriving...
Forum: Tech Help 09-26-2018, 03:57 PM
Replies: 12
Views: 918
Posted By cleavster
I tried measuring the transmission fluid using...

I tried measuring the transmission fluid using this procedure:

Started the car
Warm up for 20 minutes
Shifted the car through its gears
Pulled out the dipstick and wipe off using a lint free...
Forum: Tech Help 09-24-2018, 01:33 AM
Replies: 12
Views: 918
Posted By cleavster
I'll check tomorrow morning. There are some...

I'll check tomorrow morning. There are some leaks on the ground and after close examination it looks like ATF, red in color.
Forum: Tech Help 09-23-2018, 11:35 PM
Replies: 12
Views: 918
Posted By cleavster
The wagon still accelerates in a constant pace...

The wagon still accelerates in a constant pace when it surges. Could it be the modulator valve?
Forum: Tech Help 09-23-2018, 10:28 PM
Replies: 12
Views: 918
Posted By cleavster
1995 W124 Wagon - Surge Issue

Hi folks,

From stop, slowly accelerating, the wagon RPMs suddenly surges when it reaches 2K-2.5K RPM marks when cold or warm. When the car gets hot, I have no surging issues even starting from a...
Forum: Tech Help 09-15-2018, 04:44 PM
Replies: 3
Views: 925
Posted By cleavster
Thanks everyone for your replies. I just needed...

Thanks everyone for your replies. I just needed to pull harder on the red top to open the filler door. I was just afraid to break something else. As suggested, with a little penetrating oil, it...
Forum: Tech Help 09-12-2018, 01:30 AM
Replies: 3
Views: 925
Posted By cleavster
1995 W124 Wagon - Fuel Filler Door

Hi Folks,

I have an issue where the fuel filler door will not open. I checked the fuel door actuator and it seems to be working correctly. When you lock the driver side door, the red top and the...
Forum: Tech Help 07-25-2016, 09:38 PM
Replies: 5
Views: 853
Posted By cleavster
After receiving the replacement part from this...

After receiving the replacement part from this site, I replaced it last weekend. The procedures and advise really made the job very straightforward. When I removed the part, one of the ears broke...
Forum: Tech Help 07-25-2016, 12:23 PM
Replies: 3
Views: 692
Posted By cleavster
The ground point on W3 and W9 checks out. With...

The ground point on W3 and W9 checks out. With the hazards on, I checked for voltage on the rear driver turn signal wire harness socket and I was registering zero volts. The other rear lights were...
Forum: Tech Help 07-25-2016, 03:15 AM
Replies: 3
Views: 692
Posted By cleavster
95 E320 Wagon Turn light woes

Hi Folks,

The bulb warning light came on today as I was making a left hand turn. The rear driver side was not working and the front driver side signal was flashing very fast. I changed the rear...
Forum: Tech Help 07-19-2016, 01:06 PM
Replies: 5
Views: 853
Posted By cleavster
W124 E320 Radiator leak

Hi folks,

I'm inquiring what is the best procedure to replace the radiator fitting (the top part that bends 90 degrees for the drain hose). Do I need to remove the radiator to remove or can I just...
Forum: Tech Help 09-22-2015, 04:11 AM
Replies: 9
Views: 1,863
Posted By cleavster
From what I'm reading I should do the following: ...

From what I'm reading I should do the following:

(1) Remove valve cover and check for any loose lifters. If any, change them. Do I change them all or just the ones that are loose?
(2) Check...
Forum: Tech Help 09-21-2015, 10:33 PM
Replies: 9
Views: 1,863
Posted By cleavster
Thank you for all your replies. I'll start by...

Thank you for all your replies. I'll start by checking the timing chain stretch on the engine. Is the easiest way to check for stretch is to use a timing light and if it is off by 5 deg on M103 then...
Forum: Tech Help 09-21-2015, 02:59 PM
Replies: 6
Views: 837
Posted By cleavster
I had a similar problem and I would check the...

I had a similar problem and I would check the fuses in the main box again. I think mine was the fuse for the CCU and it was fuse #7 on a W124.
Forum: Tech Help 09-21-2015, 02:52 PM
Replies: 9
Views: 1,863
Posted By cleavster
The car has 270K+ miles and running. I do not...

The car has 270K+ miles and running. I do not have any prior history prior to purchase. I can only assume that the I still have the original timing chain and tensioner.

When I start the car,...
Forum: Tech Help 09-21-2015, 02:43 PM
Replies: 2
Views: 683
Posted By cleavster
To my recollection, you will need to set/move the...

To my recollection, you will need to set/move the pointer to the sharpest part (right mark) of the triangle marker. Then, you will need to tighten the 13mm nut until the pointer moves to the widest...
Forum: Tech Help 09-20-2015, 12:26 PM
Replies: 9
Views: 1,863
Posted By cleavster
M103 Engine Rattle Noise on Startup

Hi Folks,

When starting the car, I heard a rattling noise for a few seconds and it goes away when the oil pressure goes up. This happened only twice so far when the car sat overnight. Last night,...
Forum: Tech Help 09-01-2015, 11:18 AM
Replies: 3
Views: 750
Posted By cleavster
I could not hear/tell the vacuum pods were...

I could not hear/tell the vacuum pods were adjusting. Checked Main Fuse Box and found fuse#7 to be broken. Replaced fuse and CCU is now working again! Thank You both! :)
Forum: Tech Help 09-01-2015, 05:20 AM
Replies: 3
Views: 750
Posted By cleavster
W124 Climate Control Unit no response

I pressed the CCU to get the AC working and nothing happens. I pressed all of the buttons and there is no response. I went ahead and checked the 30 AMP fuse and it looked fine. Had a spare and...
Showing results 1 to 30 of 102

 
Forum Jump


All times are GMT -4. The time now is 09:33 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2022, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page