Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Search Forums

Showing results 1 to 28 of 28
Search took 0.03 seconds.
Search: Posts Made By: rfremista
Forum: Tech Help 11-03-2003, 05:07 AM
Replies: 15
Views: 4,349
Posted By rfremista
check your distributor cap, plugs, wires

I basically replaced my distibutor caps, plugs and wires and that seemed to get the idling down a bit but the big fix was when I took it to an MB certified shop and they reconnected what was a...
Forum: Tech Help 09-28-2003, 09:50 PM
Replies: 11
Views: 989
Posted By rfremista
finally passed emissions!

I managed to pass the emissions test finally .......... the initial analysis turned out to be bogus from my non-MB mechanic. I managed to get hooked up with a couple of dudes that run an MB shop....
Forum: Tech Help 09-25-2003, 04:33 AM
Replies: 11
Views: 989
Posted By rfremista
thanks for the article link...

thanks for the article link .......................

When you described the symptoms of a possible bad catalytic converter I've come to realize that I have some of those problems.

My car does...
Forum: Tech Help 09-25-2003, 12:19 AM
Replies: 11
Views: 989
Posted By rfremista
I heard about that those fuel additives ...........

I heard about that those fuel additives ........ but the shape that my car is in I know that I might need more than just those additives. I will definitely add it on though when the time comes for a...
Forum: Tech Help 09-24-2003, 11:17 PM
Replies: 11
Views: 989
Posted By rfremista
failed emission readings

I had my non-MB mechanic run my 85' 190E car in his Snap-On Emission Analyzer and he said that I'm off the charts on the following readings:

HC - Hydrocarbons and
CO - Carbon Monoxide

His...
Forum: Tech Help 09-23-2003, 01:11 PM
Replies: 5
Views: 904
Posted By rfremista
how to test these list of components?

does anybody have any good resource for testing the following components on an 85' 190E 8V:

1. microswitch
2. throttle valve switch
3. airflow sensor
4. idle control valve
5. EHA
6. OVP
7....
Forum: Tech Help 09-23-2003, 12:53 PM
Replies: 4
Views: 610
Posted By rfremista
cruise control problem

thanks for the response Gilly,

I have a cruise control problem currently and I'm trying to figure it out. Basically my cruise control don't work at all ............. Do you have any ideas on where...
Forum: Tech Help 09-23-2003, 05:13 AM
Replies: 4
Views: 610
Posted By rfremista
Question what is this module?

It might not be clear but I came across this module in my 85' 190E and has the following part number:

003 545 09 32

I found it underneath a black plastic cover that sits under the passenger...
Forum: Tech Help 09-20-2003, 03:04 AM
Replies: 0
Views: 622
Posted By rfremista
does the W124 model have an "idle control module"?

I have an 85' 190E US model and I've been looking at various postings on high-idle and came across the idle control module re-solder.

Does this year have one and is it underneath all the carpet in...
Forum: Tech Help 09-09-2003, 06:49 AM
Replies: 5
Views: 800
Posted By rfremista
actually I have been dealing with the cold start...

actually I have been dealing with the cold start problem since I've had this car (last year around this time). It also has always had a high idle problem as well.

In the mornings, here in...
Forum: Tech Help 09-08-2003, 12:54 PM
Replies: 9
Views: 1,889
Posted By rfremista
from the Tire Calculator link above ...............

from the Tire Calculator link above ............ it seems to me that this could be my problem. I'm just verifying what was discussed below:
Forum: Tech Help 09-05-2003, 05:35 PM
Replies: 9
Views: 1,889
Posted By rfremista
thanks for the quick reply guys! I have...

thanks for the quick reply guys!

I have heard about this smaller-than-stock tire syndrome ........... does anybody know what the stock tire would be for that model (85' 190E)? I think I have...
Forum: Tech Help 09-05-2003, 04:13 PM
Replies: 9
Views: 1,889
Posted By rfremista
speedometer reading faster than actual speed

I have this problem with my 85' 190E where the speedometer is reading at least 10 mph faster than what I'm actually doing.

Does anybody else know if there is any relationship with this problem and...
Forum: Tech Help 09-05-2003, 05:07 AM
Replies: 0
Views: 383
Posted By rfremista
jumpers on unknown connectors

I have another dilemma with a jumped connection to a connector that I don't know, help!
Forum: Tech Help 09-05-2003, 05:02 AM
Replies: 5
Views: 800
Posted By rfremista
no connection on EHA

what type of problem if any could a disconnected EHA cause on my 85' 190E?

Does anybody know what the color coding is for that connector?
Forum: Canada 09-03-2003, 04:07 AM
Replies: 141
Sticky: Canada
Views: 38,944
Posted By rfremista
MB mechanic for late model (85' 190E) around the Vancouver, BC area

hey everyone,

just looking to see if any of the members from the Vancover lower mainland has some suggestions for credible tech shops for MB's

thanks!
Forum: Tech Help 08-06-2003, 05:36 AM
Replies: 7
Views: 669
Posted By rfremista
Re: fast speedo reading problem solved?

Hi Steve,

I was just wondering if you ever got around to solving this problem. I have an '85 190E 2.3 8V and you've basically described my problem right on the money.

hope to hear from you...
Forum: Tech Help 07-08-2003, 03:51 PM
Replies: 9
Views: 1,465
Posted By rfremista
thx for the quick response haasman! I lived...

thx for the quick response haasman!

I lived in the East Bay for two years and I miss it. I will definitely try the bleeding procedure and hopefully better the performance of the car. I have been...
Forum: Tech Help 07-08-2003, 01:39 PM
Replies: 9
Views: 1,465
Posted By rfremista
Well, I ended up replacing the the spark plugs,...

Well, I ended up replacing the the spark plugs, plug wires, distributor cap and rotor ............... voila the car is doing just fine. I test drove it around the block, slowing down, shifting and...
Forum: Tech Help 07-04-2003, 05:46 PM
Replies: 9
Views: 1,465
Posted By rfremista
hey Earl, thanks for the info. I would...

hey Earl,

thanks for the info.

I would say that I resoldered most of the joints on the fuel pump relay but no luck with it. It would still stall on me.

I did not get a chance to test it with...
Forum: Tech Help 07-02-2003, 05:41 PM
Replies: 9
Views: 1,465
Posted By rfremista
hey EJSHarp, thanks for the response...

hey EJSHarp,

thanks for the response ................. This fuel pump relay, is it around the area behind the battery beside the Over voltage protection relay?
Forum: Tech Help 06-30-2003, 03:50 PM
Replies: 9
Views: 1,465
Posted By rfremista
190E stalls after shifting in gear

hey everyone,

initially I had a high idle problem a few months back so I decided to take the distributor apart with all the injector lines, valves etc and showered it with carburator cleaner. Soon...
Forum: Tech Help 06-27-2003, 07:11 AM
Replies: 15
Views: 4,349
Posted By rfremista
idle dipped after cleaning vacuum hoses and fuel distributor

thanks for all the response guys!

I managed to get the idling to drop around 750 rpm when in Drive and around 1000 rpm when in N or P.

Just last week I ran into another problem however...
Forum: Tech Help 05-02-2003, 12:22 PM
Replies: 15
Views: 4,349
Posted By rfremista
I don't have a service manual so what exactly is...

I don't have a service manual so what exactly is OVP and where is it located?
Forum: Tech Help 05-02-2003, 03:53 AM
Replies: 3
Views: 802
Posted By rfremista
Smile my bad!

ooops, I guess I should have looked into the owner's manual first for this one.

G-Benz is right on the money, it is the brake pad wear sensor that is being triggered. I have not looked at my pads...
Forum: Tech Help 05-02-2003, 03:49 AM
Replies: 15
Views: 4,349
Posted By rfremista
I bought the car about 8 months ago and it has...

I bought the car about 8 months ago and it has been idling high ever since. I will try to look into the suggestions over the weekend and hopefully come up with the solution. I will keep everyone...
Forum: Tech Help 04-29-2003, 05:30 AM
Replies: 3
Views: 802
Posted By rfremista
"Check Engine" light on when I step on the brake

this is a weird one ........... the check engine light seems to go on when I press on the brake pedal. Sometime it would flicker.

I was wondering if their is a link between those two electrical...
Forum: Tech Help 04-29-2003, 05:25 AM
Replies: 15
Views: 4,349
Posted By rfremista
85' 190E high idle problem

anybody out there has any ideas on why the idling of my car is erratic. When the car is in P or N, the idle shoots up to about 1500 rpm and when in gear around 1000 rpm. I think that this is...
Showing results 1 to 28 of 28

 
Forum Jump


All times are GMT -4. The time now is 02:18 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page