Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help



Go Back   PeachParts Mercedes-Benz Forum > Search Forums

Showing results 1 to 30 of 107
Search took 0.03 seconds.
Search: Posts Made By: ericzacha
Forum: Tech Help 05-10-2018, 02:36 AM
Replies: 4
Views: 1,106
Posted By ericzacha
Well, the ground was a good thought, and not one...

Well, the ground was a good thought, and not one I would have come up with on my own. I pulled the ground strap completely off. Didnít have much corrosion as itís been a garaged California car most...
Forum: Tech Help 05-02-2018, 04:17 PM
Replies: 4
Views: 1,106
Posted By ericzacha
No start, wipers always on

Well, Iíve searched the web and this site to the best of my googling abilities to no avail. I have an M103 1988 W126 300 SEL. Initially, I thought I had a battery going bad because the car wouldnít...
Forum: Tech Help 12-01-2008, 03:48 PM
Replies: 0
Views: 472
Posted By ericzacha
trans sticks in 3rd

I have a w126 1988 300 SEL with automatic trans, I think 722.351. The other day I took a trip into the mountains and downshifted into 3rd on a couple of steep hills. Coming home, well past the hills...
Forum: Tech Help 06-27-2008, 05:11 PM
Replies: 5
Views: 1,255
Posted By ericzacha
sounds like a monovalve. millions of post on...

sounds like a monovalve. millions of post on that, and it's pretty cheap and easy to fix. this is from the diy page.

http://www.peachparts.com/shopforum/showthread.php?p=1026761
Forum: Tech Help 06-16-2008, 03:11 AM
Replies: 1
Views: 768
Posted By ericzacha
Auxiliary fan not working on 88 300 SEL

88 300 SEL. Converted to R134a before I purchased it. Let's ignore that for now and just focus on the fan issue. A/C works well when I'm driving, but when I'm at idle, it barely feels colder than...
Forum: Tech Help 05-15-2008, 10:15 PM
Replies: 8
Views: 1,960
Posted By ericzacha
I think the system still has some charge to it. ...

I think the system still has some charge to it. If I start out by disconnecting the drier will that release r134 into the atmosphere? Do I need to take any precautions when disconnecting the drier?...
Forum: Tech Help 05-15-2008, 03:52 PM
Replies: 8
Views: 1,960
Posted By ericzacha
When recharging R134a do I need to replace drier?

1988 300 SEL
It was converted to R134a before I came along. A/C has been gradually getting warmer over the past two years and I figure it's time for a recharge. Did a lot of reading here and other...
Forum: Tech Help 02-13-2008, 02:08 PM
Replies: 3
Views: 1,237
Posted By ericzacha
Where is the throttle microswitch? How would I...

Where is the throttle microswitch? How would I go about testing it? I am going to check the idle valve today to see if it is closing the circuit.
Forum: Tech Help 02-13-2008, 03:30 AM
Replies: 3
Views: 1,237
Posted By ericzacha
Why do injectors cause a rough warm idle?

1988 300 SEL with 111,000 miles. Car starts up fine. Idles ok first few minutes until it gets warm. When warm it runs great at speed. When I come to a stop it doesn't die (well every once in a...
Forum: Tech Help 02-13-2008, 02:56 AM
Replies: 8
Views: 2,070
Posted By ericzacha
I posted this a few weeks ago. I think you have...

I posted this a few weeks ago. I think you have an M103 as well so should be the same. Even if you have a different engine the basics should apply.
...
Forum: Tech Help 02-04-2008, 04:15 PM
Replies: 12
Views: 1,360
Posted By ericzacha
So I cracked open the separation diode today. It...

So I cracked open the separation diode today. It was burnt. New one is ordered. Thanks Steve and everyone else who threw in their two cents.
Forum: Tech Help 02-02-2008, 07:05 PM
Replies: 12
Views: 1,360
Posted By ericzacha
Steve, You're a genius! I have read many of...

Steve,
You're a genius! I have read many of your posts in the past and am always impressed. So I pulled the gray two pin relay next to the power seat relay. It was marked "G". Opened the door,...
Forum: Tech Help 02-02-2008, 06:12 PM
Replies: 12
Views: 1,360
Posted By ericzacha
Where is the separation diode located?

Where is the separation diode located?
Forum: Tech Help 02-02-2008, 02:52 AM
Replies: 12
Views: 1,360
Posted By ericzacha
So my old part number was 0025455205. This was...

So my old part number was 0025455205. This was evidently superseded by part number 0035452405 which is what was put in my car. The original was a nine pin and the new one is a ten pin. It seems...
Forum: Tech Help 02-01-2008, 11:19 PM
Replies: 12
Views: 1,360
Posted By ericzacha
The mechanic told me that I had the incorrect...

The mechanic told me that I had the incorrect fuel pump relay on the car. He replaced it with the correct one. Is it possible that changing to a different fuel pump relay caused this?
Forum: Tech Help 01-31-2008, 03:42 PM
Replies: 12
Views: 1,360
Posted By ericzacha
I should add that I used the Crutchfield wire...

I should add that I used the Crutchfield wire harness and followed several posts related to wire colors, so everything should be hooked up to the radio correctly. I really don't think I hooked the...
Forum: Tech Help 01-31-2008, 03:36 PM
Replies: 12
Views: 1,360
Posted By ericzacha
Weird electrical issue 88 300 SEL

My fuel pump and relay went out. I didn't have time to fix it myself, so I took it to the local indy I trust. Fixed it and had it back to me within the day. But when I got home I had a weird...
Forum: Tech Help 01-17-2008, 03:02 PM
Replies: 1
Views: 5,012
Posted By ericzacha
w126 02 sensor replacement/installation

I'd been meaning to do something about the fluctuating idle when coming to a stop on my 1988 300 SEL for some time. When the CEL came on briefly a month or so ago and indicated oxygen sensor, I...
Forum: Tech Help 01-17-2008, 03:41 AM
Replies: 6
Views: 754
Posted By ericzacha
Interesting. I had just assumed that I could get...

Interesting. I had just assumed that I could get amber lights to go with my clear rears. I agree, it wouldn't pose too much of a problem for me as I almost never use my parking lights. When you...
Forum: Tech Help 01-16-2008, 11:44 PM
Replies: 6
Views: 754
Posted By ericzacha
yeah, part of me has a fear that it will look too...

yeah, part of me has a fear that it will look too out of place for me, that's why I was hoping to see it on someone else's car. I don't care so much for the original lights, and I would like to...
Forum: Tech Help 01-16-2008, 02:13 PM
Replies: 6
Views: 754
Posted By ericzacha
Anyone have clear tail lights?

I've been thinking about updating the tail lights on the 88 300 SEL. The current tail lights are faded and I've never been a big fan of the orange. I've already converted to clear corners in the...
Forum: Car Audio and Multimedia 12-30-2007, 10:38 PM
Replies: 1
Views: 1,080
Posted By ericzacha
Rewiring a w126

I'm trying to install a new headunit on my 88 300 SEL. I am planning on bypassing the fader and stock amps by running 8 wires from the new HU to the wiring leading from the amps behind the back...
Forum: Tech Help 11-25-2007, 09:15 PM
Replies: 1
Views: 647
Posted By ericzacha
fault code help 1988 300 sel m103

I've done my diligent searching, and I'm still confused. My CEL came on a few days ago. I am getting fault code 5. I am unsure what this code means. In looking thru the forum it seems it is...
Forum: Tech Help 10-05-2007, 05:03 PM
Replies: 0
Views: 577
Posted By ericzacha
Driver side windshield seal separating

The driver side exterior windshield seal is separating on my 1988 300 SEL. I don't know if this is something to worry about or not. If this is something that is going to cause water to seep into...
Forum: Tech Help 09-29-2007, 04:58 AM
Replies: 8
Views: 1,098
Posted By ericzacha
Well, I finished the job today. The belt...

Well, I finished the job today. The belt tensioner worked just fine. I guess it is most important to have the 19mm bolt loose when tightening the belt tensioner, it may not matter when you are...
Forum: Tech Help 09-28-2007, 12:52 AM
Replies: 8
Views: 1,098
Posted By ericzacha
That sounds logical to me. I'll let ya'll know...

That sounds logical to me. I'll let ya'll know if it works after I get it all back together.
Forum: Tech Help 09-28-2007, 12:51 AM
Replies: 6
Views: 970
Posted By ericzacha
Thanks for that, I will order that o-ring. I'm...

Thanks for that, I will order that o-ring. I'm always a little nervous to substitute parts.
Forum: Tech Help 09-27-2007, 04:29 PM
Replies: 6
Views: 970
Posted By ericzacha
The local mercedes dealer doesn't carry the...

The local mercedes dealer doesn't carry the o-ring. They told me to take it to Orchard Supply Hardware and get a similar sized o-ring.
Forum: Tech Help 09-27-2007, 04:28 PM
Replies: 6
Views: 970
Posted By ericzacha
I finally got brave, and just took the bracket...

I finally got brave, and just took the bracket off. No gasket, but there is an O-ring right where you said there was. Thanks.
Forum: Tech Help 09-27-2007, 04:26 PM
Replies: 8
Views: 1,098
Posted By ericzacha
On my m103 the belt tensioner has a 19mm bolt...

On my m103 the belt tensioner has a 19mm bolt around which the whole assembly pivots. This seems to be the standard from all of the other posts I've read for the m103. This is the bolt that must be...
Showing results 1 to 30 of 107

 
Forum Jump


All times are GMT -4. The time now is 09:21 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page