Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Search Forums

Showing results 1 to 30 of 75
Search took 0.02 seconds.
Search: Posts Made By: 79300D
Forum: Tech Help 05-07-2017, 05:47 PM
Replies: 6
Views: 230
Posted By 79300D
Thumbs up You, my friend, win the prize. That is the one! ...

You, my friend, win the prize. That is the one! Thank you so much.
Forum: Tech Help 05-07-2017, 09:07 AM
Replies: 6
Views: 230
Posted By 79300D
Josh.. Thank you for the reply, but thats not it....

Josh.. Thank you for the reply, but thats not it. The one I am looking for is white in color and has a longer "neck"... Thanks again.
Forum: Tech Help 05-06-2017, 07:52 PM
Replies: 6
Views: 230
Posted By 79300D
Thanks for the reply. I have been all over that...

Thanks for the reply. I have been all over that EPC.. I found the hardware / plug section, put it does not appear to be listed there either. It would be great if the WIS had a link back to the...
Forum: Tech Help 05-06-2017, 02:11 PM
Replies: 6
Views: 230
Posted By 79300D
Anyone know the part number / Where in EPC

Anyone know part number or where in the EPC I can find part #5 ("plug") in the attached image. This is a w202, but i believe w208 and others use the same. It secures the under dash panel to the...
Forum: Tech Help 08-29-2016, 08:15 PM
Replies: 17
Views: 710
Posted By 79300D
The fan is clear of the shroud. Even with my...

The fan is clear of the shroud. Even with my stethoscope I still cant pin it down which is what irritates me the most. I really didn't mind replacing the "front of the engine" parts; at least I...
Forum: Tech Help 08-28-2016, 09:54 PM
Replies: 17
Views: 710
Posted By 79300D
duxthe... It's not that I don't believe you, I'm...

duxthe... It's not that I don't believe you, I'm just not fully convinced! It did the same thing with the OLD and NEW water pumps installed.
Forum: Tech Help 08-28-2016, 08:44 PM
Replies: 17
Views: 710
Posted By 79300D
97 SL320.. Interestingly the water seems to make...

97 SL320.. Interestingly the water seems to make a difference sometimes, but because of the intermittent nature of the noise, it is hard to tell if it actually doing anything. I actually replaced...
Forum: Tech Help 08-28-2016, 07:31 PM
Replies: 17
Views: 710
Posted By 79300D
Ugh. Water pump pulley replaced, another belt...

Ugh. Water pump pulley replaced, another belt tried, the noise still remains.
Remove belt... noise seems to be gone.
Just to reiterate:

(All Mercedes brand parts)

New:

Alternator
AC...
Forum: Tech Help 08-21-2016, 07:15 PM
Replies: 17
Views: 710
Posted By 79300D
97 SL320 - Thanks for the thoughts. I'm...

97 SL320 - Thanks for the thoughts. I'm beginning to believe it is the water pump pulley.. I will post my findings when I take it off and scuff it up or replace it....
Forum: Tech Help 08-19-2016, 09:26 PM
Replies: 17
Views: 710
Posted By 79300D
Went and listened closely. It definitely sounds...

Went and listened closely. It definitely sounds like it is coming from the passenger side of the engine near the front. Once the temperature has increased... gone.
Forum: Tech Help 08-19-2016, 10:34 AM
Replies: 17
Views: 710
Posted By 79300D
No metal shavings. Anywhere. The car has 90k...

No metal shavings. Anywhere. The car has 90k miles, but has been "stealership" maintained since new. It is in excellent condition and everything has been replaced as needed. No deferred...
Forum: Tech Help 08-18-2016, 08:32 PM
Replies: 17
Views: 710
Posted By 79300D
Thanks for the response. The water pump is brand...

Thanks for the response. The water pump is brand new as well. Interestingly, when I replaced it, it wasn't really making any terrible noises, but the impeller was actually slightly binding on the...
Forum: Tech Help 08-18-2016, 07:28 PM
Replies: 17
Views: 710
Posted By 79300D
2002 W208 Cabrio M113 Engine Squeak

Okay, any ideas are appreciated because it is driving me crazy.

2002 W208 M113, all service records since new, so well taken care of.

It began what sounded like a serpentine belt squeak when...
Forum: Tech Help 07-08-2014, 09:31 PM
Replies: 0
Views: 431
Posted By 79300D
2002 CLK430 Cabrio. Interior Trim Question

I just replaced the trim piece shown in the attached image. Does anyone know if that little piece at the bottom (with the box drawn around it) should be trimmed off? The old ones did not have this,...
Forum: Tech Help 11-09-2009, 08:24 AM
Replies: 5
Views: 1,324
Posted By 79300D
Like magic.... Moved tire to rear, cruise works...

Like magic.... Moved tire to rear, cruise works flawlessly. It is hard to believe that the system is THAT sensitive. The other tires are not very old, maybe six months. That was a very...
Forum: Tech Help 11-08-2009, 05:55 PM
Replies: 5
Views: 1,324
Posted By 79300D
Very interesting... It just dawned on me that I...

Very interesting... It just dawned on me that I noticed the problem AFTER the car had a tire replaced under its road hazard warranty. It hadnt been driven in a few days, and, I really didnt think...
Forum: Tech Help 11-08-2009, 11:59 AM
Replies: 5
Views: 1,324
Posted By 79300D
W124 1994 E320 Cruise Control Problems

Any ideas? The cruise control engages and accelerates on the stalk up to 40 miles an hour and then switches off. Above 40, it will not engage at all. Amplifier time? Why 40?

Thanks.
Forum: Tech Help 06-24-2009, 10:35 PM
Replies: 14
Views: 2,316
Posted By 79300D
Lower control arm bushings. Replaced... problem...

Lower control arm bushings. Replaced... problem solved.
Forum: Tech Help 06-17-2009, 10:47 AM
Replies: 14
Views: 2,316
Posted By 79300D
Its going in for a full checkup on Friday.......

Its going in for a full checkup on Friday.... I'll let you know what we find.

Thanks for all of the replies thus far.

Jeff
Forum: Tech Help 06-16-2009, 01:31 PM
Replies: 14
Views: 2,316
Posted By 79300D
Mine seems to start at -+60 mph and on up as...

Mine seems to start at -+60 mph and on up as well.
Forum: Tech Help 06-16-2009, 12:31 PM
Replies: 14
Views: 2,316
Posted By 79300D
Tires were balanced, front end alignment was spot...

Tires were balanced, front end alignment was spot on. The front discs are new....
Forum: Tech Help 06-16-2009, 10:57 AM
Replies: 14
Views: 2,316
Posted By 79300D
Angry Annoying steering wheel vibration W124

I'm sure this has been covered before, but here is the issue.

1994 E320. 91k

Slight steering wheel vibration ( also noticable in passenger seat back movement when empty ).

I was...
Forum: Tech Help 06-16-2009, 10:46 AM
Replies: 9
Views: 1,748
Posted By 79300D
It was an OEM brake caliper.. inexpensive, and...

It was an OEM brake caliper.. inexpensive, and seems like a good rebuild. Good experience!
Forum: Tech Help 05-25-2009, 07:18 PM
Replies: 9
Views: 1,748
Posted By 79300D
I'll let you know how it works out. I just...

I'll let you know how it works out. I just bought one from ******** for $62.00.. cheap.
Forum: Tech Help 05-24-2009, 12:53 PM
Replies: 9
Views: 1,748
Posted By 79300D
Brake Caliper W124 Question... Cardone vs. New ATE

Are the Cardone "remanufactured" brake calipers OEM ATE calipers that have been rebuilt, or, some other brand? (1994 E320 Sedan).

Anyone have a right rear caliper in good working condtion that...
Forum: Tech Help 03-24-2009, 02:33 PM
Replies: 10
Views: 1,121
Posted By 79300D
By the way.. anyone else have / ever seen a...

By the way.. anyone else have / ever seen a Sierra Brown W124? I think mine is the only one I have ever seen...
Forum: Tech Help 03-24-2009, 02:31 PM
Replies: 10
Views: 1,121
Posted By 79300D
The sensor is a brand new MB unit ( from the...

The sensor is a brand new MB unit ( from the fusebox to the front bumber ) Same result as the old one. 18 degrees off...

Babymog... I sent you a PM.

Thanks!

Jeff
Forum: Tech Help 03-21-2009, 06:45 PM
Replies: 10
Views: 1,121
Posted By 79300D
Thanks for the suggestion. It is pretty strange.

Thanks for the suggestion. It is pretty strange.
Forum: Tech Help 03-21-2009, 11:00 AM
Replies: 10
Views: 1,121
Posted By 79300D
W124 Ambient Temperature Display Issue

Anyone have an idea? The ambient temperature display in my 1994 E320 reads 18 degrees lowall of the time. Sometimes after starting, it comes on correctly, but then "resets" itself to 18 degrees...
Forum: Tech Help 03-03-2008, 03:30 PM
Replies: 16
Views: 1,439
Posted By 79300D
The color is Sierra Brown. I like because it is...

The color is Sierra Brown. I like because it is not as anonymous as the sea of silver/white/black cars.
Showing results 1 to 30 of 75

 
Forum Jump


All times are GMT -4. The time now is 04:45 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page