Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Search Forums

Showing results 1 to 30 of 63
Search took 0.02 seconds.
Search: Posts Made By: 95e320
Forum: Tech Help 08-14-2003, 09:37 AM
Replies: 3
Views: 617
Posted By 95e320
Yeah, it does have the hood pad. One thing I...

Yeah, it does have the hood pad. One thing I notice is that there is a loud resonance just over 2000 rpm. Could this be somekind of exhaust leak?
Forum: Tech Help 08-13-2003, 04:45 PM
Replies: 3
Views: 617
Posted By 95e320
1995 E320 Engine Sound

Hello all,

I had a chance to drive another 1995 e320 and the engine was so much quieter! It was almost like my old 1988 190e2.6! Now I am wondering why my car sounds so loud! My car has a very...
Forum: Tech Help 08-11-2003, 09:15 AM
Replies: 14
Views: 1,109
Posted By 95e320
I used a O2 sensor from Lincoln continental for...

I used a O2 sensor from Lincoln continental for my 95 E320. Runs fine without any problems. Now getting 25mpg from 16mpg.
Forum: Tech Help 08-05-2003, 10:38 AM
Replies: 1
Views: 491
Posted By 95e320
Good autoglass shop in Toronto?

Hello,

I have a huge crack on my windshield. However, I am afraid to take it to any joblow glass shop. Does anyone know of a reputable place (with experience working on MB) in Toronto?
...
Forum: Tech Help 05-13-2003, 04:54 PM
Replies: 2
Views: 543
Posted By 95e320
Re: alarm & remote starter

I just finished mine. Same car. If you look under the carpet near the door opening. You will see a black plastic conduit holding wires that go to the back. One of them is blue and that is...
Forum: Tech Help 04-16-2003, 10:37 AM
Replies: 15
Views: 2,886
Posted By 95e320
I don't have it with me, but you can do a search...

I don't have it with me, but you can do a search on the forum. It is called k1 spring kit. My dealer didn't know the kit, but when I gave them the number they were able to order it from Germany.
...
Forum: Tech Help 04-15-2003, 04:49 PM
Replies: 16
Views: 2,633
Posted By 95e320
Just finished installing my unit on the weekend. ...

Just finished installing my unit on the weekend. The keyless part and the lights were easy, but had problems with the horn and the remote start.

MB hid the ignition wires behind the instrument...
Forum: Tech Help 04-14-2003, 11:55 AM
Replies: 23
Views: 2,981
Posted By 95e320
HI Manny, Yeah, I will give it a try this...

HI Manny,

Yeah, I will give it a try this weekend. BTW, does anyone know the Bosch number for the O2 sensor in this car? (95 e320) I think I can just splice the connector.

Richard
...
Forum: Tech Help 04-14-2003, 09:07 AM
Replies: 23
Views: 2,981
Posted By 95e320
Ok. I checked the fuel pressure. It's dead...

Ok.

I checked the fuel pressure. It's dead on at 3.8bar. I don't see any leaks either. Arthur, what do you think? I added a fuel injector cleaner just to make sure that they are not clogged.
...
Forum: Tech Help 04-11-2003, 10:40 AM
Replies: 23
Views: 2,981
Posted By 95e320
Unhappy It's back.

Yup. The CE light came back on. I guess I'll have to check the fuel pressure next to see where the problem is coming from!
Forum: Tech Help 04-10-2003, 11:24 AM
Replies: 23
Views: 2,981
Posted By 95e320
An update

Hello all,

I was looking through the engine bay for vacuum leaks and noticed that a plug (I think it is the intake air temp sensor) is loose. It's a plug that is attached to cross-over pipe close...
Forum: Tech Help 04-04-2003, 11:40 AM
Replies: 15
Views: 2,886
Posted By 95e320
WOT = Wide Open Throttle Richard

WOT = Wide Open Throttle

Richard
Forum: Tech Help 04-03-2003, 12:54 PM
Replies: 15
Views: 2,886
Posted By 95e320
Sorry for the late reply. My 2-3 flair has...

Sorry for the late reply.

My 2-3 flair has disappeared. Although there is a slight hint under WOT, in normal driving, I don't see any slippage.

I bought it from the local MB dealer. Had to...
Forum: Tech Help 04-03-2003, 11:25 AM
Replies: 16
Views: 2,633
Posted By 95e320
Very good post! I am about to put in...

Very good post!

I am about to put in keyless/remote start on my 95e320. I don't see a huge problem as one can find all the information in the wiring diagrams that come with the MB CD.
...
Forum: Tech Help 04-03-2003, 11:13 AM
Replies: 23
Views: 2,981
Posted By 95e320
Thanks Arthur. I will take a look for...

Thanks Arthur.

I will take a look for missing vacuum lines.

Do you think a slowly dying O2 sensor could be the problem as well?

Thanks for all the help. I'll keep you posted.
Forum: Tech Help 04-02-2003, 04:30 PM
Replies: 23
Views: 2,981
Posted By 95e320
Hi Arthur, Thanks for your comments. When...

Hi Arthur,

Thanks for your comments. When you say vac leaks, where would it be? Also, where's the fuel pressure regulator located? I'm just an amatuer, so any help will be greatly apprecaited....
Forum: Tech Help 04-02-2003, 03:15 PM
Replies: 23
Views: 2,981
Posted By 95e320
Thanks Manny, I'll try replacing the oxygen...

Thanks Manny,

I'll try replacing the oxygen sensor since they are cheap.

Richard
Forum: Tech Help 04-02-2003, 02:33 PM
Replies: 23
Views: 2,981
Posted By 95e320
Hi Manny, Thanks for the suggestion. If O2...

Hi Manny,

Thanks for the suggestion. If O2 sensor is bad, wouldn't it trip other codes as well? For example Code 2 comes to mind. Car only has 60K miles.

Another question, does Chrysler 4...
Forum: Tech Help 04-02-2003, 10:54 AM
Replies: 20
Views: 2,938
Posted By 95e320
HI Arthur, I checked it last night and I got...

HI Arthur,

I checked it last night and I got the code 13.

I think it indicates the the lambda control is at its rich/lean maximum.

Do you know what might cause this? Have you seen this...
Forum: Tech Help 04-02-2003, 09:47 AM
Replies: 23
Views: 2,981
Posted By 95e320
Fault code 13 - Lambda control at limit

Hello!

I had CE light come on in my 95 e320. Checked the code and it gave me code #3. So I proceeded to check HFM code and it came out to #13. From the chart, it indicates lambda control...
Forum: Tech Help 04-01-2003, 11:29 AM
Replies: 20
Views: 2,938
Posted By 95e320
Hi Arthur, Yes, I already checked the LED...

Hi Arthur,

Yes, I already checked the LED and I'm getting the code 3. Which I believe indicates problem with HFM, right?

Richard
Forum: Tech Help 04-01-2003, 10:59 AM
Replies: 20
Views: 2,938
Posted By 95e320
Thanks for the comments everyone. I...

Thanks for the comments everyone.

I successfully changed the harness on my car. It took me about an hour. However, I still have my CE light on. :mad:

I am going to hook up an LED to the...
Forum: Tech Help 04-01-2003, 10:52 AM
Replies: 15
Views: 2,886
Posted By 95e320
Hi. I just did the K1 accumulator kit on my...

Hi.

I just did the K1 accumulator kit on my 95 E320. It had the famous 2-3 slip. It's not difficult to do. I bought the kit for $5 and dropped my trans pan and replaced it.

The 2-3 slip did...
Forum: Tech Help 03-17-2003, 04:47 PM
Replies: 5
Views: 824
Posted By 95e320
Yup. I have the same car as you and there are...

Yup. I have the same car as you and there are two like Arthur said. They are two side by side.

If you search the forum, there is a nice Bosch document showing you how to change it. It took me...
Forum: Tech Help 03-03-2003, 12:39 PM
Replies: 20
Views: 2,938
Posted By 95e320
So the plot thickens. I opened up the hood...

So the plot thickens.

I opened up the hood on my car looked at the wiring harness. There were no white tag near the connector, so I decided to slit open some of the insulation near the intake. ...
Forum: Tech Help 02-28-2003, 01:28 PM
Replies: 20
Views: 2,938
Posted By 95e320
Thanks everyone for the replies. Yes. I've...

Thanks everyone for the replies.

Yes. I've already spent all morning reading archives. Did you know that there are 49 pages of threads on wiring harness.

Yet there's not one complete picture...
Forum: Tech Help 02-28-2003, 10:39 AM
Replies: 20
Views: 2,938
Posted By 95e320
Wiring harness??

Hello,

I've go 95 e320 that's having multitude of problems lately.

I changed the spark plugs and saw that some of the wiring next to it had brittle insulation (is that part of the wiring...
Forum: Car Audio and Multimedia 02-27-2003, 11:21 AM
Replies: 3
Views: 990
Posted By 95e320
What I did to my 95 e320 (should be same as...

What I did to my 95 e320 (should be same as yours).

Buy a m-bus alpine changer ($60 used from ebay)

Buy a cable adaptor ($19 from Crutchfield)

Plug it in and voila!
Forum: Tech Help 02-27-2003, 11:18 AM
Replies: 30
Views: 5,604
Posted By 95e320
Sorry to bring back an old thread, but my car (95...

Sorry to bring back an old thread, but my car (95 e320) uses 4 wire sensor. I was given a bosch part number 13314. Can I use the voyager oxygen sensor instead of the mercedes one? It seems like...
Forum: Tech Help 02-25-2003, 02:13 PM
Replies: 2
Views: 833
Posted By 95e320
Thank you Steve.

Thank you Steve.
Showing results 1 to 30 of 63

 
Forum Jump


All times are GMT -4. The time now is 08:04 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page