Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes-Benz Forum > Search Forums

Showing results 1 to 30 of 232
Search took 0.03 seconds.
Search: Posts Made By: smk_texas
Forum: Diesel Discussion 04-16-2018, 10:20 PM
Replies: 4
Views: 260
Posted By smk_texas
I did that (x2 auto button press down) and the...

I did that (x2 auto button press down) and the blower motor comes on at full blast but the auxiliary fan does not.
Forum: Diesel Discussion 04-16-2018, 01:25 PM
Replies: 4
Views: 260
Posted By smk_texas
96 e300 auxiliary fan control module location

Hi ,
The ac (auxiliary) fan does not come on in my 96 e300d. Ran some tests and it looks like the control module is faulty. I traced the wire/cable from the aux fan and noticed that it goes into the...
Forum: Diesel Discussion 04-16-2018, 12:32 AM
Replies: 27
Views: 6,351
Posted By smk_texas
96 e300d auxiliary fan control module location

Hi ,
The ac fan does not come on in my 96 e300d. My control module is faulty. I traced the wire/cable from the aux fan and noticed that goes into the fuse box. After that i can't see where/what it...
Forum: Diesel Discussion 02-12-2017, 08:34 PM
Replies: 9
Views: 573
Posted By smk_texas
Thanks very much All. Appreciate the ideas and...

Thanks very much All. Appreciate the ideas and input. I'll keep an eye on the hose at the pre-heater. Have a Great evening.

smk_texas
Forum: Diesel Discussion 02-12-2017, 01:20 PM
Replies: 9
Views: 573
Posted By smk_texas
Thanks to both of you for your suggestions. ...

Thanks to both of you for your suggestions.

Here is a very interesting thing that happened yesterday. The temperature shot up to almost 90F here in Dallas/Ft.Worth area. I decided to start the...
Forum: Diesel Discussion 02-06-2017, 11:59 PM
Replies: 9
Views: 573
Posted By smk_texas
Unhappy 96 e300d w210 - fuel preheater problems

Hi Folks,

I replaced the main fuel filter and pre-filter on my 96 e300d. Installed fresh orings on both filters. Now the car won't start. There is no fuel coming from the pre-heater (aka...
Forum: Diesel Discussion 12-10-2016, 05:48 PM
Replies: 2
Views: 231
Posted By smk_texas
Question 96 e300d w210 - P120

Folks,
My 96 e300d (157k) acts up when the weather turns cold. Runs perfectly during summer . The temp fell to about 28f here in N.texas the last couple of days.

1. Last morning when i tried to...
Forum: ML, GL, G-Wagen, R-Class, Unimog, Sprinter 09-08-2013, 12:06 AM
Replies: 0
Views: 1,121
Posted By smk_texas
Question 03 ml500 overheating

Hi...My 03 ml500 overheated the other day. I did some checking and noticed that the radiator fan does NOT run at a high speed when the AC is turned. It just runs at one speed which is quite slow.
...
Forum: Tech Help 07-08-2013, 01:49 PM
Replies: 8
Views: 2,034
Posted By smk_texas
Smile Hi ...Thanks for the help. I took the car for...

Hi ...Thanks for the help. I took the car for inspection and it passed. They were able to connect to the port and read with no issues. It looks like my scanner is faulty. Thanks again for the...
Forum: Tech Help 07-03-2013, 12:45 PM
Replies: 8
Views: 2,034
Posted By smk_texas
Do you know exactly where under the hood ????...

Do you know exactly where under the hood ???? Thanks very much.

smk_texas
Forum: Tech Help 07-03-2013, 12:35 PM
Replies: 8
Views: 2,034
Posted By smk_texas
Thanks Al. I appreciate your offer. I am going...

Thanks Al. I appreciate your offer. I am going to take it to the inspection shop on Friday and see what happens. Will keep you posted. I am thinking mostly like the diagnostic module but don't...
Forum: Tech Help 07-01-2013, 11:06 PM
Replies: 8
Views: 2,034
Posted By smk_texas
Hi Al......Thanks for your reponse but i am not...

Hi Al......Thanks for your reponse but i am not sure i explained the problem correctly.

The OBD2 scanner says 'READ FAILED. Unable to read data from vehicle. Please make sure KEY is on and tool...
Forum: Tech Help 06-30-2013, 12:02 AM
Replies: 8
Views: 2,034
Posted By smk_texas
Unhappy 98 s420 - OBD II scanner unable to pull codes

Hi...My OBD II scanner is unable to read codes from the OBD port on my 98 -420 -w140. There is NO CEL. The car drives fine and i have used this scanner to pull codes from this car in the past with...
Forum: Diesel Discussion 03-15-2011, 06:08 PM
Replies: 4
Views: 401
Posted By smk_texas
John....Thanks for your input. Should i use a...

John....Thanks for your input. Should i use a hoist to slide the engine forward ?? Or will it slide forward when i lift it from the tranny mount point with a jack ???? Thanks.
Forum: Diesel Discussion 03-15-2011, 01:01 PM
Replies: 4
Views: 401
Posted By smk_texas
Hello Jeff.. Thanks for your suggestions. I...

Hello Jeff..
Thanks for your suggestions. I really like your suggestion #2.

I have the tranny mount supported with a jack right now. Based on your suggestion, all i need to do is remove the...
Forum: Tech Help 03-14-2011, 11:59 PM
Replies: 4
Views: 568
Posted By smk_texas
95 e300d tranny removal

Hello,

I began the process of removing the transmission (722.435) from my 95 e300d(w124) over the weekend. I am unable to loosen top bolt on the bell cover housing where the tranny is bolted to...
Forum: Diesel Discussion 03-14-2011, 11:57 PM
Replies: 4
Views: 401
Posted By smk_texas
95 e300d tranny removal

Hello,

I began the process of removing the transmission (722.435) from my 95 e300d(w124) over the weekend. I am unable to loosen top bolt on the bell cover housing. This is the hard to get bolt....
Forum: Tech Help 02-02-2011, 02:12 PM
Replies: 9
Views: 5,428
Posted By smk_texas
Hello Gmcosta, There was very little...

Hello Gmcosta,

There was very little residual pressure. I loosened the gas cap before I changed the FPR. You will see some gas (very little) spill over when you unplug the hose from the FPR. Just...
Forum: Diesel Discussion 01-21-2011, 10:33 PM
Replies: 19
Views: 10,968
Posted By smk_texas
I have a 95 e300 with 320k. Everything is still...

I have a 95 e300 with 320k. Everything is still original. The reverse gear on the tranny is going bad....but it still drives great and i get about 32 mpg. I have been driving with the bad tranny for...
Forum: ML, GL, G-Wagen, R-Class, Unimog, Sprinter 10-11-2010, 06:38 PM
Replies: 0
Views: 1,400
Posted By smk_texas
03' ML500 Front Blower regulator part#

Hi, Can someone please post the part# for a 2003 ML500 front blower regulator ? Thanks so much.
Forum: Tech Help 08-03-2009, 12:11 AM
Replies: 22
Views: 1,459
Posted By smk_texas
Arthur is a great guy !!! He has bailed me out on...

Arthur is a great guy !!! He has bailed me out on several occasions saving me a bunch of $$$. He always gives thoughtful and CORRECT answers. I'll stick by him any day.

smk_texas
Forum: Tech Help 07-18-2009, 03:38 PM
Replies: 3
Views: 409
Posted By smk_texas
Thanks Arthur.

Thanks Arthur.
Forum: Tech Help 07-18-2009, 02:51 PM
Replies: 3
Views: 409
Posted By smk_texas
95 e300-D AC refrigerant temp switch

Hello,

I am in the process of replacing my AC receiver/ dryer along with both the switches that sit on top of it. The new red pigtail switch (URO brand) that I purchased has both black wires. I am...
Forum: Diesel Discussion 06-30-2009, 10:11 AM
Replies: 2
Views: 388
Posted By smk_texas
Thanks Jimmy. Yes the car runs fine when the...

Thanks Jimmy. Yes the car runs fine when the compressor is off. Yes, Don is a great guy as well as a mechanic. I'll be taking it to him soon in case I can't figure out what is wrong.

smk_texas...
Forum: Diesel Discussion 06-29-2009, 11:19 PM
Replies: 2
Views: 388
Posted By smk_texas
95 E300D engine cuts out

Hi,

The AC in my 95E300D was not working for a while. Today I decided to check if there was any freon in the system. There was no pressure at the low side...absolutely zero. None at the high side...
Forum: Diesel Discussion 06-29-2009, 10:37 PM
Replies: 4
Views: 837
Posted By smk_texas
I am in the same boat. My 95 E300D (307K) tranny...

I am in the same boat. My 95 E300D (307K) tranny is on its way out. I was told my the local Mercedes dealer that when a tranny does not reverse.. it is the first sign of it going south. My car...
Forum: Diesel Discussion 06-25-2009, 10:41 AM
Replies: 3
Views: 407
Posted By smk_texas
Thanks Folks. I'll try the suggested procedures...

Thanks Folks. I'll try the suggested procedures and get back.

smk_texas
Forum: Diesel Discussion 06-25-2009, 12:24 AM
Replies: 3
Views: 407
Posted By smk_texas
95 E300 Diesel CCU push button jammed

Hi,

The 'low speed fan' button in my CCU is jammed. It is pushed in and doesn't come out even if press the 'auto' or 'high fan' push button. I get very little air from the center vents and none...
Forum: Tech Help 06-16-2009, 08:51 PM
Replies: 1
Views: 789
Posted By smk_texas
98S420(W140) CEL on CODE P0170

Hi Folks,
The CEL came on this morning in my 98 S420 (72K miles). The following were some of the symptoms that preceded the CEL.

1. During the last month or so, on a few occassions whenever I...
Forum: ML, GL, G-Wagen, R-Class, Unimog, Sprinter 05-17-2009, 02:28 PM
Replies: 10
Views: 5,510
Posted By smk_texas
I am fixing to change plugs in my 03 ML500....

I am fixing to change plugs in my 03 ML500. Should I use the bosch platinum +4 or the regular bosch F8DPP33 (see attachment) . Please advise. Thanks.

smk_texas
03 ML500 70K
98 S420 71K
Showing results 1 to 30 of 232

 
Forum Jump


All times are GMT -4. The time now is 01:40 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page