Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help



Go Back   PeachParts Mercedes-Benz Forum > Search Forums

Showing results 1 to 30 of 141
Search took 0.03 seconds.
Search: Posts Made By: Mike Freeman
Forum: Tech Help 03-04-2013, 09:35 AM
Replies: 3
Views: 1,080
Posted By Mike Freeman
Serpentine belt

I have a 1991 300SE, The Air pump bearings have failed for the last time, I recall there is a serpentine belt that fits the engine with the pump removed. If anyone has an idea what size it is I could...
Forum: Tech Help 09-24-2008, 01:43 PM
Replies: 3
Views: 767
Posted By Mike Freeman
280ce won't accelerate

Does the trans upshift at any time when accelerating?
Perhaps the throttle pressure linkage misadjusted or missing. What happens when you manually shift the trans using the shifter lever?
Even...
Forum: Tech Help 09-24-2008, 01:33 PM
Replies: 20
Views: 5,509
Posted By Mike Freeman
Cranks , Won't start

Try a little shot of gasoline or starting fluid i the intake(less than a teasoon) if it still won't fire it's an ignition related problem if it fires and dies it's a fuel related problem.
Mike...
Forum: Tech Help 09-24-2008, 01:26 PM
Replies: 2
Views: 627
Posted By Mike Freeman
Guages

Just in time;
Replace fuse #9
Mike Freeman
Forum: Tech Help 09-24-2008, 01:17 PM
Replies: 3
Views: 2,771
Posted By Mike Freeman
Thermo timewarp

Dieselnutnj;
How describing the cold start problem? There was a cold start problem inherent to that year/car/engine combo!
The wire you pull off that makes black smoke is the one we'll deal with...
Forum: Tech Help 09-24-2008, 12:46 PM
Replies: 9
Views: 1,379
Posted By Mike Freeman
Fumes

Has the engine wire harness been replaced? The high heat at floorboard implies the catalyst is overheating! This can only happen if the cat is getting too much fuel and oxygen. The car would produce...
Forum: Tech Help 09-24-2008, 12:26 PM
Replies: 13
Views: 2,671
Posted By Mike Freeman
No power at top end.

Appatula;
I've been working on Mercedes Benz for almost fourty years and I've never heard any 103 powered car described as powerful.
Perhaps before you do any more to your car you should go drive...
Forum: Tech Help 09-22-2008, 01:41 PM
Replies: 4
Views: 615
Posted By Mike Freeman
380 SL won't start

I think your thread stated the car has around 83k miles, When cranking does the engine sound different? You're in the zone for timing chain problems.
Mike
Forum: Tech Help 09-22-2008, 01:20 PM
Replies: 14
Views: 1,434
Posted By Mike Freeman
Climate control fan

jlomon;
You referr to the problem part as climate control fan. To clear things up do you mean the blower that blows air inside the car or the electric fan at the radiator? Each has a different fix....
Forum: Tech Help 09-19-2008, 01:42 PM
Replies: 4
Views: 646
Posted By Mike Freeman
Reverse in all selector positions

There is a lug on the front of the reverse piston, It has broken off and now jams the piston in the apply position.
The reverse piston lives in the front cover.
Repeated attempts at running the...
Forum: Tech Help 09-19-2008, 01:13 PM
Replies: 18
Views: 2,947
Posted By Mike Freeman
Code reader

cclake;
As stated there is no "code" reading capability on your car.
In response to many complaints of harsh engagement from reverse to drive and vice versa Mercedes Benz incorporated a delayed...
Forum: Tech Help 09-08-2008, 03:47 PM
Replies: 22
Views: 2,209
Posted By Mike Freeman
Miss

Carefully inspect all sparkplugs for cracked insulators,They are hard to see but will give you fits!
Wrong wrench or improper tightening can crack the insulator.
Mike
Forum: Tech Help 09-08-2008, 03:31 PM
Replies: 4
Views: 704
Posted By Mike Freeman
a/c 500SL

Check the fuse for the aux. fan.
Make sure fan(s) isn't stuck,If it is replace.Test by applying power to fan motor.
Check operation of aux. fan relay. Jump pressure switch wires (pigtail)on...
Forum: Tech Help 09-02-2008, 02:21 PM
Replies: 4
Views: 704
Posted By Mike Freeman
85 SL won't unlock

There are a couple of possibilities here, #-1 The metal rod to the vacuum element fell off.
#-2 The deadbolt actuator for the ATA is in the locked position.
If the rod fell off you will have...
Forum: Tech Help 09-02-2008, 02:10 PM
Replies: 4
Views: 994
Posted By Mike Freeman
600SEL Trans

It was normal for trannies of that era to delay engagement up to 5 seconds. It was intended to fix the harsh engagement problem.
There is a modification shown in programmed repairs that involves a...
Forum: Tech Help 08-27-2008, 02:34 PM
Replies: 2
Views: 529
Posted By Mike Freeman
L/R door won't open

Lift the lock knob at that door,Is it connected? Often lock knobs are unscrewed and the rod drops out. When you unlock the car the rod jams under the door panel.
If this is the case lock the car...
Forum: Tech Help 08-26-2008, 01:34 PM
Replies: 27
Views: 5,981
Posted By Mike Freeman
Are you using primium gasoline?If so switch to...

Are you using primium gasoline?If so switch to regular grade. There are a lot of things that can cause this complaint but grade of fuel is easiest to fix.
Mike
Forum: Tech Help 08-26-2008, 01:27 PM
Replies: 24
Views: 3,678
Posted By Mike Freeman
Headjob and waterpump

Ps2cho
The tools you will need should be aquired aheas of time(I think you can get them through this site),Allow 3 or 4 days for this project since after the head is off you will send it out for...
Forum: Tech Help 08-26-2008, 01:14 PM
Replies: 22
Views: 2,209
Posted By Mike Freeman
e420 miss

Here are a couple of things you can check with basic tools.
1-The fuel pressure regulator is located on the fuel rail over cylinder #8,
pull the vacuum line off and plug,with engine running check...
Forum: Tech Help 06-21-2007, 01:57 PM
Replies: 13
Views: 1,927
Posted By Mike Freeman
88 300se Stalls , no power

This car has no "limp home mode"! The problem you describe sounds like a clogged catalyst. Loosen the bolts where the cat connects to the manifolds push the pipes back a little and test drive it, If...
Forum: Tech Help 06-15-2007, 02:53 PM
Replies: 49
Views: 9,679
Posted By Mike Freeman
500E no power

Could it be taking off in 2nd gear? When it works correctly the up**** delay forces a first gear take off and holds first and second gears to almost redline. Perhaps you have a bad bowden cable?
Mike
Forum: Tech Help 06-15-2007, 02:45 PM
Replies: 5
Views: 632
Posted By Mike Freeman
Transmission; Will it fit

Yes the transmission will fit/work. The difference between the .3 and .4 is size.
the .4 fits the 2.6 ltr. 103 engine and was made smaller and lighter since the engine developed less torque.
Mike
Forum: Tech Help 06-15-2007, 02:35 PM
Replies: 8
Views: 2,213
Posted By Mike Freeman
92 2.6 won't start

You stated it has spark so crank angel sensor is probably not going to help, I would suspect fuel pumps or relay. You could test this by spraying some starting fluid into the air cleaner and...
Forum: Tech Help 06-15-2007, 02:29 PM
Replies: 5
Views: 1,511
Posted By Mike Freeman
Stalling 380

The idle control valve may sticking shut. When it stalls and won't restart smack the valve with a screwdriver handle and retry.
Mike
Forum: Tech Help 06-15-2007, 11:33 AM
Replies: 109
Views: 13,809
Posted By Mike Freeman
Surging 88 420SEL

Your idle numbers seem a little high, Thats why everyone keeps pointing fingers at the valve but off idle the valve has little on nothing to do with smooth running.
Even though you say the plugs and...
Forum: Tech Help 06-15-2007, 11:17 AM
Replies: 13
Views: 4,568
Posted By Mike Freeman
Code 16

You need to understand how the ECU tests the EGR system!
With the engine at operating temperature the ECU monitors manifold vacuum via the Piezo pressure sensor in the EZL (electronic ignition) and...
Forum: Tech Help 06-14-2007, 06:03 PM
Replies: 4
Views: 1,277
Posted By Mike Freeman
Hard start

Sounds like the pressure accumulator may be leaking internally!
After the engine has been off for 20 mins. loosen the fuel supply hose to the fuel dist. and see if any pressure exists, if not...
Forum: Vintage Mercedes Forum 06-14-2007, 05:56 PM
Replies: 0
Views: 550
Posted By Mike Freeman
1978 6.9 Engine

Anybody interested?Musst pick up in northern L.A. county.Make offer!
Mike
Forum: Tech Help 05-24-2007, 11:35 AM
Replies: 5
Views: 751
Posted By Mike Freeman
Blown fuse at OVP

The overvoltage relay works like this. B+ (12v pos.) enters at one end of the fuse, at the other end power is distributed to consumers such as CIS, However the downstream end of the fuse also has a...
Forum: Tech Help 05-24-2007, 11:20 AM
Replies: 11
Views: 966
Posted By Mike Freeman
93 400 e

On the pass. side next to the firewll there is a black cover that covers the control units. Remove the cover and you'll find the control units, the one at the rear has four 10 amp fuses (replace them...
Showing results 1 to 30 of 141

 
Forum Jump


All times are GMT -4. The time now is 01:09 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2021, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page