Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help



Go Back   PeachParts Mercedes-Benz Forum > Search Forums

Showing results 1 to 30 of 35
Search took 0.01 seconds.
Search: Posts Made By: Rob Thomas
Forum: Mercedes-Benz SL Discussion Forum 01-03-2014, 11:27 AM
Replies: 9
Views: 1,692
Posted By Rob Thomas
oil leak

Can you see the leak trace definatively with how crammed in everything is in that engine? I will try the heavier waighted oil? Is that weight oil ok for here in nc which gets into 30's in winter.? ...
Forum: Mercedes-Benz SL Discussion Forum 01-02-2014, 03:29 PM
Replies: 9
Views: 1,692
Posted By Rob Thomas
oil leak reply

5W20 and 5W 30 Castrol or Pennzoil
Forum: Mercedes-Benz SL Discussion Forum 01-01-2014, 10:03 PM
Replies: 9
Views: 1,692
Posted By Rob Thomas
1986 560sl oil leak

I have had an oil leak that is hard to detect. Been going on for a few years. Only drive the car about 5k miles per year. Oil does not leak until engine warm. drips right behind oil pan when...
Forum: Tech Help 08-22-2004, 07:37 PM
Replies: 0
Views: 1,002
Posted By Rob Thomas
1986 560sl ignition control unit

I am having trouble with stalling and my mechanic thinks the problem is in the ignition control unit. My question is; Is there any ignition relay or any other relay that is in the ignition circuit? ...
Forum: Mercedes-Benz SL Discussion Forum 06-14-2004, 11:35 AM
Replies: 3
Views: 956
Posted By Rob Thomas
560sl stalling

My 1986 560sl stalls at generally low speeds. It does it intermittently. I might drive 100 miles and it never happens and I might have it happen twice in a few minutes. It usually happens at slow...
Forum: Mercedes-Benz SL Discussion Forum 06-14-2004, 11:29 AM
Replies: 4
Views: 1,567
Posted By Rob Thomas
1986 560sl ignition switch

I need to change this switch and I assume you have to remove the instrument panel to do this. Does anyone know what kind of tool takes the air bag out? What size and type? Thanks. Rob T
Forum: Mercedes-Benz SL Discussion Forum 05-16-2004, 11:35 AM
Replies: 2
Views: 1,276
Posted By Rob Thomas
Randy, Thanks for your help. Hopefully I can...

Randy,
Thanks for your help. Hopefully I can find a mechanic who knows how to troubleshoot rather than just replace parts. From some of the threads I have read it seems like it could be alot of...
Forum: Mercedes-Benz SL Discussion Forum 05-13-2004, 10:15 PM
Replies: 2
Views: 1,276
Posted By Rob Thomas
560sl Stalling

lately, my 1986 560sl stalls. It can stall while slowing down or at highway speed and today it just quit when sitting there idling. The symptoms are few, it just quits. I stop the car and it...
Forum: Tech Help 08-28-2002, 10:14 PM
Replies: 0
Views: 655
Posted By Rob Thomas
560sl air cond

I need some help. freon was put into system but compressor will not come on. Why no power to compressor? Thanks. Rob Thomas
Forum: Tech Help 03-25-2002, 10:35 PM
Replies: 1
Views: 570
Posted By Rob Thomas
560sl cooling

After my 1986 560sl gets warmed up to temp of about 80C, the coolant temp will continue to climb to about 110C. If I put the defrost on it will stay between 80 and 90. Used to be fine, always...
Forum: Tech Help 12-23-2001, 11:10 PM
Replies: 6
Views: 1,135
Posted By Rob Thomas
I was on the highway doing 55. Thanks.

I was on the highway doing 55. Thanks.
Forum: Tech Help 12-23-2001, 07:10 PM
Replies: 6
Views: 1,135
Posted By Rob Thomas
I would think so but the one wrench in the entire...

I would think so but the one wrench in the entire troubleshooting process was the "bad" test of the alternator in the car. So far, two tests were good, one bad. I will try the regulator. Thanks.
Forum: Tech Help 12-23-2001, 06:40 PM
Replies: 6
Views: 1,135
Posted By Rob Thomas
I have had it tested again. It showed 13.6 volts...

I have had it tested again. It showed 13.6 volts while engine running and I took alternator out of car and had it benched tested and it tested 13.6-13.8. I took the regulator off and the portion of...
Forum: Tech Help 12-18-2001, 07:38 PM
Replies: 6
Views: 1,135
Posted By Rob Thomas
alternator or voltage regulator

The other night I was driving my 1986 560sl and a series of electrical malfunctions occurred; the radio switched off, then the "antilock" light came on followed by the "light out" light illuminating,...
Forum: Tech Help 11-29-2001, 06:34 PM
Replies: 1
Views: 669
Posted By Rob Thomas
monovalve

After driving my 1986 560sl for a while with coolant temp about 90-100, I sometimes hear "gurgling" in the dash area where the heater box is. Any ideas what that might be? I have just recently...
Forum: Tech Help 11-26-2001, 12:13 AM
Replies: 0
Views: 496
Posted By Rob Thomas
radiator 560 sl

In trying to figure out an overheating condition(temp at idle about 100 degrees) I checked the radiator for evenness of heating. The top of the radiator is hotter to the touch than the bottom. The...
Forum: Tech Help 11-25-2001, 10:08 AM
Replies: 2
Views: 629
Posted By Rob Thomas
overheating

1986 560sl- I have an overheating condition after just refreshing the coolant. I also had the upper hose off to put new clamp on (it goes into the thermostat area). All is back together and it...
Forum: Tech Help 11-24-2001, 12:12 AM
Replies: 1
Views: 923
Posted By Rob Thomas
monovalve 560sl

how do i know if the monovavle is working? And if it is not, is repairing it the same as putting in a new one? Thanks..
Forum: Tech Help 11-23-2001, 12:11 AM
Replies: 7
Views: 886
Posted By Rob Thomas
recirculating pump

On a 1986 560sl, how can I check to see if the recirculating pump is working correctly? I think it is also referred to as the auxilliary water pump.
Forum: Tech Help 11-23-2001, 12:04 AM
Replies: 3
Views: 978
Posted By Rob Thomas
I have a 1981 300d that was shifting late in all...

I have a 1981 300d that was shifting late in all gears and my problem was a vaccuum switch on top of the valve cover. There are 3 of them under a black cover. There is a connector to them. The one...
Forum: Tech Help 11-06-2001, 11:29 PM
Replies: 2
Views: 625
Posted By Rob Thomas
560 sl

Is it hard to take out the gauges(speedometer, tach etc) on this car? I saw one mech take out the airbag and then take off the steering wheel to get at it before. DO you just pry it out them? ...
Forum: Tech Help 11-06-2001, 11:15 PM
Replies: 2
Views: 827
Posted By Rob Thomas
300d tranny

I have a 1981 300d. Lately, it has been shifting late in each gear. It will always shift before the max speed indicated on the speedometer. In the past, this usually occurred when I had a vaccuum...
Forum: Tech Help 11-06-2001, 11:06 PM
Replies: 0
Views: 858
Posted By Rob Thomas
heating 560 sl

When I select defrost the air will only be lukewarm. Also, when I select the middle button or one to its left the air is only lukewarm with the temp wheel max hot. I get the hottest air(good and...
Forum: Tech Help 11-06-2001, 11:02 PM
Replies: 0
Views: 573
Posted By Rob Thomas
560sl cooling

Recently, I changed coolant. After completing the job I had a few things occur. At idle after the engine has been at temp the coolant temperature rises. When driving it stays right around 80 but...
Forum: Tech Help 07-23-2001, 04:43 AM
Replies: 8
Views: 979
Posted By Rob Thomas
I have a 1986 560 sl. I was driving it one day...

I have a 1986 560 sl. I was driving it one day when a spray came out from under the hood. I stopped the car and found the upper radiator hose had come off top of rt side of radiator. The plastic...
Forum: Tech Help 03-15-2001, 07:11 AM
Replies: 6
Views: 1,190
Posted By Rob Thomas
As far as parts. I have =found the axle at...

As far as parts. I have =found the axle at Advance auto parts for $110.00 and another mercedes parts shop has an axle for $275. Is there going to be a big difference between the two? Thanks. Rob...
Forum: Tech Help 03-13-2001, 10:46 PM
Replies: 6
Views: 1,190
Posted By Rob Thomas
Have a 1981 300D with a torn axle boot. Is it...

Have a 1981 300D with a torn axle boot. Is it important to change right away? Can the car be driven very long with this condition? What is easier, changing the boot or the axle? Saw a mechanic...
Forum: Tech Help 01-25-2001, 01:51 PM
Replies: 4
Views: 1,168
Posted By Rob Thomas
I had a shifting problem similiar with my 86...

I had a shifting problem similiar with my 86 560sl. It would only shift to 4th if I did the nuetral thing or it would shift to 4th automatically when I got above 65 mph. I had someone tell me that...
Forum: Tech Help 01-23-2001, 07:14 AM
Replies: 1
Views: 657
Posted By Rob Thomas
I have a vacuum leak in my 1981 300D. I have...

I have a vacuum leak in my 1981 300D. I have narrowed it down to either of the two back doors and /or fuel door. I am testing via the lines under the front passenger seat. Do you need to test with...
Forum: Tech Help 11-08-2000, 01:54 PM
Replies: 1
Views: 603
Posted By Rob Thomas
I had the timing chain replaced on my 81...

I had the timing chain replaced on my 81 300D(180k)but not the tensioner. Thinking of replacing tensioner now too. Is that a tough job for amateur mech?
Rob Thomas
Showing results 1 to 30 of 35

 
Forum Jump


All times are GMT -4. The time now is 04:38 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2022, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page