Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Search Forums

Showing results 1 to 8 of 8
Search took 0 seconds.
Search: Posts Made By: jerryg
Forum: ML, GL, G-Wagen, R-Class, Unimog, Sprinter 11-07-2004, 04:06 PM
Replies: 2
Views: 856
Posted By jerryg
ML320 window switch

I need to replace a faulty window switch on a 98 ML320. It appears that if I remove the plastic liner box inside the center console, the switches will be easy to get to.

I have put medium...
Forum: Tech Help 02-21-2004, 03:35 PM
Replies: 1
Views: 825
Posted By jerryg
Cam position sensor fault M104

My mechanic is putting a 1995 AMG 3.6 engine from a C36 into a 1996 G-320 for me. It is finally far enough along that we could start it up this morning for a moment.

We are getting a "67 CMP...
Forum: Tech Help 01-23-2004, 10:57 AM
Replies: 6
Views: 3,919
Posted By jerryg
Check EGR connector

I had a similar problem with a 96 G320. The harness had 2 identical connectors for the EGR control and unused air pump. The factory harness had a wire tie over the EGR connector to encourage the...
Forum: Tech Help 12-24-2003, 07:14 PM
Replies: 5
Views: 1,028
Posted By jerryg
Thanks -- who else

Thanks for the reference and advise on the $$. I have a 96 G320 with 170,000 miles. I have enough custom modes on it that I do not want to trade it on a V8 and not sure I want that engine and the...
Forum: Tech Help 12-23-2003, 09:10 PM
Replies: 5
Views: 1,028
Posted By jerryg
engine rebuild -- remtec???

There is a company (in Florida i believe) who rebuilds engines such as a M104 from 3.2 to 2.6 similiar to AMG or Brabas. I may be misspelling their name and cannot find them on the net.

Anyone...
Forum: Tech Help 11-17-2003, 09:07 PM
Replies: 6
Views: 931
Posted By jerryg
problem still there

This problem has come back. I replaced both the wires and plug ends and even replaced the O2 sensor and fuel pump -- with 160,000 miles it seems time anyway. The coils have also been replaced, and 1...
Forum: Tech Help 08-13-2003, 05:54 PM
Replies: 6
Views: 931
Posted By jerryg
Would that be reset with ignition off/on

If I understand you correctly, that is part of the spark plug wires. I will look at them again, but they were replaced about 1 year ago. Also would that give this fault and repliably go away when the...
Forum: Tech Help 08-13-2003, 05:31 PM
Replies: 6
Views: 931
Posted By jerryg
EGR crossover switch and engine miss

Folks on the benzworld g forum said perhaps someone over here could help on this. I have a 1996 G-320, LWB 463 with a M 104 engine with 156,000.

I have had an intermittent miss/power loss for some...
Showing results 1 to 8 of 8

 
Forum Jump


All times are GMT -4. The time now is 01:32 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page