Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Search Forums

Showing results 1 to 13 of 13
Search took 0.02 seconds.
Search: Posts Made By: tigeroscar1
Forum: Tech Help 07-25-2005, 06:36 PM
Replies: 6
Views: 729
Posted By tigeroscar1
could not found the weep hole

I looked on line until I found some pictures and manuals for the car. Still could not find it and I do not have a small inspection mirror. So I put water in the the coolant tank and it started to...
Forum: Tech Help 07-24-2005, 03:27 PM
Replies: 6
Views: 729
Posted By tigeroscar1
Exclamation Where is the weep hole?

I have a 89 260E with over 180,000 miles. It is leaking coolent from some where on the drivers side of the engine. I have jacked it up and started her up had and coolent leaking almost right away. I...
Forum: Tech Help 09-22-2003, 08:32 AM
Replies: 5
Views: 689
Posted By tigeroscar1
Breather Hose

Well I did have the return line replaced on the breather hose from the valve cover to the air filter housing. I'll take another look today after class. Thanks
Forum: Tech Help 09-22-2003, 08:23 AM
Replies: 5
Views: 689
Posted By tigeroscar1
Breather Hose

Well I did have the return line replaced on the breather hose from the valve cover to the air filter housing. I'll take another look today after class. Thanks
Forum: Tech Help 09-21-2003, 08:04 PM
Replies: 5
Views: 689
Posted By tigeroscar1
Update on the 260E thing

Well I went and filled her up put some STP additive in the tank. It started running alittle better after a little trip around town. but the engine still sounded 'funning". I figured I would go and...
Forum: Tech Help 09-21-2003, 12:36 PM
Replies: 5
Views: 689
Posted By tigeroscar1
Exclamation 260E with engine problems?

My 89 260E has develope a problem of some sort. Yesterday I drove from Las Vegas to Albuquerque. Running at 75mph most of the way, I filled the tank up at a Chevon in Flagstaff. After about a half...
Forum: Tech Help 09-21-2003, 11:26 AM
Replies: 20
Views: 3,099
Posted By tigeroscar1
I think I got some in Flagstaff

Yesterday I was driving from Las Vegas to Albuquerque for a class. My 260E was running like a champ. I stopped to fill-up at a Chevon. About a half hour later the engine started to sound rough and...
Forum: Tex-Mex (TX, OK, NM, Mexico) 09-19-2003, 10:04 AM
Replies: 0
Views: 2,469
Posted By tigeroscar1
Question Albuquerque NM

I am driving down to Albuquerque this weekend and was wondering if they have any "good" MB shops. (Just in case.) :D :D
Forum: Tech Help 08-24-2003, 07:18 PM
Replies: 0
Views: 628
Posted By tigeroscar1
260E with #9 fuze that keeps blowing

I had a problem with the dome light, radio, hazard lights, dash clock not working. I checked the fuze box found the number 9 blown. I replaced it and it blow again. So I unplugged the dome light and...
Forum: Tech Help 08-13-2003, 01:32 PM
Replies: 2
Views: 672
Posted By tigeroscar1
Question dome light unit ( I did the search alright still have questions)

Ok I did the search and found out how the remove the dome assembly part # P9040-38546. Great!!!! I did this to make sure that I could do it with little problem.
The reason I'm checking this is that...
Forum: Tech Help 08-08-2003, 01:56 PM
Replies: 7
Views: 669
Posted By tigeroscar1
the cable may need to be replaced or

it might be happen if you changed tire size from the factory ones. This happens because the computer is coded for whatever size is put on the car at the factory. Just take it in and have it re-shot...
Forum: Tech Help 08-04-2003, 11:38 AM
Replies: 2
Views: 616
Posted By tigeroscar1
Thanks I'll try that and see if it works. I'll...

Thanks I'll try that and see if it works. I'll have my shop check it out the next oil change. (8/19/03) I go by time not miles here in las vegas.:)
Forum: Tech Help 08-04-2003, 12:19 AM
Replies: 2
Views: 616
Posted By tigeroscar1
Question 1989 260E alarm help

Hello all, Yes this is my first MB. I did a search about this and did not find what I needed.
Here is the problem, today I moved car and locked it with my key which armed the system alarm. Later on...
Showing results 1 to 13 of 13

 
Forum Jump


All times are GMT -4. The time now is 03:46 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page