Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > SL Forum

Reply
 
LinkBack Thread Tools Display Modes
  #16  
Old 03-01-2006, 01:10 PM
elau's Avatar
Registered User
 
Join Date: Nov 1999
Location: MD.
Posts: 1,725
Not sure if you have an OVP in the '99. You may want to check that out while you are at it.
__________________
95 R129
04 Infiniti G35.5 BS
10 X204
Reply With Quote
  #17  
Old 03-01-2006, 01:48 PM
Registered User
 
Join Date: Oct 2005
Posts: 19
Shaking engine syndrome

Carlos you helped me and I am grateful. My 92 sl used to shake and it drove me crazy too. Motor mounts are always suspect but you changed yours. In gear mine did not shake, only in neutral or park. This told me it was hitting on all 8 in general. My car shook even when I test drove it at the time of purchase! Dealer said it was moisture. I said a $90,000 car should not shake. Well I took it to a private shop and they changed many little rubber hoses on top of the engine. This helped a lot because I believe the misfiring is largely due to lean mixture at idle. Air leaks can cause this. Injector patern at low flow can also cause it. I replaced all the injectors and that did little. One thing I did on a different car is expose all the plug wires/coil pacs in total darkness (outside) with the engine running. You should see some corona discharge which could indicate a track to ground on a coil pack. Voltage is highest at idle. Dont' give up cause my wife says "Her old Pontiac Transport doesen't shake!"

Last edited by Daytonaman; 03-01-2006 at 02:16 PM.
Reply With Quote
  #18  
Old 03-02-2006, 02:23 PM
Registered User
 
Join Date: Jun 2005
Posts: 48
Daytona Man

I too have been grateful for Carlos's help in the past....and wish I had my SL longer so I could assist further. I had a freakin 94 BMW 530i that was born (Block replaced at 40K by BMW) with rough shaking engine. Ignition set up was like the SL with 8 coil packs. In my first response suggested using ohm meter to check resistance in individual coils...to see if there's one with a difference. Unfortunately unlike BMW can find little to no technical info on the SL.
Also thinking could have an intake manifold leak. Another reason for 530's shakes. Not sure if its easy to spray some carb cleaner around edges and check for increased idle. As you mentioned (Daytona Man) leaning is probably the reason...so anthing that has to do with vacuum.

If my 99 SL starts shaking like this I'll be soooooo pissed finally getting rid of the 530 and having to happen all over again.

Good Luck Carlos.
Reply With Quote
  #19  
Old 03-02-2006, 07:05 PM
"99 SL500
 
Join Date: Oct 2004
Location: Jacksonville Fla.
Posts: 332
99sl

Thank you for the best wishes everybody, I've search all over the forums and haven't found any other 113 powered SL's with this problem, so I wouldn't judge all of them by this, but then again most SL owners with this problem probably do not try to fix it by them selfs. This is an awesome car I've enjoy it for a couple of years back when it only had 46,000 on the clock, and this will be fix I'm sure of that, it is just annoying to feel this fine enginnered machine shake at all, the stumbling is gone when I changed the wires so I'm getting there slowly but surelly.
Enjoy yours, this are great cars.
Reply With Quote
  #20  
Old 03-05-2006, 12:10 PM
Registered User
 
Join Date: Jul 2000
Posts: 638
cause of rough idle ?

It may well be deposits on the underside of the intake valves, particularly if its worse cold than hot. Even minute amounts of varnish/gum build-up will cause that cylinder(s) to run poorly at ldle as the fuel flow is disturbed and soaked up by the deposits.

I have one engine (bought at 90Kmiles) (4cam, VVT 32valve 4.5L,290Hp)that had such deposits. With enough Techron and good fuel, finally got it cleaned up CLEAN (used a high tech boroscope --ex medical endoscope) and the thigh runs like a different engine--MUCH more power, silky smooth idle always. THat was THE ONLY thing doen--clean-up the intake system. No p[lugs, wires, hoses--just really clean the intake valves and injectors.
Reply With Quote
  #21  
Old 03-06-2006, 03:59 AM
Registered User
 
Join Date: Jul 2004
Location: Beverly Hills, CA
Posts: 90
Do you still get the shake when it is in gear, or only when in Neutral/Park?
__________________
1999 SL500
Reply With Quote
  #22  
Old 03-06-2006, 10:15 AM
"99 SL500
 
Join Date: Oct 2004
Location: Jacksonville Fla.
Posts: 332
Sl

It is much, much less in gear barely felt but it is still there.
Reply With Quote
  #23  
Old 03-06-2006, 10:29 AM
"99 SL500
 
Join Date: Oct 2004
Location: Jacksonville Fla.
Posts: 332
99 Sl

[QUOTE=Kebowers]It may well be deposits on the underside of the intake valves, particularly if its worse cold than hot. Even minute amounts of varnish/gum build-up will cause that cylinder(s) to run poorly at ldle as the fuel flow is disturbed and soaked up by the deposits.

The engine is going thru the second tankfull treated with techron, it is almost to reserve now, so I am runing another tankfull after this.
The engine knocks from somewhere around the power steering reservoir when the temperature drops below 50 F, it can be carbon knocking, I used a stetoscope trying to pinpoint the sound and I can hear it the loudest at the fuel injector on # 1 cylinder, I suspected the belt tensioner pulley, that is were it seemed to come from but the stetoscope tells me otherwise, it stops knocking when the engine warms up, it sound like the metallic pinging in a diesel engine valve.
Reply With Quote
  #24  
Old 04-05-2006, 05:23 PM
Registered User
 
Join Date: Jun 2005
Posts: 48
???????????

Carlos:

No activity on your thread......first, guess congratulations are in order. Being newlywed was fun ....been a while though.

But more importantly how's the SL. Did you ever solve????

Callen
Reply With Quote
  #25  
Old 04-06-2006, 01:58 PM
"99 SL500
 
Join Date: Oct 2004
Location: Jacksonville Fla.
Posts: 332
Sl

Well the honeymoon is over it actually lasted three years and ended the day after I got married, then again this is not my first rodeo so all is well as expected.
The prognosis on the rough idle is Gremlins, one day it will idle smooth as silk, then I shut it off after I parked, the same day it will idle rough the second time around and vise-versa, so it could be contaminated fuel in the tank, in that case I will replace the filter again, the car was idling smooth right after I changed the wires but my fuel was low so I refueled, full tank of British Petroleum Amoco fuels premium and a bottle of techron, took the car home parked it, happy as can be about my car, but an hour later went to fullfill a "honeydo" at the store 1/2 mile away return home park the car, sat in it while it idle and there it was shaking like a vacuum hose was off, turn it off disgusted with it, by the way the techron got rid of the knocking and there we are, some days are good others....
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 05:02 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page