Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > SL Forum

LinkBack Thread Tools Display Modes
Old 11-07-2006, 05:04 PM
Registered User
Join Date: Nov 2006
Posts: 4
Sl500 1994 Asr Light

I Just Purchased A 1994 Sl500. Two Days Later A High Presure A/c Hose Exploded. The Mechanic Said The Motor Mounts Were Bad, & This Cause The Engine To Fall On The Hose. I Replace The Hose & The Mounts. But Now The Asr Light Came On. The Gas Pedal Is Hard, & The Engine Does Not Feel Right. They Told Me To Repalce The Throttle Actuator. The Light Came On Only After The Motor Mounts Were Installed. Can Someone Help?
Reply With Quote
Old 11-07-2006, 10:42 PM
Registered User
Join Date: Mar 2003
Location: Milwaukee Wisconsin
Posts: 1,149
That damn ASR light. You need to do a forum search on "ASR". There is abundent information on causes and fixes.
Resistance is Futile.
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -4. The time now is 02:38 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page