Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > SL Forum

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 12-23-2008, 12:10 PM
Registered User
 
Join Date: Dec 2008
Location: FLORIDA
Posts: 1
Fuel pump/relay

Afternoon,

I have a 1981 380 SL that's hard to start, the car was in storeage for sometime. I went to start the car which it cranked the first time and from then on it would not turnover. Long story short, I've removed the fuel pump and attached jumper cables to make sure the pump was working which it is, but not quite sure about the presure it's putting out. After looking through several forums I see there are several components related to the fuel system. HELP!
Reply With Quote
  #2  
Old 12-24-2008, 10:38 AM
meltedpanda's Avatar
Certified Benzaholic
 
Join Date: Mar 2003
Location: Central Ky
Posts: 6,028
well need a bit more info, just because the pump is working does not mean you are getting fuel to the fuel rails. Vacuum issues can be a big problem and contribute to non start, filters clean? old fuel? ect ect. I noticed you are a first time poster, the more specific the details , the better we can help
Good luck
__________________
Ron
99 E320 THE Queen Mary
62 220b - Dolly - Finally my Finny!
72 450SL, Pearl-SOLD
16 F350 6.7 Diesel -THOR
07 Lexus RX 350 - Lexi
14 38HP John Deere 3038E Tractor -Mean Green
84 300SD, Benjamin -SOLD
71 220 - W115-Libby ( my first love) -SOLD
73 280 - W114 "Organspende" Rest in Peace
81 380 SL - Rest in Peace
Reply With Quote
  #3  
Old 12-26-2008, 02:12 PM
Seriously off center
 
Join Date: May 2008
Location: Anaheim, CA
Posts: 17
Quote:
Originally Posted by adrianunderway View Post
Afternoon,

I have a 1981 380 SL that's hard to start, the car was in storeage for sometime. I went to start the car which it cranked the first time and from then on it would not turnover. Long story short, I've removed the fuel pump and attached jumper cables to make sure the pump was working which it is, but not quite sure about the presure it's putting out. After looking through several forums I see there are several components related to the fuel system. HELP!
OK, so it "cranked" the first time (I'm assuming the starter turned the engine over) and from then on "would not turn over". So it spun the engine, then would not. If so, not a fuel pump (or supply) problem. Look at the starter relay/starter/neutral safety switch to start. When you get the engine to crank again, start looking at the fuel system.
__________________
1972 350sl (European)
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 10:24 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page