Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > SL Forum

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 12-25-2013, 11:28 PM
po7553
 
Join Date: Mar 2010
Location: Las Vegas Nv
Posts: 28
Top problems

Merry Christmas all
Dec has not been good for my 300 sl I had engine problems which turns out I needed new valves 2 cylinders the exhaust valves were completely burnt out so I had the head redone and everything is great now runs like a brand new car and I cant complain considering I had 210000 miles on the car they even detailed the motor so it shines.But now the bad news.This afternoon I decided to put the top down since it was 65 degrees and nothing happened I pulled the switch back and nothing no noise or anything.The light blinked when I pulled back on the switch but when released the switch the blinking stops.Also the roll bar switch does nothing when I try to raise the roll bar.So if anyone has any advice let me know.I cant afford another major expense.Hope you are listening Klaus.Thanks everyone for your help in the past.Merry Christmas Peter

Reply With Quote
  #2  
Old 12-26-2013, 10:24 AM
meltedpanda's Avatar
Certified Benzaholic
 
Join Date: Mar 2003
Location: Central Ky
Posts: 6,044
what year car Peter?
have you checked fuses?
__________________
Ron
99 E320 THE Queen Mary
62 220b - Dolly - Finally my Finny!
72 450SL, Pearl-SOLD
16 F350 6.7 Diesel -THOR
07 Lexus RX 350 - Lexi
14 38HP John Deere 3038E Tractor -Mean Green
84 300SD, Benjamin -SOLD
71 220 - W115-Libby ( my first love) -SOLD
73 280 - W114 "Organspende" Rest in Peace
81 380 SL - Rest in Peace
Reply With Quote
  #3  
Old 12-26-2013, 12:42 PM
Registered User
 
Join Date: Mar 2003
Location: Milwaukee Wisconsin
Posts: 1,149
Battery was probably disconnected while engine work done. You'll need to reset the top controller. Depending on the model year, there are slight variations to the procedure. But it's not too difficult and the methods have been posted many times here on the forum. You access the diagnostic port and use a simple home made tool / switch to read and clear the trouble codes. Use the forum search tool.
__________________
Resistance is Futile.
Reply With Quote
  #4  
Old 12-27-2013, 02:20 AM
po7553
 
Join Date: Mar 2010
Location: Las Vegas Nv
Posts: 28
I have a 1992 300 sl-24 any help you can give me would be greatly appreciated. Thanks
Reply With Quote
  #5  
Old 12-27-2013, 01:11 PM
Registered User
 
Join Date: Mar 2003
Location: Milwaukee Wisconsin
Posts: 1,149
look at this thread.

Rough Idle

go to my post. tecqboy
__________________
Resistance is Futile.
Reply With Quote
  #6  
Old 12-27-2013, 02:31 PM
po7553
 
Join Date: Mar 2010
Location: Las Vegas Nv
Posts: 28
Thanks I will try it and let you know what happens.Thanks again for your help.
Peter
Reply With Quote
  #7  
Old 12-27-2013, 05:38 PM
Gilly's Avatar
Registered User
 
Join Date: Mar 2001
Location: Evansville WI
Posts: 9,616
On the earlier 129's, I had found in the past that disconnecting the top control module will sometimes make the top operate again. I am usually not hopeful at all on methods like that, like you hear or read others doing to try to clear check engine lights and so forth. But I know a few times when I was at the dealership that the tech line even told us to try that. They say disconnecting the battery won't work, but for some reason on the top control module they will sometimes respond to being disconnected at the module itself, which is under the "floor" behind the seats, under the storage area. This for some reason doesn't work on the later facelift models when they changed how the top operates (after 1994-1995 or so).
Reply With Quote
  #8  
Old 12-28-2013, 09:37 PM
po7553
 
Join Date: Mar 2010
Location: Las Vegas Nv
Posts: 28
Hi guys Its me again I just wanted to let you know that I checked the codes for the top and had codes 17 -22 and roll bar codes 3 and 8 and erased them all and now all is well top goes up and down perfectly Thanks for all your help and I owe all of you a beer.Thanks again you guys are the best.Peter
Reply With Quote
  #9  
Old 12-29-2013, 12:22 PM
Registered User
 
Join Date: Mar 2003
Location: Milwaukee Wisconsin
Posts: 1,149
Glad that you got it sorted out. My controller gets messed up from time to time, so I keep the "tool" in the glove box.
__________________
Resistance is Futile.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 10:19 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page