Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > SL Forum

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 07-21-2014, 09:47 PM
Registered User
 
Join Date: Jul 2014
Posts: 1
88 560sl New Owner Q's, Mechanic Rec

Hi,

Just bought an 1988 560sl, Signal Red on black with 59k miles. Great condition inside and out, although I don't think the paint is completely original. . I didn't notice until after I got it home. It runs well and doesn't leak.

Here's the issues I have and I am hoping to get some feedback:

1. Recomendation Bay Area mechanic especially in San Francisco. I took it to Ed's ******** already, not exclusively a Benz shop but he seemed nice enough albeit a bit rushed. He read the code for me for the check engine light for free. I was also looking at Sal's who is a Benz only shop and does a lot of vintage work. I'd like to pay a good mech to go through the whole car for me.

2. After about 100 miles check engine light came on. Also, after sitting it's hard to start. Can take about 10 cranks and some gas to turn over. After warmed up, starts on first crank. Ed says code reads Air Flow Sensor and recommended replacing the entire Fuel Distributor body which can run around $1000 on parts alone! He says he just had this same problem with hard starting and this fixed the issue. I'm going to get a second opinion before I jump into this repair.

3. Brakes squeal like a bat out of hell. No sensor light on so I assume the pads are ok. I'm going to check them soon to make sure. I guess the squealing and the dusting is just something we have to put up with on these cars? Any recommendations for place to buy genuine brake pads and sensors if I need to replace? You think it's ok to downshift moderately especially in hilly SF to take some pressure of the squealing? Don't want to wear out the tranny.

4. Other than that the car looks, runs and sounds great. I ordered a replacement left window switch as I was able to determine a faulty switch which kept the window from going down by swapping the two switches. Thanks forum! Also need to check the third brake light, as it's out and the sensor is tripped.

Absolutely love the car! I read through this very informative thread: New 560sl owner questions

Thinking I'll try and do most of this stuff over the next few years but not really in a major hurry considering my low miles. Any other advice is appreciated!
Reply With Quote
  #2  
Old 07-22-2014, 03:44 PM
Registered User
 
Join Date: Feb 2011
Location: Modesto CA
Posts: 2,304
Re: hard start

From your description of hard starting after sitting (1 day, 2 days?), the fault is likely to be failure of the various check valves and pressure regulator to hold residual fuel pressure in the system. Test this by cycling the fuel pumps 2-3 times without cranking the engine. Key ON (not start), listen for fuel pumps. When pumps stop (about 2 seconds), key OFF, and back ON again. Cycling the pumps will build system fuel pressure. Now try starting.

If this is successful, only a few components of the fuel supply system will need to be addressed; the air flow sensor and fuel distributor are parts of the fuel metering system.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 02:15 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page