Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > SL Forum

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 08-01-2014, 12:36 PM
Registered User
 
Join Date: Oct 2010
Location: Seattle, WA
Posts: 14
380SL Misfiring/ Loping idle?

1982 380SL and I suddenly have an issue with what I think is a misfire. I can't pin it down to just one cylinder though. It's kind of loping when at idle and I held the revs at 3000 and it does the same thing. The engine idles normal then rev dip then back go up very quickly and it cycles through this quickly.

I just redid the heads a couple hundred miles ago and replaced all the vacuum lines and it was running like it was new. This developed all the sudden a week ago. I've put new plugs in, new wires, cleaned the rotor and dist. cap and replaced the coil. I'm going to swap and old dist cap and rotor to see if that makes a difference.

I've checked all the vacuum lines and they are all still tight. At this point other than swapping the rotor and dist cap I'm running out of ideas. I wonder if it could be a clogged fuel injector or bad fuel? I put some cleaner in just in case but that hasn't made an effect yet. If the cap does't change anything I'm going to run through the troubleshooting section of the injector controller and see if that could be the issue.

Any thoughts or ideas is much appreciated.
Reply With Quote
  #2  
Old 08-01-2014, 04:52 PM
Wodnek's Avatar
Vintage Mercedes Junkie
 
Join Date: Jun 2004
Location: Southeast Wisconsin
Posts: 1,658
Try the original coil. Is it OEM, or is it one of those "made in mexico" replacements? I had the same issue with my 380SL, I swapped out the new coil, with an old one from a 450SEL.
__________________
1959 Gravely LI, 1963 Gravely L8, 1973 Gravely C12
1982 380SL
1978 450 SEL 6.9 euro restoration at 63% and climbing
1987 300 D
2005 CDI European Delivery
1995 E300D Handed down to daughter
2006 CDI Wifes

Reply With Quote
  #3  
Old 08-02-2014, 10:16 PM
meltedpanda's Avatar
Certified Benzaholic
 
Join Date: Mar 2003
Location: Central Ky
Posts: 6,064
auxillary air valve was aways the issue on my 72 when those symptoms cropped up , not sure if the 82 has the same?
__________________
Ron
99 E320 THE Queen Mary
62 220b - Dolly - Finally my Finny!
72 450SL, Pearl-SOLD
16 F350 6.7 Diesel -THOR
07 Lexus RX 350 - Lexi
14 38HP John Deere 3038E Tractor -Mean Green
84 300SD, Benjamin -SOLD
71 220 - W115-Libby ( my first love) -SOLD
73 280 - W114 "Organspende" Rest in Peace
81 380 SL - Rest in Peace
Reply With Quote
  #4  
Old 08-10-2014, 07:23 PM
Registered User
 
Join Date: Oct 2010
Location: Seattle, WA
Posts: 14
I finally resolved this issue. After running a full tank of gas through it, I pulled the plugs again and #2 was clearly not firing properly as compared to the other plugs. I did a compression test and sure enough, I wasn't getting compression on that cylinder. I pulled the valve cover and investigated the rocker arms. One of the rocker arm shims was somehow out of alignment. Must have been me when I was getting the rockers all shimmed properly. I filed to make it receive the rocker arm smoothly and reinstalled and now my issue is resolved! Thanks for the replies.
Reply With Quote
  #5  
Old 08-10-2014, 07:34 PM
meltedpanda's Avatar
Certified Benzaholic
 
Join Date: Mar 2003
Location: Central Ky
Posts: 6,064
good work , I will stash that bit of info away in case I need it in the future.
do you mean the rocker arm -"arm" or where it rests
__________________
Ron
99 E320 THE Queen Mary
62 220b - Dolly - Finally my Finny!
72 450SL, Pearl-SOLD
16 F350 6.7 Diesel -THOR
07 Lexus RX 350 - Lexi
14 38HP John Deere 3038E Tractor -Mean Green
84 300SD, Benjamin -SOLD
71 220 - W115-Libby ( my first love) -SOLD
73 280 - W114 "Organspende" Rest in Peace
81 380 SL - Rest in Peace
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 05:48 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page