PeachParts Mercedes-Benz Forum

PeachParts Mercedes-Benz Forum (http://www.peachparts.com/shopforum/)
-   Tech Help (http://www.peachparts.com/shopforum/tech-help/)
-   -   no turn signals (http://www.peachparts.com/shopforum/tech-help/100518-no-turn-signals.html)

VADIM 08-01-2004 03:38 AM

no turn signals
 
On my 1994 E 320 W124, after turning the turning signals on, they blinked a couple of times and then stop. Now, however, they would not come on at all. At first, I noticed, by moving steering wheel they would come on for a couple of blinks but that does not happen anymore, or was it just my imagination? Last week I replaced the OVP due to other issues (which were solved, thanks to this forum), don't know if that could have affected it to malfunction. Please advise.

glmoy 08-01-2004 06:32 AM

I has this problem on my 92 190E, and it was fixed by replacing the hazard switch.
Its the one with the red button, apparently the turn signals are wired through it. If the hazard switch makes your signals flash then that is not the problem.

deanyel 08-01-2004 08:57 PM

I agree - bad hazard switch / flasher. I think it's sometimes known as a combination relay. I just replaced mine - it's about $40-$50. On a 124 it's located in the fuse/relay box - behind the fuses, on the rear driver's side of engine compartment. You have to take out six phillips screws to lift up the black frame around the fuses. It's the front relay (little black box - maybe 1" by 3" by 2" deep) in the middle row - the H relay position. Current replacement part number is 124 821 02 47 - part number coming out will be similar to this, but not exactly the same. Very easy to take and install a new one.


All times are GMT -4. The time now is 09:55 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website