Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 08-06-2004, 12:47 AM
yosshimura's Avatar
Registered User
 
Join Date: Oct 2001
Location: Liberty City, FL
Posts: 653
Red face Car "was" doing so well...OVP again , now resolved...

Man, Just last week I was like "damn, when there are no tech problems with the car or questions I dont visit here that much"... .... fast forward to SUnday.... went to concert, came out no start......... arrgh

Recent change of OVP / Fuel Pressure relay, ..... wtf!?!? Had it towed to local shop / Royal European in NMB, FL.... and what did they find? rusted out month old OVP!! seems like at some point the top of the cover? (not the one you remove to access ovp and battery) had not been installed properly and was leaking water straight on top of the ovp


It has been pouring the last couple days, so looks Like I should not have any more problems in this area... not for now atleast

Happy with the outcome that it was resolved quickly and simple..
__________________
1995 E320 smoke silver / parchment
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 06:59 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page