Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 11-01-2000, 05:21 PM
Leon Hernandez
Posts: n/a
Anyone ever get a dental drill sound out of your radio when just cruising down the road?
It comes and goes cannot place a event that would lead to this culprit. The radio is on and the dental drill sound varies with the engine RPM (not partial to golden oldies! or Country he he.) I've tried various radio stations to see if it made any difference and it does not. Appreciate your thoughts on this.

FWIW, Even in our Nuclear industry there is an air of disdain for us craft type persons as we maintain our twin 1250 MWe units. This nation has done its artisians and craft a great disservice with it's elitism attitude. Having now owned a 85 300SD and a 94 C280 it reminds my of my old avionics tech days on CH-47's, Cobras etc. I have great appreciation for the MB techs. My hat off to you folks that try to have a normal family life, hobby, job and put up with a lot of us rookies. Got to admit though some of these postings have me laughing in tears. I read them when on night shift, especially the Perf. site. Can't say thanks enough for the benefit you all provide. God Bless.

Best regards, Leon H

93 F-150 4X4 110k still strong(them oil changes pay off!)
86 Ninja 1000 60k(sold)
85 300SD 168k
94 C280 58K (what a blast to drive, 100+ easy)
Reply With Quote
Old 11-01-2000, 05:28 PM
Registered User
Join Date: Aug 1999
Location: ajax, ontario, canada
Posts: 773
are you sure it is coming from the radio?

i also got this high-pitched sound once on my 190e, and it seemed to be coming from the speedometer cable, with its tone directly correlating to vehicle speed, not rpm.

it really freaked me out ...
Reply With Quote
Old 11-01-2000, 06:58 PM
300EVIL's Avatar
Moderator Incarnate
Join Date: Apr 2000
Location: Lake Geneva, WI.
Posts: 1,676
if your radio is not stock,, you should use a filter on your head unit. if you have an external amplifier, (other than stock) you could have a bigger problem like ground loop.
good luck,

87 300E

87 420SEL
Reply With Quote
Old 11-01-2000, 07:36 PM
Registered User
Join Date: Jan 2000
Location: New Bedford, MA USA
Posts: 1,583
Leon, sounds like electrical interference most likely associated with alternator or ignition. If you don't get it on FM stations but you get it on AM, then it may be a bad ground under the hood. If you get it all the time, then it's probably a bad antenna ground..At least that's been my experience..

Jeff Lawrence
1989 300e
2000 Dodge Grand Caravan SE
Reply With Quote
Old 11-01-2000, 11:06 PM
Ashman's Avatar
Service Advisor
Join Date: Sep 2000
Location: Sherman Oaks, CA
Posts: 4,748
In the stereo business they call that engine noise. It could be that there is a bad ground. If you wired a custom Stereo in, with Amps, you have a couple of choices, either run the power cables down one side of the car, and the RCA's down the other side.

You can use an inline noise filter, but it can cut the signal slightly.

I would check your radio ground/antenna ground/amplifier ground. and all connections.

If you do have a custom stereo with amps, and you ran the power and RCA's downt he same side, then definately move the power wires to the other side of the car.

I have also heard that some spark plugs can cause this engine noise. if it is definately coming through the speakers, then I would look into the stereo wiring.


'92 300CE
Metallic Black (Blue Flaked) on Parchment
Clear Corners
94-95 Tail-Lights
Black Grille Insert
78.5k Miles

Future Upgrades:
Sportline Suspension
17" AMG Monoblocks or EVO II's
Euro Headlights
Performance Chip
AMG Exhaust

Click here to Go To My 300CE Page
Reply With Quote
Old 11-02-2000, 12:44 AM
Leon Hernandez
Posts: n/a
You know I can't write er type as fast as I think and that's pretty slow! The noise comes in the FM band and the radio is MB stock. The noise will go away when radio is turned off. So, sounds like I'll go chasing after those grounds. Thanks for the hints, apreciate them. LH
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Similar Threads
Thread Thread Starter Forum Replies Last Post
New car owners embarassed by vintage cars? 300SDog Vintage Mercedes 23 02-11-2003 10:47 PM
intermittent no starting 420SEL david74mr Tech Help 19 11-12-2002 10:23 AM
new 240D owner!!! I have some questions about car mrwith Diesel Discussion 33 11-20-2001 05:32 PM
94 C280 cold start problems... hancheng Tech Help 4 02-26-2001 04:45 PM

All times are GMT -4. The time now is 12:55 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page