Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 08-19-2004, 07:00 PM
Registered User
 
Join Date: Aug 2004
Posts: 2
SLK 230 Electrical Problems

I have a 99 Slk 230 and I have having problems with my alarm as well as the button that puts the top down. I have replaced my PSE pump in the truck and it works but when I plug in my alarm fuse, it goes off. No one can seem to find the problem. Also, my button for the top blinks and beeps at me, like the trunk is not closed, but it all works properly. When I try to put the top up the quarter windows wont go up either. I just put a new radio in, anyone think they may be connected. Alarm problem happened before the radio. Any info would be greatly appreciated.. had it to 2 shops and no one knows!
Reply With Quote
  #2  
Old 08-20-2004, 08:12 AM
Moderator
 
Join Date: Mar 1999
Location: Tucker, Ga USA
Posts: 12,153
Exclamation

When you replace the PSE pump on that car & "most" MB's after 1997, you also need to program that pump with DAS (dealer laptop) computer. That PSE pump is a computer & controls the ATA (alarm) functions, also is on the interior CAN network. The interior CAN needs to have diagnostic scan tool connected to read codes.
__________________
MERCEDES Benz Master Guild Technician (6 TIMES)
ASE Master Technician
Mercedes Benz Star Technician (2 times)
44 years foreign automotive repair
27 Years M.B. Shop foreman (dealer)
MB technical information Specialist (15 years)
190E 2.3 16V ITS SCCA race car (sold)
1986 190E 2.3 16V 2.5 (sold)
Retired Moderator
Reply With Quote
  #3  
Old 08-20-2004, 08:41 AM
Registered User
 
Join Date: Aug 2004
Posts: 2
They did that at the dealer. Didnt fix it. It blew the fuse immediately.
Reply With Quote
  #4  
Old 08-20-2004, 05:52 PM
Moderator
 
Join Date: Mar 1999
Location: Tucker, Ga USA
Posts: 12,153
Exclamation

Again, IF the car is having alarm problems have the PSE pump coding checked. Possibly they mis-coded the pump. ALSO there is a bulletin on WHY the pumps fail on the SLK's dated March 2004 P-B-80.00/25.

Also the RHT(hard-top) system can be scanned for problems at the same time as they are on the same interior CAN network!
__________________
MERCEDES Benz Master Guild Technician (6 TIMES)
ASE Master Technician
Mercedes Benz Star Technician (2 times)
44 years foreign automotive repair
27 Years M.B. Shop foreman (dealer)
MB technical information Specialist (15 years)
190E 2.3 16V ITS SCCA race car (sold)
1986 190E 2.3 16V 2.5 (sold)
Retired Moderator
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 08:23 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page