Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help



Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 08-22-2004, 05:14 PM
Registered User
 
Join Date: Jan 2004
Posts: 52
Question W124 Brake Loss

Hit the brakes hard today in a panic stop (brakelightless Astro minivan turning at a penticostal church!) and heard a 'POP' sound and the pedal went almost to the floor... Drove on, testing the brakes all along, and found they feel hard but then down the pedal goes, like it has air in the system. There is no fluid loss and no light has appeared. Searched the forum and found a similar story with the master being at fault... What's the deal, is this how they usually fail?

ABH3

Reply With Quote
  #2  
Old 08-22-2004, 07:06 PM
haasman's Avatar
Registered User
 
Join Date: Jun 2001
Location: San Francisco, CA
Posts: 3,097
Same thing just happen with the old 190e ... it was a failed outside wheel bearing.

Haasman

__________________
'03 E320 Wagon-Sold
'95 E320 Wagon-Went to Ex
'93 190E 2.6-Wrecked
'91 300E-Went to Ex
'65 911 Coupe (#302580)
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 04:42 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2022, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page