Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 11-11-2000, 05:10 PM
Registered User
 
Join Date: May 1999
Location: Sacramento, CA
Posts: 1,472
1991 300E, 154k miles. The small electric pump on the coolant line from the engine to the coolant reservoir tank (auxiliary water/heater pump) is leaking coolant. It looks like a pretty straightforward R&R; is there anything I need to keep in mind before I try this? Should I get new hoses for both sides of the pump?

thanks in advance,
anthony
Reply With Quote
  #2  
Old 11-11-2000, 08:30 PM
Registered User
 
Join Date: Mar 1999
Location: Suwanee, GA, USA
Posts: 4,712
Just be sure to replace the clamps. You will be fine. We carry all of the needed parts in the partsshop and we ship from CA!!! You will get them fast.


------------------
Benzmac:
Donnie Drummonds
300E
ASE CERTIFIED MASTER AUTO TECHNICIAN
MERCEDES SPECIALIST 8 YRS
PARTNER IN MERCEDESSHOP.COM
OWNER OF MB AUTOWERKS .COM
Reply With Quote
  #3  
Old 11-12-2000, 09:01 PM
Registered User
 
Join Date: May 1999
Location: Sacramento, CA
Posts: 1,472
Thanks. I put in an order once before, and got it days before i thought I would (like, the next day on a ground shipment, or something close to that). I was pleasantly surprised.

One last question - are there any tips to getting all of the air out of the cooling system, or is this not something I should be too concerned about?

thanks!
anthony
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
300e 2.6 fuel pump relay incorporated in MAS sensor? petaling Tech Help 0 01-05-2005 11:08 PM
300e water pump vanagony Tech Help 4 08-26-2004 03:57 AM
300E water pump replacement Walter Lake Tech Help 3 03-13-2004 07:56 PM
aux. water pump & mono valve questions TheLaw Tech Help 1 08-23-2001 11:01 PM
300e fuel pump rich30769 Tech Help 3 09-03-2000 03:12 AM



All times are GMT -4. The time now is 05:47 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page