Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 11-15-2000, 08:52 AM
roland__y
Guest
 
Posts: n/a
Hi,
Has anyone encountered such a problem before..this W124 16V....while idling has a rpm reading of 500 and below which eventually causing the engine to ceased.
Was stuck in traffic had to keep my feet at the throttle to keep the idling above 1,000
While trying to cruise..the car starts jerking as though it was choking and I notice the tranny was behaving in a very erratic manner during its gear shift.
Am I looking at a fuel pump/filter problem.


Thanks

[This message has been edited by roland__y (edited 11-15-2000).]
Reply With Quote
  #2  
Old 11-16-2000, 08:40 PM
roland__y
Guest
 
Posts: n/a
Hi,
To add to my last posting.....the car engine runs well when it cold BUT after 30 mins or so...man it feel as though you are in the rodeo....mean machine jerking and though it was breaking up in pieces.......anyone had this similar ride b4?
Reply With Quote
  #3  
Old 11-16-2000, 09:20 PM
Moderator
 
Join Date: Mar 1999
Location: Tucker, Ga USA
Posts: 12,153
Sounds like a similar problem that Benzmac had with his 16V, air flow sensor sending incorrect info to computer.

[This message has been edited by M.B.DOC (edited 11-16-2000).]
Reply With Quote
  #4  
Old 11-16-2000, 09:48 PM
Registered User
 
Join Date: Mar 1999
Location: Suwanee, GA, USA
Posts: 4,712
I had this problem as Doc said. Also, I have seen where a vacuum leak that was bad enough could cause this.

------------------
Benzmac:
Donnie Drummonds
300E
ASE CERTIFIED MASTER AUTO TECHNICIAN
MERCEDES SPECIALIST 8 YRS
PARTNER IN MERCEDESSHOP.COM
OWNER OF MB AUTOWERKS .COM
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
idle at 500 rpms in Drive, 87 420 SEL RKreutzer Tech Help 1 03-09-2003 07:48 PM



All times are GMT -4. The time now is 04:44 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page