Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 11-18-2000, 12:02 PM
Registered User
 
Join Date: Aug 2000
Posts: 106
Yesterday I put a citric acid flush in my 83 CD and drove it about 15 miles, when I got back I went into the garage for a screw driver and when I came back it was pouring water out of the area of the waterpump. I shut it down, refilled the rad. and started it back up, no leak. I drove it with the brake on to heat it up but no leak. I jacked it up and looked all over the front of the engine and the only thing I found was a bit of steam that seemed to be from behind the harmonic balancer. Monday I will have it pressure checked, but are there any other ideas?
Thanks,
Jerry
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Coolant RED vs. GREEN CJ Tech Help 79 05-23-2009 08:07 PM
Aux water pump leak prb51 Tech Help 1 04-27-2004 10:04 PM
Radiator blew up Scott98 Diesel Discussion 15 02-24-2004 08:57 PM
Headliner Water Leak, '86 300E d2bernhard Tech Help 2 06-03-2003 07:53 PM
Water leak 500sec Tech Help 6 02-04-2001 10:21 AM



All times are GMT -4. The time now is 10:27 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page