Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 09-24-2004, 04:27 AM
Registered User
 
Join Date: Sep 2004
Posts: 1
Fuel system problem

Driving a 300E V6 1991 W124 merc. Car would stall while driving and restart after a little while. Would jerk whilst driving before stalling. Seems as if spark plugs are flooded with petrol. Probable cause? Suggested I replace fuel distibutor. Very expensive. Any way of confirming cause?
Reply With Quote
  #2  
Old 09-24-2004, 11:51 PM
Mike Murrell's Avatar
Registered User
 
Join Date: Feb 2000
Posts: 2,357
Not sure about a V6 in a 300E?

Anyway..........

Check out this thread and consider what Steve Brotherton had to say:

fuel distributor

You can also go to the SEARCH facility and use -> Fuel Distributor as the search phrase and select titles only. Lots to read, but you may find enough information to help you perhaps eliminate the FD as the problem.

It will require thorough diagnosis to resolve. No way you'll be able to quess-work this one. Doing so will result in many $$$ being spent shot-gunning new parts.
__________________
Mike Murrell
1991 300-SEL - Model 126
M103 - SOHC
"Fräulein"
Reply With Quote
  #3  
Old 09-25-2004, 01:01 AM
simmo300e's Avatar
Registered User
 
Join Date: Jun 2004
Location: Bali, Indonesia
Posts: 200
Basil, if you can give us a few more clues, we might be able to help. First off, it isn't likely to be the fuel distributor itself, much more likely to be one of the known suspects up or down the line...

When you say stalls while driving, do you mean driving under power or slowing to a stop?

Does the jerking only happen before stalling or is it something that's happening all the time?

Do you know when the fuel filter was last changed?
Have you recently used any kind of injector cleaner in your petrol?
Have you checked the plugs to confirm they are wet?


While you're checking the plugs, just confirm that they are all in a straight line and this is a 103 motor we're talking about.
__________________
1987 300e manual 250,000 km (sold)
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 03:58 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page