Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 11-20-2000, 12:55 PM
joedirocco
Guest
 
Posts: n/a
Help! I get only a trickle of heat with low fan and EC setting. Using the full fan or auto setting just blows lots of cold air. First MB so I am learning. Any recommended places to troubleshoot? Thanks, Joe
Reply With Quote
  #2  
Old 11-20-2000, 07:01 PM
Moderator
 
Join Date: Mar 1999
Location: Tucker, Ga USA
Posts: 12,153
Try searching the forum with mono heat valve. There are many simular posts with the same results, you need a new mono heat valve insert.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Help: Failed NOx test in MA 1990 300SE cam69ss Tech Help 9 08-22-2004 11:04 AM
1990 500sl NO HEAT Rich WNY Tech Help 1 06-25-2004 01:52 AM
1990 300SE for sale, pics available rla2719 Mercedes Cars For Sale 0 09-07-2003 07:56 PM
Exhaust System 1990 300SE Joe VB Tech Help 0 02-14-2002 08:07 PM
1990 300SE Muffler part # Joe VB Tech Help 1 02-08-2002 09:27 AM



All times are GMT -4. The time now is 07:40 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page