Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 11-20-2000, 11:55 AM
Posts: n/a
Help! I get only a trickle of heat with low fan and EC setting. Using the full fan or auto setting just blows lots of cold air. First MB so I am learning. Any recommended places to troubleshoot? Thanks, Joe
Reply With Quote
Old 11-20-2000, 06:01 PM
Join Date: Mar 1999
Location: Tucker, Ga USA
Posts: 12,153
Try searching the forum with mono heat valve. There are many simular posts with the same results, you need a new mono heat valve insert.
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Similar Threads
Thread Thread Starter Forum Replies Last Post
Help: Failed NOx test in MA 1990 300SE cam69ss Tech Help 9 08-22-2004 10:04 AM
1990 500sl NO HEAT Rich WNY Tech Help 1 06-25-2004 12:52 AM
1990 300SE for sale, pics available rla2719 Mercedes Cars For Sale 0 09-07-2003 06:56 PM
Exhaust System 1990 300SE Joe VB Tech Help 0 02-14-2002 07:07 PM
1990 300SE Muffler part # Joe VB Tech Help 1 02-08-2002 08:27 AM

All times are GMT -4. The time now is 12:08 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page