Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 11-20-2000, 10:45 PM
Posts: n/a
Until the engine is rev'd to nearly 2000 RPM it hesitates, sputters, misses, whatever you want to call it. The car has a new fuel pump, filter and has had the injector cleaned. Your feedback is greatly appreciated! Otherwise, this is one gutsy little powerplant.


P.S. This car has a four speed manual--is very nearly 4000 RPM normal at about 75 MPH. Seems high to me. Thanks again.
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Similar Threads
Thread Thread Starter Forum Replies Last Post
Engine misses badly when cold Gregg Bambo Jr. Vintage Mercedes 25 12-29-2004 09:45 PM
W123 230E stolen for parts pentoman Open Discussion 0 06-02-2004 01:04 PM
300E misses and hestiates after a Car Wash!!! mike690003 Tech Help 5 11-27-2003 12:42 PM
Transmission thump or bump accelerating out of a turn DieselGuy Tech Help 7 11-23-2003 11:13 AM
changing 230E to 320E front brake calipers? netken Tech Help 1 10-15-2002 10:49 AM

All times are GMT -4. The time now is 02:54 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page