Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 11-11-2004, 10:20 PM
Registered User
 
Join Date: Nov 2004
Posts: 1
Transmission Is Gone

I have a 1999 S600 coupe with 67000 miles on it. The transmission is gone. I taught the transmissions on the V12 were good for 300,000 miles. Now dealer wants $7100 to put a new one in. Please help.
Reply With Quote
  #2  
Old 11-11-2004, 10:55 PM
Registered User
 
Join Date: Nov 2004
Posts: 1
doesn't sound right - what happened - sure it's not the computer ?
I heard a similar story told to me ny AAMCO guy who changed my fluids for $150 when the dealer wanted $350 just to diagnose..... I'd look around
Reply With Quote
  #3  
Old 11-11-2004, 11:06 PM
Registered User
 
Join Date: Aug 2003
Location: Phoenix
Posts: 3,726
Do a search herein - there's lot of information on the 722.6 transmission, which I believe yours is. It's been a fairly troubled transmission - I think that 300,000 mile number would only be for driving downhill with no gear changes.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 02:39 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page