Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 12-05-2000, 06:02 PM
Registered User
Join Date: May 1999
Location: Charlotte, NC, USA
Posts: 688
Been having an ongoing problem for a few years which I'd like to clear up. My heater control valve works OK if vacuum is put to it at the end of the line at the control switch unit (under right vent). Everything else appears to switch OK the rest of the year. To keep heat off when unwanted I put a manual shutoff on the heater hose under the hood. That is a pain to control in winter, either too little or too much the hood and adjust!

So, is there a way to diagnose if the vacuum switching unit that controls the heat flow (#11) without using dealer test boxes etc.? Have the switch out and all looks to intact, no cracks etc, or could the problem be elsewhere? How would one check the operation of the unit?

Tobias MB
4 MBs
Reply With Quote
Old 12-05-2000, 09:23 PM
Registered User
Join Date: Mar 1999
Location: Suwanee, GA, USA
Posts: 4,712
More than likely you have one of two problems.

1) You could have a vacuum leak somewhere in the car. The most common problem is the vacuum leak at the line that goes under the battery tray to the vacuum reservoir.

2) You may have a problem with the blend flap potentiometer. If it gives a false reading, the heat and or A/C modes will not work correctly.
Donnie Drummonds
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Similar Threads
Thread Thread Starter Forum Replies Last Post
300D 123 Chassis 1983 Vacuum Problem MattRick Diesel Discussion 4 12-21-2004 09:45 PM
1986 190D 201 body Sunroof problem - HELP!! grimgaunt Mercedes Used Parts For Sale & Wanted 2 11-28-2004 12:34 PM
Mystery Solved - But Problem persists pberku Diesel Discussion 3 08-31-2004 02:15 AM
intermittent brake problem fz500sel Tech Help 2 10-07-2003 01:44 AM
Tormenting Problem with 95 E320 (Long) JetForeman Tech Help 16 10-01-2003 10:57 AM

All times are GMT -4. The time now is 02:01 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page