Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 12-11-2000, 04:46 PM
arochard
Guest
 
Posts: n/a
Hello again, well it looks like I might be without my car over the holidays again this year.

My car would sputter and choke before it finally revved up in the mornings, over a month or so and then one morning it just wouldn't start. It turned over, just wouldn't start. My fuel pump had been dripping slowly and my mechanic suggested replacement before it died, so I ordered one, and installed it this weekend, just to find that it turns over, but still won't "catch".

Is there something I can do to help ? I was thinking maybe siphoning the gas forward then re-attaching the fuel line to the pump?

I still only have about a teaspoon of gas in my fuel filter, so I believe it is gas related.

Please advise,

Thanks, guys.

AARON ROCHARD
1976 230.4 W115
Reply With Quote
  #2  
Old 12-11-2000, 04:59 PM
WmHarlow
Guest
 
Posts: n/a
Doesn't the fuel pump have to be 'timed' in this car?
Sounds like it is not delivering / pumping the fuel.
Reply With Quote
  #3  
Old 12-11-2000, 11:33 PM
Registered User
 
Join Date: Mar 1999
Location: Suwanee, GA, USA
Posts: 4,712
If this the car/engine combination I think it is, you will need to have the choke looked at on the carb.

Good luck. You could take off the air cleaner and be sure that it is closing properly.

The choke has to be working for the engine to start in cold weather.
__________________
Benzmac:
Donnie Drummonds
ASE CERTIFIED MASTER AUTO TECHNICIAN
MERCEDES SPECIALIST 11 YRS
Reply With Quote
  #4  
Old 12-12-2000, 05:21 PM
arochard
Guest
 
Posts: n/a
Guess what ! Went into the garage yesterday, checked the wire attached to the fuel shut off solenoid on the carb, and then cranked her again and after two tries, she started. Needless to say I felt like doing cartwheels.

It did shudder quite a bit before it began to run properly, I wonder if there was some blockage or air bubbles in the fuel lines that were keeping it from running.

I have had nothing but problems with this carb, so I wouldn't be surprised if it was carb related.

Can anyone out there suggest a possible replacement for this rebuilt Stromberg 175 CD (P.I.T.A.) Someone suggested a Weber, but I think that's a bit more dough than I can muster right now.

A carb specialist tested it and told me that there is a vacuum problem with it because the seat that the piston rests on is worn.

Thanks again for your help

AARON

1976 230.4 W115
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Dead on the side of the road -- help needed (long) Cazzzidy Diesel Discussion 9 05-31-2004 10:59 AM
location of 73 280 sel 4.5 fuel pump relay? thombenz Tech Help 1 04-10-2004 08:18 AM
190E Fuel Pump Relay/Electrial problem treynolds Tech Help 0 05-29-2003 11:59 AM
380E won't start, fuel problem (pump good) New2MBZ Tech Help 0 05-22-2003 01:06 AM
Got into a car accident--need advice cossie Off-Topic Discussion 2 09-18-2002 09:42 PM



All times are GMT -4. The time now is 04:34 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page