Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 12-14-2000, 06:07 PM
Registered User
 
Join Date: Dec 2000
Posts: 11
my transmision in my SL goes from 3rd to 5th(overdrive) without shifting through 4th. it started this with no warning,ie noises,slipping or other problems associated with trannys going bad. i think its electrical and i took it to my dealer to check. they checked the overdrive switch on the shift lever, changed a selinoid valve assbly , and 1 month later admitted they were stumped. i told them to take the new parts off which the did and i picked my car up (after paying$ 500.00 for them to practice) and drove it home with the same problem. oh i forgot, they also said the only way to fix the car was to put in a new tanny. i heard of a shop in sfo area that specializes in mb trannys, so i called them and explained my problem. very helpful and i got the feeling they new what they were talking about. they said the problem was electrical and putting a new tranny would not fix the car. possible problems, wireing harness shorting out, the computer control box on the firewall(egs box).i called the dealer to have them talk to this shop and by the time they got around to it the mechanic had left for England for a month. H E L P i'm fairly mechanical having overhauled 2 previous mb diesels,but i need some place to start. thanks for any help 92 300 sL 68000mi.
Reply With Quote
  #2  
Old 12-14-2000, 06:31 PM
Moderator
 
Join Date: Mar 1999
Location: Tucker, Ga USA
Posts: 12,153
The early overdrive solenoids cause this problem. Have them look in their RED Fische under topic 27A93062. The replacement solenoid is part # 124-304-04-90. Did they charge you for this part number?? Also did they read codes from the trans ECU & erase them. IF the electrical connector is the problem then the computer will have many codes.
__________________
MERCEDES Benz Master Guild Technician (6 TIMES)
ASE Master Technician
Mercedes Benz Star Technician (2 times)
44 years foreign automotive repair
27 Years M.B. Shop foreman (dealer)
MB technical information Specialist (15 years)
190E 2.3 16V ITS SCCA race car (sold)
1986 190E 2.3 16V 2.5 (sold)
Retired Moderator
Reply With Quote
  #3  
Old 12-29-2000, 06:58 PM
Registered User
 
Join Date: Dec 2000
Posts: 11
300 sL TRANNY NOT FIXED YET

AFTER CHECKING WITH THE DEALER THEY SAID THEY REFERED TO SERVICE BULLETIN THAT YOU MENTIONED, AND THAT WAS THE SERVICE THEY PERFORMED. THEY ALSO SAID THAT MY 300 HAD BEEN UPDATED TO THE NEW COMPUTER CONTROL BOX I.E. THE ONE THAT IS LOCATED ON THE RIGHT HAND FIREWALL.COULD THIS HAVE GONE BAD I UNDERSTAND THEY COST ABOUT $800. IDONT MIND PAYING THIS IF IT WILL FIX THE PROBLEM. WHAT IS YOUR BEST GUESS.THAKS FOR YOUR H E L P .GREGHSKJ 300 SL
Reply With Quote
  #4  
Old 01-02-2001, 03:29 PM
Registered User
 
Join Date: Dec 2000
Posts: 11
I STILL NEED HELP

DID YOU FORGET ABOUT ME WITH THE NEW YEAR HOLIDAY AND ALL. I STILL NEED HELP WITH MY TANNY PROBLEM. GREGHSKJ 300 SL
Reply With Quote
  #5  
Old 01-02-2001, 05:03 PM
Moderator
 
Join Date: Mar 1999
Location: Tucker, Ga USA
Posts: 12,153
OLD Post

Just didn't read latest post, SORRY. Have you had the Trans codes read by dealer or repair shop?? Did they use the suggested part number, on your receipt? If they used the old number the problem would be the same. The only other problem I've seen is the switch/detent on the shifter itself! Re-reading computer codes should point a finger at the problem!
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
92 300 sL tranny skips 4th gear HELP greghskj Tech Help 3 04-16-2007 07:08 PM
Tranny won't shift to 4th Tom Q Tech Help 4 05-04-2005 09:11 AM
Transmission on 300 Diesel, 2nd gear start or not can-do Tech Help 4 03-21-2001 12:36 PM
300 D Tranny Probs Rxrcyst Tech Help 1 05-03-2000 09:35 PM
300 D turbo tranny swap out (easy?) xtant Tech Help 1 03-06-2000 10:13 PM



All times are GMT -4. The time now is 06:04 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page