Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 12-16-2000, 10:23 PM
Dorsey Lay
Guest
 
Posts: n/a
Hi, hope you can advise. I had a new trans put in approximately a year ago. I have a 190E 2.3 8V with 88,900. Just the last couple of days when I drive,it doesn't seem to know what gear to go into. It goes up and down then finally gets it right a proceeds. It is always sluggish on initial take off. I have been attempting to find out what to do to make it a little speeder. Any ideas on the stumbling? Thank you.
Reply With Quote
  #2  
Old 12-17-2000, 01:01 AM
cth350's Avatar
Registered User
 
Join Date: Dec 2000
Location: Long Island, NY
Posts: 3,654
You checked the fluid level? Is the stuff nice and rosey and smells good? or has it turned orange and/or brown and smells icky?

I have a 300sel 3.5 tranny with a bad case of symptoms like you described. I've been told that it's contamination in the valve body.

-CTH
Reply With Quote
  #3  
Old 12-17-2000, 01:36 AM
Dorsey Lay
Guest
 
Posts: n/a
STUMBLING TRANS

Hi, thanks for the reply, I checked the trans and the fluid appears to be a light brown, but its full. What do you do if the fluid is contaminated because of the problem you describe?
Reply With Quote
  #4  
Old 12-17-2000, 10:40 AM
cth350's Avatar
Registered User
 
Join Date: Dec 2000
Location: Long Island, NY
Posts: 3,654
Light brown means burnt clutches. Does the stuff SMELL burned?

Somebody else will have to second my idea about contamination. Wait for the techs to wake up and have their morning coffee.

Rebuilt a year ago and the fluid is brown? That doesn't sound good.

-CTH
Reply With Quote
  #5  
Old 12-17-2000, 10:32 PM
Dorsey Lay
Guest
 
Posts: n/a
STUMBLING TRANS

It doesn't have a smell other than oil. I don't smell anything burning either. I'd better take it back to the shop just to be safe. Thanks guys for your replies. Much appreciated.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
1997 e320 codes po715 po720 + 11 ? in trans mike webb Tech Help 9 08-06-2007 01:51 PM
Please, please, please help! 87 300SDL Trans Problem pstutcher Diesel Discussion 2 07-21-2004 10:54 PM
Auto trans 88 300TE ulterior Tech Help 0 04-23-2004 02:34 AM
early death of 190E trans at 95k miles alphanumeric Tech Help 4 10-02-2003 05:59 AM
Trans stuck or ???? 1981 300 TD BillGallagher Tech Help 0 08-26-2003 10:16 PM



All times are GMT -4. The time now is 09:56 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page