Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 12-17-2000, 06:27 PM
Posts: n/a
I have a leak in my hydraulic suspension system. The pump is not leaking. It seems to be leaking from the high pressure line just after the pump (buried down below the water pump and behind the balancer). Does anyone know if there is a coupling/connection buried down in there? Is there any way of getting to it without removing the water pump? Thanks.
Reply With Quote
Old 12-17-2000, 09:46 PM
Join Date: Mar 1999
Location: Tucker, Ga USA
Posts: 12,153
The pump can stay but it's about 4-5 hrs to remove & replace the line.
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Similar Threads
Thread Thread Starter Forum Replies Last Post
idle on '88 560 SEL steveholz Tech Help 22 11-18-2003 04:21 PM
Just added a 560 SEL jchip Tech Help 1 03-22-2003 09:44 PM
Wanted-1990/91 560 SEL in Toronto Canada Cigar Havana Mercedes Cars For Sale 22 01-30-2003 11:15 PM
'89 560 Sel Mino Erhan Tech Help 2 12-08-2002 04:52 PM
1987 560 SEL For Sale MarcP Mercedes Used Parts For Sale & Wanted 0 11-25-2001 10:40 PM

All times are GMT -4. The time now is 01:22 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page