Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 05-05-2005, 09:38 PM
shawncisco
Guest
 
Posts: n/a
new fuel pump & relay & car still won't run

I put a remanufactured fuel pump in and then I wasn't getting any power to it. So I went to the junk yard and found a fuel relay from another 300e, but it was a superseeded part number.
Now the pump kicks on but when I'm driving it stumbles every time you try and give it gas.
Could this be because of the fuel relay being an earlier superseeded part number than the one that was in the car.
Any suggestions, I'm stumped and still have a car that won't run
Reply With Quote
  #2  
Old 05-05-2005, 09:51 PM
Jim Villers's Avatar
Registered User
 
Join Date: Jan 2000
Location: Virginia Beach, VA
Posts: 490
Have you tried replacing the over voltage Relay? It provides the power to the fuel pump relay relay.
__________________
Jim Villers
190SL, 230SL 5-speed, 95 E320 Wagon, 01 E320 Wagon, MGB, Boxster 'S', 190SL "Barn Find"
Reply With Quote
  #3  
Old 05-06-2005, 12:18 PM
shawncisco
Guest
 
Posts: n/a
No, I haven't tried replacing that. In fact I've never heard of it. Where is it located?
Reply With Quote
  #4  
Old 05-06-2005, 12:59 PM
Registered User
 
Join Date: May 2005
Posts: 4
side by side with the fuelpump rele. (With a10A fuse on top)
Reply With Quote
  #5  
Old 05-10-2005, 01:42 AM
shawncisco
Guest
 
Posts: n/a
balkpark, about how much dose it run
Reply With Quote
  #6  
Old 05-10-2005, 02:09 AM
carson356
Guest
 
Posts: n/a
ov relay

i have a new one in the box, i believe it will fit your car, it is the newest version, send me an email if interested
Reply With Quote
  #7  
Old 05-16-2005, 09:08 AM
shawncisco
Guest
 
Posts: n/a
Thanks but I think I got it figured out. I swapped the pumps back around and it seems to be running fine now, or at least as good as it was before the fuel pump went south.
Not sure exactly why switching them around makes a difference being that there supposed to be exactly the same, but it's working so I'll leave it alone.
thanks for the advice
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
fuel pump relay bypass? Jim LaFevers Tech Help 1 07-25-2004 12:22 PM
Where's the fuel pump relay on 88 190e? mgriff1969 Tech Help 5 07-14-2004 08:16 AM
location of 73 280 sel 4.5 fuel pump relay? thombenz Tech Help 1 04-10-2004 07:18 AM
fuel pump relay expert needed for 87 420 RKreutzer Tech Help 15 03-18-2003 05:43 PM
Need help with fuel pump relay wireing xp190 Tech Help 0 12-30-2002 04:27 PM



All times are GMT -4. The time now is 01:17 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page