Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 01-04-2001, 02:06 AM
Registered User
 
Join Date: Nov 2000
Location: Houston, TX, USA
Posts: 185
Hello everyone...

A while ago (year or so) i had the heater core in the car changed. Ever since, the buttons associated with the AC on the dash are no longer lighted. The other night, I noticed they happened to be working, but as soon i pressed one of the buttons, the lights in the buttons went off again. Anybody know what it could be? I thought the light bulbs inside the unit all burned out until i saw the lights on the other night. The plugs behind the unit are secure, i've checked. Thanks in advance.....

Peter
__________________
Peter Balias
pbalias@hotmail.com
1992 400E
http://albums.photopoint.com/j/View?...103&p=46824109
Reply With Quote
  #2  
Old 01-04-2001, 09:13 AM
Moderator
 
Join Date: Mar 1999
Location: Tucker, Ga USA
Posts: 12,153
In the a/c pushbutton itself there are 2 bulbs, remove wood trim to replace them.
Reply With Quote
  #3  
Old 01-04-2001, 07:00 PM
J.HIDALGO's Avatar
Registered User
 
Join Date: Jul 1999
Location: Jax, FL
Posts: 1,785
Do a search on the subject! This is the easy way to replace them. After you remove the wood trim, you will see two holes cover with aluminum foil. Inside each hole, there is a light bulb. I use any rubber hose to twist and "catch" the light bulbs and remove/insert the old/new light bulbs. Obviously, buy 2 light bulbs BEFORE removal and get appropiate diameter rubber hose. Good luck!
__________________
J.H.
'86 300E
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
new 500e Ryan Featured Cars 4 01-27-2010 05:30 AM
European 400E specs and questions DangerMouse Tech Help 8 03-31-2004 11:06 PM
Some console buttons don't light up now DieselHead Diesel Discussion 5 10-03-2002 03:41 PM
400E diag codes bourman Tech Help 4 12-30-2001 04:17 PM
What does 400E first gear start relay do? carman850 Tech Help 7 12-05-2001 07:08 PM



All times are GMT -4. The time now is 07:24 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page