Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 01-10-2001, 02:43 PM
Registered User
 
Join Date: May 2000
Posts: 317
Made the appt. to have the diagnostic check done on my car(rough idle still),Jan.22,at (Souverign MBZ,Bklyn,NY),dealer said because of the year and the history of these cars it's a 4 to 5 hr. job and I'm looking at $400. to $500. Does this sound right? I don't know, sounds awfully high AND this doesn't include actually FIXING the d**n car.
__________________
Richie
1986 300E
Reply With Quote
  #2  
Old 01-10-2001, 09:14 PM
JCE's Avatar
JCE JCE is offline
Down to the Wear Bars
 
Join Date: May 1999
Location: So Kalifornia
Posts: 2,189
Damn Richie, for that kind of time and money you could almost have a major tune done! When mine was idling a little rough, my tech carged me for a spark plug wire connector and 1 hour diagnosis - problem fixed. I'd take it to a good independent first.
Before I gave the dealer that kind of $$$ I would check the search button on rough idle and see what others found. I would be inclined to check plugs, cap and rotor, plug wires and connectors, fuel filter, and O2 sensor, and fuel pump if all else failed.

Good luck!
__________________
John

2003 Firemist Red/grey leather SL 500
2015 Palladium Silver/black mbtex GLK 350
1987 Smoke Silver/burgundy mbtex 300E Sportline (SOLD)

Click to see 87 300E
Reply With Quote
  #3  
Old 01-10-2001, 09:38 PM
dtanesq's Avatar
Registered User
 
Join Date: Oct 2000
Location: Northern California/Western Washington
Posts: 386
How rough is it? We have the same model year. Mine stumbles through idle, but it's very subtle and not much of a problem. I second what JCE suggested that you check. In addition, you may also have the original injectors (like mine) which apparently don't like premium gasolines as they are currently formulated. There is a thread in which I discussed what my tech told me about rough idle in my 300E and what I tried (regular instead of premium) as an experiment. Do a search under my username and you'll find that thread. The guy who started that thread said that his injectors were replaced and ultimately the fix on his was as simple as JCE's (as I recall). If your idle is REALLY bad then I may be running off without my mouth connected anywhere sanitary and I apologize.
__________________
David

His:
2003 Dodge Durango SLT
2002 BMW E39 530i Sport
1988 Mercedes 300TE
Hers:
2003 Chevrolet Suburban
1999 E430
Reply With Quote
  #4  
Old 01-10-2001, 10:14 PM
Registered User
 
Join Date: Mar 1999
Location: Suwanee, GA, USA
Posts: 4,712
If they quoted you this over the phone, they are scared of it because it is old.

Beware. I would use a KNOWN GOOD independent.
__________________
Benzmac:
Donnie Drummonds
ASE CERTIFIED MASTER AUTO TECHNICIAN
MERCEDES SPECIALIST 11 YRS
Reply With Quote
  #5  
Old 01-10-2001, 10:42 PM
JCE's Avatar
JCE JCE is offline
Down to the Wear Bars
 
Join Date: May 1999
Location: So Kalifornia
Posts: 2,189
David:
Thanks for kicking some of the plaque loose on my Alzheimers. After you mentioned injectors a (dim) bulb came on, and I went out and looked at my service records. The tech that did the plug connector also told me I had a bad injector seal/sleeve. I had him do all the seal/sleeves at the same time. It was $81 parts and labor for the injector seals and sleeves, and $21 for the plug connector. 95% of the roughness gone.

Richie:
For comparison, $400 at my tech was the cost of a complete 60,000 mile service including tune up with new plugs and filters, and trans/power steering fluid and filters, diff lubrication replacement, oil and filter change, lube of sunroof, doors, hood, adjustment of fuel mixture, etc etc etc. $400 to just to look at it is a rip! (IMHO)
__________________
John

2003 Firemist Red/grey leather SL 500
2015 Palladium Silver/black mbtex GLK 350
1987 Smoke Silver/burgundy mbtex 300E Sportline (SOLD)

Click to see 87 300E
Reply With Quote
  #6  
Old 01-11-2001, 01:10 AM
Registered User
 
Join Date: May 2000
Posts: 317
Thanks guys

THIS QUOTE WAS IN PERSON!!I GUESS I LOOK LIKE JOE NECKBONE! They actually wanted to push my appt. up to tomorrow. NO THANKS!! Have just put new Beru wires on, idle cleared up alittle, tomorrow will try new plugs. Everything else mentioned was just changed. There was an independent shop suggested to me, but I figured why not give the dealer a shot. NOT! I guess I'll try the independant shop after all. My brother laughed and said,"I told you Mercedes was expensive". Yeah, but not that expensive.

dtanesq: other than the occasional stumble when idling, the car runs great(to me anyway). I believe that they are the original injectors,not 100% sure though.

Forgot to add, the dealer believes it might even turnout to be an electrical wiring problem. For $400/$500, they might as well do the whole harness.

[Edited by rich30769 on 01-11-2001 at 12:42 AM]
__________________
Richie
1986 300E
Reply With Quote
  #7  
Old 01-15-2001, 05:16 PM
Registered User
 
Join Date: Jan 2001
Location: Cedar Rapids, Iowa
Posts: 63
rough idle

My 420 SEL just went through a major surgery as a result of the timing chain follower deal. After initial startup, the check engine light came on and they changed the O2 sensor. Now I have severe rough idle and at 75 can feel it in the wheel. I hope the solutions I've seen suggested to your problem work for me. The shop immediately wanted to replace the fuel distributor. Thanks. BTY, is the lambda harness just a "T" or does it have components in it? And will a digital multimeter work or does it have to be analog?
__________________
Gregga
'89 420 SEL "Moby Dick"
'30 Ford Coupe
'31 Ford Slant Windshield Town Sedan
'33 Ford Pickup
'34 Ford Pickup
'01 Honda Passport
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
'91 300E 3.0 check engine light, code 17, after 02 sensor replacement kristian85 Tech Help 1 07-16-2004 12:40 PM
93 300E, 3.2L Engine Surge jeffandmaria Tech Help 1 07-10-2004 02:00 PM
1991 300E Diagnostic Eiknujrac Tech Help 7 05-20-2004 10:00 AM
300E Engine Serial Numbers: decrypt please asiamood Tech Help 5 04-28-2003 03:07 PM
rpm surges on idling- 300E 1993- 104 engine bencarol Tech Help 1 09-06-2001 10:18 PM



All times are GMT -4. The time now is 07:33 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page