Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help



Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 06-13-2005, 04:54 AM
Registered User
 
Join Date: May 2005
Location: Cape Town
Posts: 6
1993 w124: aircon works, heater does not

Has anybody had this particular problem? My '93 280E has no heat. The aircon seems to be working just fine, but it's mid winter here in Cape Town and I nearly froze to death on my way to work this morning.

Just bought the car at an absolute premium because of low mileage and pristine looks so I'm hoping there's a cheap fix for this.

Reply With Quote
  #2  
Old 06-13-2005, 07:22 AM
Registered User
 
Join Date: Oct 2004
Location: Baton Rouge La
Posts: 2,632
monovalve.

cylinder looking item... passenger side....closer to firewall.... unscrews with two screws if you can get one from a junk yard....

The whole contraption new is about 100 bucks... I have heard there is a repair kit., however. I have an extra one...but it's used.
__________________
1989 300ce 129k
( facelifted front,updated tail lights, lowered suspension,bilstein sports, lorinser front spoiler, MOMO steering wheel, remus exhaust,stainless steel brake lines). (Gone)

1997 s320 154k (what a ride). Sold with 179k miles. Replaced with Hyundai Equus

1994 e320 Cabriolet 108k



1972 280se 4.5 153k Owned for 12 yrs, sorry I sold it


[/SIGPIC]
Reply With Quote
  #3  
Old 06-13-2005, 07:51 AM
Registered User
 
Join Date: May 2005
Location: Cape Town
Posts: 6
Thanks - that makes sense. I will give it a shot on the weekend.
__________________
1993 280E

-------------
Past Mercs:
1988 200
1984 230E
1977 350 SE
Reply With Quote
  #4  
Old 06-13-2005, 10:11 AM
Registered User
 
Join Date: Jun 2000
Location: Plano, TX
Posts: 2,574
This is a first, I've never heard this complaint about a 124 before. Everyone always complains the aircon doesn't work, and/or the heater works too well!

I'll second the monovalve recommendation. The monovalve is normally open - power is applied to close it and block the flow of coolant to the heater core. When something fails, normally the monovalve stays open and cooks the occupants of the vehicle. I suppose it could have stuck closed, just never heard of this failure mode before.

South Africa is right hand drive, correct? On left hand drive cars the monovalve is between the two firewalls, in front of the battery. I'm not familiar with the underhood layout of right hand drive versions of the 124, so it may or may not be in the same location.

- JimY
Reply With Quote
  #5  
Old 06-13-2005, 10:15 AM
Registered User
 
Join Date: Oct 2004
Location: Baton Rouge La
Posts: 2,632
it's happened to me , thats how I know.
__________________
1989 300ce 129k
( facelifted front,updated tail lights, lowered suspension,bilstein sports, lorinser front spoiler, MOMO steering wheel, remus exhaust,stainless steel brake lines). (Gone)

1997 s320 154k (what a ride). Sold with 179k miles. Replaced with Hyundai Equus

1994 e320 Cabriolet 108k



1972 280se 4.5 153k Owned for 12 yrs, sorry I sold it


[/SIGPIC]
Reply With Quote
  #6  
Old 06-13-2005, 11:04 AM
Registered User
 
Join Date: May 2005
Location: Cape Town
Posts: 6
Took a quick drive to the store just now and thought I'd try the heater again. I noticed very moist warm air coming out the driver side vent but as soon as I upped the blower speed the heat dissapeared. Does that stroke with the monovalve scenario?

This problem is new to me too - had the opposite dilemma on both my previous 124's. The car is a RHD - I've downloaded a pic of LHD engine and will compare layout this evening.

Thanks for all the input so far!

__________________
1993 280E

-------------
Past Mercs:
1988 200
1984 230E
1977 350 SE
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
1993 mercedes 190e 2.3 heater problem roberto Tech Help 4 03-04-2004 02:39 AM
Heater problems 280SEL gedeonbgjr Tech Help 0 02-05-2003 06:51 PM
300SD Heater Woes Fixed! Inter911 Diesel Discussion 3 12-02-2002 08:38 PM
heater only works on max? mdlwolf Diesel Discussion 2 11-27-2002 08:51 AM
87 190E heater only works when accelerating jgnagy Tech Help 1 02-08-2002 08:57 PM



All times are GMT -4. The time now is 06:15 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2024, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2024 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page