Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 06-19-2005, 05:18 PM
lamathis
Guest
 
Posts: n/a
Question Need help with an 87 sel 420 that won't start

My dad has tried everything that he could think of to fix his car he changed the ignition coil and the ingition control module and it still will not start. Can someone help to troubleshoot this problem. It was running fine about a month ago but then it stopped and has not started since then.
Reply With Quote
  #2  
Old 06-19-2005, 07:45 PM
MikeTangas's Avatar
Senior Member
 
Join Date: Apr 2000
Location: So. Cal
Posts: 4,430
Did it stop suddenly while running?

You should probably pull the left valve cover to ensure the cam, chain and upper rails are intact. Almost every 4.2 I have seen that had jumped the chain also broke the left cam ( granted I have only seen a handful though).
__________________
Mike Tangas
'73 280SEL 4.5 (9/72)- RIP
Only 8,173 units built from 5/71 thru 11/72

'02 CLK320 Cabriolet - wifey's mid-life crisis

2012 VW Jetta Sportwagon TDI...at least its a diesel

Non illegitemae carborundum.
Reply With Quote
  #3  
Old 06-19-2005, 07:49 PM
Smokiesman's Avatar
Bryson City NC
 
Join Date: Mar 2005
Posts: 182
Sure it is a electrical problem???

Smokie
Reply With Quote
  #4  
Old 06-19-2005, 10:31 PM
jdc1244's Avatar
Read Only
 
Join Date: Apr 2003
Location: Lakeland, FL
Posts: 170
Did you check the fuel pump and pump relay?
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
1987 420 sel no start benzboy Tech Help 4 01-13-2005 11:40 AM
1988 420 sel no start JCAUTOWRKS Tech Help 7 10-28-2004 08:29 PM
87 420 sel missing badly after warmup denismitchell Tech Help 14 04-01-2004 02:29 AM
Starting problems '87- 420 SEL Berolina Tech Help 11 06-10-2003 06:35 PM
420 SEL - Check Engine Light Codes Needed. rsamson830 Tech Help 1 10-30-2001 08:34 PM



All times are GMT -4. The time now is 02:53 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page