Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 06-23-2005, 03:01 PM
cradical
Guest
 
Posts: n/a
fuel injection prob

i have a 1980 merc 280se, or 126D europian manufactured.
when i push on the gas the rpm will go up slightly then the engine bogs down
and the rpm drop below 400. the vehical starts, and idles ok, it's just when I
push on the gas. and if I put in gear it will run... but only at about 5 mph. does anyone have any ideas?
Reply With Quote
  #2  
Old 06-23-2005, 09:35 PM
cradical
Guest
 
Posts: n/a
I'd really appreciate any help/advice any of you can give me with this problem. This car is my daily driver, and it's been a real inconvenience having it out of commission like this. Please let me know if you need further info to help with a diagnosis. Thanks in advance!
Reply With Quote
  #3  
Old 06-23-2005, 11:11 PM
simmo300e's Avatar
Registered User
 
Join Date: Jun 2004
Location: Bali, Indonesia
Posts: 200
what engine is it?
__________________
1987 300e manual 250,000 km (sold)
Reply With Quote
  #4  
Old 06-23-2005, 11:42 PM
cradical
Guest
 
Posts: n/a
It's an in-line 6.
Reply With Quote
  #5  
Old 06-24-2005, 12:24 AM
simmo300e's Avatar
Registered User
 
Join Date: Jun 2004
Location: Bali, Indonesia
Posts: 200
Well, that's a start. That means its probably an M110 engine, check your VIN and see. The engine number will start with either 110.987 or 110.989

Don't know what the difference is but I do know there are a number of fuel injection systems used with that engine, find out which one you have and do a search. Plenty of information in this forum if you can be a bit more specific.

good luck
__________________
1987 300e manual 250,000 km (sold)
Reply With Quote
  #6  
Old 06-29-2005, 07:57 PM
cradical
Guest
 
Posts: n/a
Sorry for the delay in getting this info:

The number on the driver's side engine block is 1100111101.

The car has been timed/tuned properly, has new rotor, dist. cap, plugs & wires, new fuel pump & filter, and a new air filter.

Again, any help with diagnosing this problem will be GREATLY appreciated!
Reply With Quote
  #7  
Old 06-29-2005, 08:05 PM
Ta ra ra boom de ay
 
Join Date: Jun 2004
Location: Pittsburgh
Posts: 1,915
Do you have a 'fuel economy' gage?

(intake manifold vacuum)... and what is it doing while the engine sputters?
__________________
-Marty

1986 300E 220,000 miles+ transmission impossible
(Now waiting under a bridge in order to become one)

Reading your M103 duty cycle:
http://www.peachparts.com/shopforum/831799-post13.html
http://www.peachparts.com/shopforum/831807-post14.html
Reply With Quote
  #8  
Old 06-29-2005, 08:53 PM
cradical
Guest
 
Posts: n/a
it stays just a little bit before the halfway mark, but will go as far as the halfway mark as the needle shakes a little.
Reply With Quote
  #9  
Old 06-29-2005, 09:15 PM
Ta ra ra boom de ay
 
Join Date: Jun 2004
Location: Pittsburgh
Posts: 1,915
I was thinking vacuum leak but that doesn't ring any bells in my limited personal experience.

Have you considered getting the fuel pressure tested?
__________________
-Marty

1986 300E 220,000 miles+ transmission impossible
(Now waiting under a bridge in order to become one)

Reading your M103 duty cycle:
http://www.peachparts.com/shopforum/831799-post13.html
http://www.peachparts.com/shopforum/831807-post14.html
Reply With Quote
  #10  
Old 06-29-2005, 09:18 PM
Registered User
 
Join Date: Jun 2005
Posts: 89
does that model have a fuel accumulator like the 450s?
they're known to go bad an impact fuel pressure.

on my recent purchase of a 76 450sl, it ran terrible (and barely)
when I got it. fuel system was all gunked up from neglect, etc.

a few bottles of Techron in the fuel system really did wonders.
I still have work to do but cleaning up the delivery system helped
a lot, and was easy.
Reply With Quote
  #11  
Old 06-30-2005, 12:21 AM
simmo300e's Avatar
Registered User
 
Join Date: Jun 2004
Location: Bali, Indonesia
Posts: 200
sounds like bad mixture to me, which culd be for a number of reasons, gunk in the system being just one.

what sort of fuel injection system is it?
__________________
1987 300e manual 250,000 km (sold)
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
240D Top Speed ? Benz240D Diesel Discussion 73 07-04-2011 12:48 PM
16v Fuel Injection Problem crbnfbr Tech Help 3 12-05-2003 05:24 PM
fuel injection problems bad122452 Tech Help 0 08-05-2003 09:25 PM
1973 fuel injection problem thombenz Vintage Mercedes Forum 2 07-31-2003 10:41 AM
190e Fuel injection ? richbark Tech Help 3 05-28-2002 02:43 PM



All times are GMT -4. The time now is 10:26 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page