Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help



Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 06-29-2005, 12:41 AM
Registered User
 
Join Date: Jun 2005
Posts: 14
84 190D ignition cylinder problem?

Hello, i just bought a 190D and i was wondering if maybe i have bad ignition key cylinder problem. I've had the car for about 3 days and i took it to work today...i work at a shop.. and i put it on my lift. Upon completing an inspection on it i go to start the vehile and nothing... no crank. Feels like kind of the ignition key cylinder is not letter me turn all the way to the start position... i can get it to run and everything else. The key is not stuck in the ignition and it comes out every time. I had to jump the solenoid on my starter to get it running back from work. The vehicle was fine for the first three days...had no problem starting it. I was wondering what parts i would need and the procedure for removing and installing these parts. Thanks.

Reply With Quote
  #2  
Old 06-29-2005, 02:07 AM
compress ignite's Avatar
Drone aspiring to Serfdom
 
Join Date: Feb 2004
Location: 32(degrees) North by 81(degrees) West
Posts: 5,554
ignition lock cylinder

'no experience with the 190's

'first and most dreadful thought is that your lock cylinder is trying to go south
on you.

If your assessment of the lack of final start position attainment is correct;
order a new lock cylinder from a "stealership" with your V.I.N. (about $80
,comes with one new key)and do a search here for the proceedure.

If the cylinder goes bad and you are unable to achieve position #1 with
your key(and insert correct diameter wire to release cylinder)
you will have avery unhappy ,expensive day.
Reply With Quote
  #3  
Old 07-01-2005, 12:56 AM
kamil's Avatar
Rutgers University
 
Join Date: Feb 2004
Location: North Jersey
Posts: 1,310
anybody else know ?

__________________
Audi TT
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Help 86 300E ignition problem jmyers177 Tech Help 4 01-23-2005 11:24 PM
ignition lock problem, help please!!! mercedesmatt Diesel Discussion 6 04-29-2004 12:31 PM
Ignition Problem On '91 300TE Wagon Andrew Freimuth Tech Help 3 12-24-2002 01:08 AM
1984 190d transmisson problem leganza Diesel Discussion 1 05-13-2002 03:32 PM
1984 380SE ignition problem has stumped us dwight hinton Tech Help 3 02-26-2001 01:17 PM



All times are GMT -4. The time now is 01:18 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page