Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 01-15-2001, 11:10 PM
jc300e's Avatar
Registered User
 
Join Date: May 2000
Location: Location: Norcross, GA
Posts: 124
I recently replaced my oil psi sending unit on my '92 400E. Seemed to work great. Now, I have a strange problem.

When I turn the key to "on" position, the guage immediately jumps to "3". When the car is a running temp and I am at idle or slowing down to idle, the guage measures oil psi properly. As soon as I come to a complete stop with brake applied, the guage jumps to "3". Upon release of brake and slight excelleration, the guage drops sightly and begins to read psi.

If I am at idle and the car is in "P", the guage works fine.

Is there a voltage problem or short somewhere?

I installed an OEM sending unit (FYI)...wiring at the unit was quite simple. I can't imagine that I screwed that up.

Comments and advice is appreciated
__________________
Jeff
'87 300E
'92 400E
'06 ML350
Reply With Quote
  #2  
Old 01-16-2001, 09:04 AM
Moderator
 
Join Date: Mar 1999
Location: Tucker, Ga USA
Posts: 12,153
Loose connector or slight break in wiring. Open circuit will cause the gauge to read 3bar.
Reply With Quote
  #3  
Old 01-16-2001, 07:11 PM
MBenzNL's Avatar
MBenzNL
 
Join Date: Jan 2001
Location: the Netherlands
Posts: 1,417
Can be the oil psi sending unit as well..
I have replaced the sender on my 190D by a new MB sender once. After about 3 months and a trip of 100km flat out my gauge went down to 0 while I stood in front of a traffic light (can you imagine the look on my face...).
I turned down the window to hear the engine, but it still sounded like the oil pressure was good.

It took me a new oil-pump and oil-filter housing before I found out that the sending unit was BAD. Normally when the sender is broken or the cable is disconnected (partly or total) the gauge will go directly to 3 when the ignition key is turned on.

greetingz,
__________________
1990 300SL-24
1993 C250D
with a minor 600+k kilometer
www.MBenzNL.com
(the Netherlands)
Reply With Quote
  #4  
Old 01-18-2001, 09:24 PM
jc300e's Avatar
Registered User
 
Join Date: May 2000
Location: Location: Norcross, GA
Posts: 124
It jumps to 3 upon ignition "on" position. Then, when the engine cranks, it drops toward 0 and immediately returns to 3 with oil psi.

It's quite interesting to watch the guage at operating temp at a stop light. With Brake applied, it quivers at 3. As soon as I release the brake and begin a slow accel, the gauge drops to 1 and begins it accent to 3 with psi...

I am gonna re-check my wiring connection at the sending unit this weekend.

Can anyone give me a tip as to where the wire terminates on the other side?

Thanks
__________________
Jeff
'87 300E
'92 400E
'06 ML350
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
The joys and sorrows of removing oil cooler lines dmorrison Diesel Discussion 22 02-11-2016 11:58 AM
Problem: The oil pressure light stays on toka Tech Help 4 11-22-2008 05:44 PM
The oil debate again What do you think of this dpbrowne Diesel Discussion 101 04-01-2005 03:33 PM
Black Oil...a Diesel thing? acastell Diesel Discussion 12 12-15-2003 06:27 PM
Oil Change Frequency mrbroche Tech Help 34 06-01-2001 12:03 AM



All times are GMT -4. The time now is 06:08 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page