Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help



Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 07-07-2005, 11:10 PM
shawncisco
Guest
 
Posts: n/a
95 C280,new plugs, good wires, OVP ok, still runs horrible

I am stumped now, I'v eput new plugs in the car, I didn't replace the ignition wires but they look good and I see no sparks when sprayed with a fine mist of water at night, the OVP sensor is the upgraded part #.
And the car is running progressivley worse. It used to run ok if you restarted the engine. now that only seem so work for a minute or so.
How do I go about retrieving the trouble codes for the car. Or is there other parts that should be replaced?
Any advice on what could be making the car run so bad? Please!

Thanks
Shawn

Reply With Quote
  #2  
Old 07-07-2005, 11:19 PM
Registered User
 
Join Date: Aug 1999
Location: Florida / N.H.
Posts: 8,804
Don't assume the OVP is Ok just cuz it is the new style.. they still go bad

When your car is running like crap, go tap the OVP with a few light taps with a screwdriver handle and see if the engine responds..

How is the harness ?
..and the mist trick does nothing to show the connectors under the coils that are notorious..
Reply With Quote
  #3  
Old 07-08-2005, 06:32 AM
shawncisco
Guest
 
Posts: n/a
Tapping the OVP while the car is missing did get some response. Although only for a second or two. So does this mean that the OVP is bad?
When I take the cover off the OVP part of the board is discolored, looks almost burned. Can these be fixed or should I just replace it?
Reply With Quote
  #4  
Old 07-08-2005, 09:20 AM
Registered User
 
Join Date: Aug 1999
Location: Florida / N.H.
Posts: 8,804
Replace is best with HFM cars

..and what did you dp about the plug connectors under the coils?
..As you just changed plugs, I Do hope you took the advice of F8DC4..
Reply With Quote
  #5  
Old 07-08-2005, 03:43 PM
Registered User
 
Join Date: May 2000
Location: Greenville, NC
Posts: 533
do like arthur dalton said and tap ovp with screwdriver while running crappy. on my w124 1993 i had an abs light, crappy idle and a/c. when i taped on old ovp it started to worked fine if only until next start up.

ordered a new ovp from www.*************** for $62 (KAE), no more abs light, runs great and a/c works.
__________________
1993 Mercedes Benz 300D 2.5 205K (ex wife's)
1984 Mercedes Benz 300SD 320K (SOLD)
2004 Mercedes Benz C240 75K
1995 GMC Sierra 2WD 5.7L 188K
1983 Mercedes Benz 300SD 239K (SOLD)
1987 BMW 325i 220K (SOLD FOR SALVAGE)

609 Certification
Reply With Quote
  #6  
Old 07-08-2005, 11:09 PM
shawncisco
Guest
 
Posts: n/a
Ok, I'm starting to loose my patients with this car. I put a new OVP relay in the car today, and still no difference. The one thing I haven't replaced is the spark plug connectors under the coils, which I will do later tonight or tomorrow. But the car is missing so bad that at times you can't accelorate from a dead stop because of the missing and backfireing.
The plug connectors are all that is left to replace from the list of things that usually cause these problems. According to the post I've recieved.
Is it possible that the plug connectors could cause the car to run as badly as it is running? When I looked at them they don't appear to look burnd or discolored.
Reply With Quote
  #7  
Old 07-08-2005, 11:33 PM
Registered User
 
Join Date: May 2000
Location: Greenville, NC
Posts: 533
has the engine wiring harness been replaced/updated to the non-biodegradable one?
__________________
1993 Mercedes Benz 300D 2.5 205K (ex wife's)
1984 Mercedes Benz 300SD 320K (SOLD)
2004 Mercedes Benz C240 75K
1995 GMC Sierra 2WD 5.7L 188K
1983 Mercedes Benz 300SD 239K (SOLD)
1987 BMW 325i 220K (SOLD FOR SALVAGE)

609 Certification
Reply With Quote
  #8  
Old 07-08-2005, 11:42 PM
shawncisco
Guest
 
Posts: n/a
I don't know if the wireing harness has been replaced or not, I didn't get any records with the car. Can you tell the difference between the two by looking at them? The harness on the car right now dosn't looked cracked anywhere.
Reply With Quote
  #9  
Old 07-09-2005, 08:49 AM
Johnhef's Avatar
Senior Member
 
Join Date: Feb 2005
Location: Frederick, Md
Posts: 4,540
If your harness is hard as a rock or splitting anywhere else on the engine I'd suspect that. Look close at the plugs on the valves at the front of the head and at the two connectors on the thermostat housing. If still ok there, slice open one of the coverings to a coil (where it bends) and inspect the wires inside the covering for cracking.

Also don't rule that you might have a bad coil(s).

__________________


1980 500SE/AMG Euro
1981 500SEL Euro
1982 380SEL
1983 300TD
1983 500SEC/AMG Euro
1984 500SEC
1984 300TD Euro
1986 190E 2.3-16
1986 190E 2.3
1987 300D
1997 C36 AMG
2003 C320T 4matic

past: 1969 280SE 4.5 | 1978 240D | 1978 300D | 1981 300SD | 1981 300SD | 1982 300CD | 1983 300CD | 1983 300SD | 1983 380SEC | 1984 300D | 1984 300D | 1984 300TD | 1984 500SEL | 1984 300SD | 1985 300D | 1986 300E | 1986 560SEL | 1986 560SEL/Carat | 1987 560SEC | 1991 300D 2.5 | 2006 R350
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Help!! Need OVP plug schematic! Cap'n Carageous Tech Help 63 12-30-2008 05:16 PM
Ignition Wires -ANY Good Aftermarket Sets? Strife Mercedes-Benz SL Discussion Forum 4 05-07-2004 05:04 PM
300E runs good ...then starts to miss. mike690003 Tech Help 0 09-03-2003 05:53 PM
Rough Start - Good Plugs and Relay mccan Diesel Discussion 6 06-12-2003 07:32 PM
runs good, mileage bad 79 300sd angst Diesel Discussion 6 02-11-2002 03:39 PM



All times are GMT -4. The time now is 07:05 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page