Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 01-27-2001, 12:26 PM
Registered User
 
Join Date: Jan 2001
Location: NY(work)/NJ(live)
Posts: 12
91 560 SEL rides like a haywagon. I had the accumulators
replaced with no difference what so ever. What direction can I give to repair shop so that can get it right on the third try? The hydraulic oil reservoir is only half full. The shop claims they filled it on the first visit ( 3 liters ).
What other moving parts are there to replace to smooth the ride?

Thanks for any suggestions.
I already know that this is the last thing
I will ever have this place fix.
Jim
Reply With Quote
  #2  
Old 01-27-2001, 02:03 PM
BlackE55
Guest
 
Posts: n/a
Jim,

I had this same problem a month ago on my '91 560 SEL (101K miles). Accumulators were deemed fine, but the rear shocks were shot. If you rode in the back, it was bone jarring. I had OEM replacement shocks installed (Bilstein) and all is well. An expensive part, from the dealer around $370, but you can find them $100 cheaper from
Rear seat had to be removed -- so there is at least 3 hrs. labor invloved (I had the hydraulic system bled and new skins put on.)

Hope this helps,
Reply With Quote
  #3  
Old 01-27-2001, 09:38 PM
Registered User
 
Join Date: Nov 1999
Location: Germany
Posts: 63
I have a 420 SEL so I don't have the hydraulic rear suspension, but concur with benefits of new rear shocks - just had all four replaced. Did you pay $370 for just the rear ones (installed), or was that for all four?

JoeB
Reply With Quote
  #4  
Old 01-28-2001, 11:51 AM
BlackE55
Guest
 
Posts: n/a
Joe,

$370/each (MB Dealer). BUT, that's only for the 560 SEL -- different shock from the 420 since it has the self-leveling suspension. That's just the cost for the part, not labor. Yeah, ouch is right!

Regards,
Reply With Quote
  #5  
Old 01-28-2001, 02:34 PM
MikeTangas's Avatar
Senior Member
 
Join Date: Apr 2000
Location: So. Cal
Posts: 4,430
Check the price of Bilsteins (OE) and Boge (AM) right here at the PartsShop. You might be suprised.
__________________
Mike Tangas
'73 280SEL 4.5 (9/72)- RIP
Only 8,173 units built from 5/71 thru 11/72

'02 CLK320 Cabriolet - wifey's mid-life crisis

2012 VW Jetta Sportwagon TDI...at least its a diesel

Non illegitemae carborundum.
Reply With Quote
  #6  
Old 01-30-2001, 07:20 PM
Registered User
 
Join Date: Jan 2001
Location: NY(work)/NJ(live)
Posts: 12
Thanks to all who responded! Your help is very appreciated!
After this problem is addressed, I'll be posting other issues for your diagnostic enjoyment.

Jim
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
126 rear suspension - done! gidpor Tech Help 8 01-21-2005 11:54 AM
Rear suspension strut replacement help. davidmash Tech Help 2 06-28-2004 06:24 PM
rear suspension w123 replace rear trailing arm nibiru Diesel Discussion 1 06-27-2004 09:35 AM
question about 300E rear suspension part WANT '71 280SEL Tech Help 2 06-10-2004 08:43 PM
rear suspension josev Tech Help 11 11-20-2002 11:57 PM



All times are GMT -4. The time now is 09:14 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page