Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 02-02-2001, 10:01 PM
63230slbenz
Guest
 
Posts: n/a
Have 1963 230sl that was in storage several years. Brake pedal seems to be "hard" (no feel), and when applying the brakes, they hang up. This goes away several hours after shutting the car off. I replaced a rear brake cylinder (was leaking slightly), thinking that was the problem, but I can't bleed the rear cylinder; no fluid comes out when applying pressure to the pedal.
Think I need a new master cylinder? If so, know where to get a good deal on one?
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Move Over Enzo, Guess Who Is Getting Carbon Brakes? MTI Off-Topic Discussion 4 09-02-2004 05:59 AM
Humming/high pitched noise, stops when brakes applied RKreutzer Tech Help 0 08-06-2003 07:43 PM
Brakes are going nuts!! HELP!!! mike690003 Tech Help 6 07-20-2003 11:56 PM
'63 230sl Brakes 63230slbenz Tech Help 7 07-15-2001 05:52 PM



All times are GMT -4. The time now is 04:35 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page