Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help



Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 11-02-2005, 10:11 AM
HUD HUD is offline
Registered User
 
Join Date: Feb 2003
Posts: 27
Sun Roof Relay Location For '87 300TD?

The sun roof on my '87 300 TD does not operate. I can hear the motor running but nothing happens. I am looking into replacing the sun roof relay but I do not know where it is located.Any help would be appreciated.

Reply With Quote
  #2  
Old 11-02-2005, 10:21 AM
Col.Klink
Guest
 
Posts: n/a
If the motor runs all the time then the switch is stuck ;if on the other hand you hear it running when you activate it and the roof does not move then the clutches are most likely slippimg it the mechanism in rear of car and can sometimes be adjusted by turning the the outer nut clockwise a round or less.
Reply With Quote
  #3  
Old 11-02-2005, 10:26 AM
HUD HUD is offline
Registered User
 
Join Date: Feb 2003
Posts: 27
Sun Roof Relay Location For '87 300td?

Thanks for the suggestions. I have already tried that. Will turn manually,but when I try to open with switch nothing happens. Do you know where relay is locted?
Reply With Quote
  #4  
Old 11-02-2005, 10:48 AM
Col.Klink
Guest
 
Posts: n/a
I do not know where or if it has a relay but if the motor is working when you use the switch the relay is not your problem but the Clutches in the gearbox and yes you will be able to open it with the tool but the tool bypasses the part I am talking about . I will look for a diag. or maybe some one else will chime in here with one.
Reply With Quote
  #5  
Old 11-02-2005, 10:51 AM
Registered User
 
Join Date: Jun 2000
Location: Plano, TX
Posts: 2,527
There is no relay, the switch is connected directly to the sunroof motor assembly. If the electric motor runs when you activate the switch then your problem is mechanical, not electrical. It's possible you have a problem with the motor assembly, they have been known to fail.

- JimY
Reply With Quote
  #6  
Old 11-02-2005, 10:55 AM
HUD HUD is offline
Registered User
 
Join Date: Feb 2003
Posts: 27
I will check it out again,see if I can find what you are talking about. Thanks for your help.

Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 07:26 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page