Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help



Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 11-20-2005, 11:13 AM
Registered User
 
Join Date: Nov 2005
Posts: 1
26E Electrical meltdown, PIC Added

Hi,
My 87 260e has been giving me fits with its climate control but now it's gotten worse. The other day an electrical part had a total meltdown. It appears to be a relay or fusible link guessing by the very small remains I can see. It was mounted to the top of the drivers side strut tower. The heavy power lead running in one side smoked as well, like a dead short. Now my climate control does nothing at all. I guess this must control the power to the blower. Anybody able to hook me up on exactly what part this is and the likely cause of failure?

Thanks, Brad


Last edited by Bythesea; 11-20-2005 at 05:44 PM.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 03:59 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page