Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 02-14-2001, 11:21 AM
Jim Hughes
Posts: n/a
My wife's '91 300TE has a real rough idle at about 600 RPM while transmission is in DRIVE. It seems to get better when the car is warmed up, but is still rough. It smoothes out when the car is shifted to PARK. Once the RPM is up to 800 or higher, it is smooth as silk.
Reply With Quote
Old 02-14-2001, 09:29 PM
Posts: n/a
I had a like problem on a 86 420 sel, changed the motor mounts (they were flat) and it idles much much better with no shake.
Reply With Quote
Old 02-14-2001, 09:45 PM
David C Klasse's Avatar
CheFrac is Back!
Join Date: Jan 2001
Location: Mission Hills in the City of San Diego
Posts: 2,352
I had the same problem. For me, it was the fuel filter and spark plugs. Hope this helps.
2006 E350 w/ 155k miles (Daily Driver)

1993 300E 3.2L Sedan w/ close to about 300k miles
2003 E500 Brilliant Silver (Had 217k miles when totalled!)
1989 300E with 289,000 miles (had for <1 yr while in HI)
03 CLK 500 cabrio (Mom's)
2006 C230k (Dad's)
1999 S420 (Mom's/Dad's)
2000 C230k Sport sedans
2001 CLK320 Cabrio (Mom's)
1995 C280 My First Mercedes-Benz... (155k miles. EXCEPTIONAL AUTOMOBILE. Was Very hard to let go of!)
Reply With Quote
Old 02-15-2001, 06:15 AM
Registered User
Join Date: Jul 2000
Location: Toronto, CANADA
Posts: 1,193
I have the same problem on my 86 420SEL and have yet to find the cause. Is it especially worse on really really cold mornings? Have your mechanic do w visual inspection of the motor mounts as Tim suggested, it is pretty quick and easy to do. You can also have your ignition system scoped out. That is a process where they use a diagnostic machine to find problems. It could be the plugs, or it could be the sprak plug wire ends (resistor tips) these are cheap and easy to change. Aside from that you could have a fuel mixture that is too rich.
Jason Priest
1999 E430
1995 E420 - retired
1986 420SEL - retired
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Similar Threads
Thread Thread Starter Forum Replies Last Post
W115 rough idle nachi11744 Vintage Mercedes 14 12-05-2003 08:10 PM
my low, rough idle, stall, hot /start solution: E320/300 rvenerac Tech Help 3 11-20-2003 09:59 AM
Could This Be the Root Cause of Rough Idle? EricSilver Tech Help 14 10-16-2003 07:51 PM
240D rough idle - Do I or don't I have rack damper bolt? JohnnyJ Diesel Discussion 8 10-08-2002 08:44 PM
88 300TE: Rough idle, low idle speed atikovi Tech Help 7 05-29-2002 06:43 PM

All times are GMT -4. The time now is 01:48 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page